1 %define cvsdate cvs-snap
2 %define cvsver %(echo %{cvsdate} | tr -d -)
5 Summary: Round Robin Database Tools
10 Group: Applications/Networking
11 Source: http://people.ee.ethz.ch/~oetiker/webtools/rrdtool/pub/beta/rrdtool-cvs-snap.tar.gz
12 URL: http://people.ee.ethz.ch/~oetiker/webtools/rrdtool/
13 Buildroot: /tmp/%{name}-root
16 BuildRequires: cgilib-devel
17 BuildRequires: freetype-devel libart_lgpl-devel libpng-devel zlib-devel
20 It is pretty easy to gather status information from all sorts of things,
21 ranging from the temperature in your office to the number of octets which
22 have passed through the FDDI interface of your router. But it is not so
23 trivial to store this data in a efficient and systematic manner. This is
24 where RRDtool kicks in. It lets you log and analyze the data you gather from
25 all kinds of data-sources (DS). The data analysis part of RRDtool is based
26 on the ability to quickly generate graphical representations of the data
27 values collected over a definable time period.
30 Summary: RRD Tool development libraries and header files
31 Group: Development/Libraries
32 Requires: rrdtool = %{version}-%{release}
35 The RRD Tools development library.
38 Summary: RRD Tool Perl interface
39 Group: Applications/Networking
40 Requires: rrdtool = %{version}-%{release}
43 The RRD Tools Perl modules.
46 %setup -q -n rrdtool-%{cvsdate}
50 ln -s ../mkinstalldirs .
53 %define deffont %{_datadir}/fonts/VeraMono.ttf
54 perl -pi -e 's!^(#define\s+RRD_DEFAULT_FONT\s+).*!$1"%{deffont}"!' src/rrd_graph.c
57 CPPFLAGS="-I/usr/include/libart-2.0 -I/usr/include/freetype2"
59 aclocal > /tmp/aclocal.out 2>&1
70 mkdir -p %{buildroot}%{_datadir}/fonts
71 install -m 644 src/VeraMono.ttf %{buildroot}%{deffont}
73 # Fix up the documentation
74 [ -d docs ] && mv docs docs.src
75 mv %{buildroot}/usr/doc docs
77 [ -d examples ] && mv examples examples.src
78 mv %{buildroot}/usr/examples examples
79 [ -d html ] && mv html html.src
80 mv %{buildroot}/usr/html html
83 %define perlsite %(perl -MConfig -e 'print $Config{"installsitearch"}')
84 mkdir -p %{buildroot}%{perlsite}
85 mv %{buildroot}%{_libdir}/perl/* %{buildroot}%{perlsite}
86 rmdir %{buildroot}%{_libdir}/perl
88 # Fix up the man pages
89 if [ "%{_mandir}" != "/usr/share/man" ]; then
90 mkdir -p %{buildroot}%{_mandir}
91 mv %{buildroot}/usr/man/* %{buildroot}%{_mandir}/
104 %defattr (-, root, root)
105 %doc 00README CONTRIBUTORS COPYING COPYRIGHT ChangeLog NEWS PROJECTS
106 %doc README THREADS TODO examples
107 %doc docs examples html
111 %{_libdir}/librrd.so.%{sover}
112 %{_libdir}/librrd_th.so.%{sover}
113 %{_mandir}/man1/[a-z]*
117 %defattr (-, root, root)
122 %{_libdir}/librrd_th.a
123 %{_libdir}/librrd_th.la
124 %{_libdir}/librrd_th.so
127 %defattr (-, root, root)
130 %dir %{perlsite}/auto/RRDs
131 %{perlsite}/auto/RRDs/RRDs.bs
132 %{perlsite}/auto/RRDs/RRDs.so
133 %{_mandir}/man1/RRDp.1*
134 %{_mandir}/man1/RRDs.1*
137 * Thu Apr 29 2004 Chris Adams <cmadams@hiwaay.net> 1.1.0-0.1.20040430