Added library link check and addressed review comments
[collectd.git] / contrib / sles10.1 / collectd.spec
1 Summary:        Statistics collection daemon for filling RRD files.
2 Name:           collectd
3 Version:        3.11.1
4 Release:        0.sl10.1
5 Source:         http://collectd.org/files/%{name}-%{version}.tar.gz
6 Source1:        collectd-init.d
7 License:        GPL
8 Group:          System Environment/Daemons
9 BuildRoot:      %{_tmppath}/%{name}-%{version}-root
10 BuildPrereq:    curl-devel, sensors, mysql-devel, rrdtool, libpcap
11 Requires:       rrdtool
12 Packager:       Florian octo Forster <octo@verplant.org>
13 Vendor:         Florian octo Forster <octo@verplant.org>
14
15 %description
16 collectd is a small daemon written in C for performance.  It reads various
17 system  statistics  and updates  RRD files,  creating  them if neccessary.
18 Since the daemon doesn't need to startup every time it wants to update the
19 files it's very fast and easy on the system. Also, the statistics are very
20 fine grained since the files are updated every 10 seconds.
21
22 %package apache
23 Summary:        apache-plugin for collectd.
24 Group:          System Environment/Daemons
25 Requires:       collectd = %{version}, curl
26 %description apache
27 This plugin collects data provided by Apache's `mod_status'.
28
29 %package dns
30 Summary:        dns-plugin for collectd.
31 Group:          System Environment/Daemons
32 Requires:       collectd = %{version}, libpcap
33 %description dns
34 This plugin collects information about DNS traffic, queries and responses.
35
36 %package mysql
37 Summary:        mysql-module for collectd.
38 Group:          System Environment/Daemons
39 Requires:       collectd = %{version}, mysql
40 %description mysql
41 MySQL  querying  plugin.  This plugins  provides data of  issued commands,
42 called handlers and database traffic.
43
44 %package sensors
45 Summary:        libsensors-module for collectd.
46 Group:          System Environment/Daemons
47 Requires:       collectd = %{version}, sensors
48 %description sensors
49 This  plugin  for  collectd  provides  querying  of sensors  supported  by
50 lm_sensors.
51
52 %prep
53 rm -rf $RPM_BUILD_ROOT
54 %setup
55
56 %build
57 ./configure --prefix=%{_prefix} --sbindir=%{_sbindir} --mandir=%{_mandir} --libdir=%{_libdir} --sysconfdir=%{_sysconfdir} --localstatedir=%{_localstatedir}
58 make
59
60 %install
61 make install DESTDIR=$RPM_BUILD_ROOT
62 cp src/collectd.conf $RPM_BUILD_ROOT/etc/collectd.conf
63 mkdir -p $RPM_BUILD_ROOT/var/lib/collectd
64 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/*.a
65 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/*.la
66 mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/init.d
67 cp %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/init.d/collectd
68
69 %clean
70 rm -rf $RPM_BUILD_ROOT
71
72 %post
73 chkconfig collectd on
74 /etc/init.d/collectd start
75
76 %preun
77 /etc/init.d/collectd stop
78 chkconfig collectd off
79
80 %files
81 %defattr(-,root,root)
82 %doc AUTHORS COPYING ChangeLog INSTALL NEWS README
83 %doc contrib
84 %config /etc/collectd.conf
85 %attr(0755,root,root) /etc/init.d/collectd
86 %attr(0755,root,root) %{_sbindir}/collectd
87 %attr(0444,root,root) %{_mandir}/man1/*
88 %attr(0444,root,root) %{_mandir}/man5/*
89 %attr(0444,root,root) %{_libdir}/%{name}/apcups.so
90 %attr(0444,root,root) %{_libdir}/%{name}/apple_sensors.so
91 %attr(0444,root,root) %{_libdir}/%{name}/battery.so
92 %attr(0444,root,root) %{_libdir}/%{name}/cpu.so
93 %attr(0444,root,root) %{_libdir}/%{name}/cpufreq.so
94 %attr(0444,root,root) %{_libdir}/%{name}/df.so
95 %attr(0444,root,root) %{_libdir}/%{name}/disk.so
96 %attr(0444,root,root) %{_libdir}/%{name}/email.so
97 %attr(0444,root,root) %{_libdir}/%{name}/hddtemp.so
98 %attr(0444,root,root) %{_libdir}/%{name}/irq.so
99 %attr(0444,root,root) %{_libdir}/%{name}/load.so
100 %attr(0444,root,root) %{_libdir}/%{name}/mbmon.so
101 %attr(0444,root,root) %{_libdir}/%{name}/memory.so
102 %attr(0444,root,root) %{_libdir}/%{name}/multimeter.so
103 %attr(0444,root,root) %{_libdir}/%{name}/nfs.so
104 %attr(0444,root,root) %{_libdir}/%{name}/ntpd.so
105 %attr(0444,root,root) %{_libdir}/%{name}/ping.so
106 %attr(0444,root,root) %{_libdir}/%{name}/processes.so
107 %attr(0444,root,root) %{_libdir}/%{name}/serial.so
108 %attr(0444,root,root) %{_libdir}/%{name}/swap.so
109 %attr(0444,root,root) %{_libdir}/%{name}/tape.so
110 %attr(0444,root,root) %{_libdir}/%{name}/traffic.so
111 %attr(0444,root,root) %{_libdir}/%{name}/users.so
112 %attr(0444,root,root) %{_libdir}/%{name}/vserver.so
113 %attr(0444,root,root) %{_libdir}/%{name}/wireless.so
114
115 %dir /var/lib/collectd
116
117 %files apache
118 %attr(0444,root,root) %{_libdir}/%{name}/apache.so
119
120 %files dns
121 %attr(0444,root,root) %{_libdir}/%{name}/dns.so
122
123 %files mysql
124 %attr(0444,root,root) %{_libdir}/%{name}/mysql.so
125
126 %files sensors
127 %attr(0444,root,root) %{_libdir}/%{name}/sensors.so
128
129 %changelog
130 * Sun Jul 09 2006 Florian octo Forster <octo@verplant.org> 3.10.0-1
131 - New upstream version
132
133 * Tue Jun 25 2006 Florian octo Forster <octo@verplant.org> 3.9.4-1
134 - New upstream version
135
136 * Tue Jun 01 2006 Florian octo Forster <octo@verplant.org> 3.9.3-1
137 - New upstream version
138
139 * Tue May 09 2006 Florian octo Forster <octo@verplant.org> 3.9.2-1
140 - New upstream version
141
142 * Tue May 09 2006 Florian octo Forster <octo@verplant.org> 3.8.5-1
143 - New upstream version
144
145 * Fri Apr 21 2006 Florian octo Forster <octo@verplant.org> 3.9.1-1
146 - New upstream version
147
148 * Fri Apr 14 2006 Florian octo Forster <octo@verplant.org> 3.9.0-1
149 - New upstream version
150 - Added the `apache' package.
151
152 * Thu Mar 14 2006 Florian octo Forster <octo@verplant.org> 3.8.2-1
153 - New upstream version
154
155 * Thu Mar 13 2006 Florian octo Forster <octo@verplant.org> 3.8.1-1
156 - New upstream version
157
158 * Thu Mar 09 2006 Florian octo Forster <octo@verplant.org> 3.8.0-1
159 - New upstream version
160
161 * Sat Feb 18 2006 Florian octo Forster <octo@verplant.org> 3.7.2-1
162 - Include `tape.so' so the build doesn't terminate because of missing files..
163 - New upstream version
164
165 * Sat Feb 04 2006 Florian octo Forster <octo@verplant.org> 3.7.1-1
166 - New upstream version
167
168 * Mon Jan 30 2006 Florian octo Forster <octo@verplant.org> 3.7.0-1
169 - New upstream version
170 - Removed the extra `hddtemp' package
171
172 * Tue Jan 24 2006 Florian octo Forster <octo@verplant.org> 3.6.2-1
173 - New upstream version
174
175 * Fri Jan 20 2006 Florian octo Forster <octo@verplant.org> 3.6.1-1
176 - New upstream version
177
178 * Fri Jan 20 2006 Florian octo Forster <octo@verplant.org> 3.6.0-1
179 - New upstream version
180 - Added config file, `collectd.conf(5)', `df.so'
181 - Added package `collectd-mysql', dependency on `mysqlclient10 | mysql'
182
183 * Wed Dec 07 2005 Florian octo Forster <octo@verplant.org> 3.5.0-1
184 - New upstream version
185
186 * Sat Nov 26 2005 Florian octo Forster <octo@verplant.org> 3.4.0-1
187 - New upstream version
188
189 * Sat Nov 05 2005 Florian octo Forster <octo@verplant.org> 3.3.0-1
190 - New upstream version
191
192 * Tue Oct 26 2005 Florian octo Forster <octo@verplant.org> 3.2.0-1
193 - New upstream version
194 - Added statement to remove the `*.la' files. This fixes a problem when
195   `Unpackaged files terminate build' is in effect.
196 - Added `processes.so*' to the main package
197
198 * Fri Oct 14 2005 Florian octo Forster <octo@verplant.org> 3.1.0-1
199 - New upstream version
200 - Added package `collectd-hddtemp'
201
202 * Fri Sep 30 2005 Florian octo Forster <octo@verplant.org> 3.0.0-1
203 - New upstream version
204 - Split the package into `collectd' and `collectd-sensors'
205
206 * Fri Sep 16 2005 Florian octo Forster <octo@verplant.org> 2.1.0-1
207 - New upstream version
208
209 * Mon Sep 10 2005 Florian octo Forster <octo@verplant.org> 2.0.0-1
210 - New upstream version
211
212 * Mon Aug 29 2005 Florian octo Forster <octo@verplant.org> 1.8.0-1
213 - New upstream version
214
215 * Sun Aug 25 2005 Florian octo Forster <octo@verplant.org> 1.7.0-1
216 - New upstream version
217
218 * Sun Aug 21 2005 Florian octo Forster <octo@verplant.org> 1.6.0-1
219 - New upstream version
220
221 * Sun Jul 17 2005 Florian octo Forster <octo@verplant.org> 1.5.1-1
222 - New upstream version
223
224 * Sun Jul 17 2005 Florian octo Forster <octo@verplant.org> 1.5-1
225 - New upstream version
226
227 * Mon Jul 11 2005 Florian octo Forster <octo@verplant.org> 1.4.2-1
228 - New upstream version
229
230 * Sat Jul 09 2005 Florian octo Forster <octo@verplant.org> 1.4-1
231 - Built on RedHat 7.3