Fixes this bug:
[onis.git] / onis.spec
1 %define ver 0.8.2
2 %define perllibdir %(eval "`perl -V:installvendorlib`"; echo $installvendorlib)
3
4 Name: onis
5 Summary: A logfile analyser and statistics generator for IRC-logfiles
6 Group: Applications/Internet
7 Version: %{ver}
8 Release: 1
9 Source0: http://verplant.org/onis/%{name}-%{ver}.tar.gz
10 URL: http://verplant.org/onis/
11 License: GPL
12 Requires: perl >= 5.6.0
13 AutoReqProv: no
14 BuildArch: noarch
15 Buildroot: %{_tmppath}/%{name}-root
16 Packager: Florian octo Forster <octo@verplant.org>
17
18 %description
19 Onis is a script that converts IRC logfiles into an HTML statistics page. It
20 provides information about daily channel usage, user activity, and channel
21 trivia. It provides a configurable customization and supports Dancer,
22 dircproxy, eggdrop, irssi, mIRC, and XChat logs. Persistent data (history
23 files) and automatic log purging make onis applicable for a large number of
24 logfiles. It also features a powerful translation infrastructure.
25
26 %prep
27 %setup
28 patch -p1 <contrib/systemwide-patch/systemwide-patch.diff
29
30 %build
31 pod2man -r "$(egrep '^\$VERSION' onis | cut -d \' -f 2)" onis >onis.1
32
33 %install
34 rm -fr $RPM_BUILD_ROOT
35
36 mkdir -p $RPM_BUILD_ROOT%_bindir \
37          $RPM_BUILD_ROOT/etc/onis \
38          $RPM_BUILD_ROOT%{perllibdir} \
39          $RPM_BUILD_ROOT%{_datadir}/onis \
40          $RPM_BUILD_ROOT/var/lib/onis \
41          $RPM_BUILD_ROOT%{_mandir}/man1
42
43 cp onis $RPM_BUILD_ROOT%{_bindir}/
44 cp onis.conf users.conf $RPM_BUILD_ROOT/etc/onis/
45 cp -r lib/Onis $RPM_BUILD_ROOT%{perllibdir}/
46 cp -r themes lang $RPM_BUILD_ROOT%{_datadir}/onis/
47 cp -r reports/*-theme $RPM_BUILD_ROOT%{_datadir}/onis/themes/
48 cp onis.1 $RPM_BUILD_ROOT%{_mandir}/man1/
49
50 chmod 0755 $RPM_BUILD_ROOT%_bindir/onis
51 chmod -R 0644 $RPM_BUILD_ROOT/etc/onis/*
52 chmod -R a-w $RPM_BUILD_ROOT%{perllibdir}/Onis
53 chmod -R a-w $RPM_BUILD_ROOT%{_datadir}/onis
54 chmod -R a-w $RPM_BUILD_ROOT%{_mandir}/man1/onis.1
55
56 %clean
57 rm -fr $RPM_BUILD_ROOT
58
59 %files
60 %defattr(-,root,root)
61 %doc CHANGELOG THANKS README TODO FAQ COPYING
62 %config(noreplace) /etc/onis/*
63 %{_bindir}/onis
64 %{perllibdir}/Onis
65 %{_datadir}/onis
66 %{_mandir}/man1/*
67
68 %changelog
69 * Tue Jun 07 2005 Florian Forster <octo@verplant.org>
70 - New upstream version.
71
72 * Sat Apr 23 2005 Florian Forster <octo@verplant.org>
73 - Added generation of manpage.
74 - Rebuild for onis-0.8.1
75
76 * Mon Apr 18 2005 Florian Forster <octo@verplant.org>
77 - Initial build.