updated build tips for updated win32 port by Chris Larsen
[rrdtool.git] / rrdtool.spec
1 %define with_python %{?_without_python: 0} %{?!_without_python: 1}
2 %define with_php %{?_without_php: 0} %{?!_without_php: 1}
3 %define with_tcl %{?_without_tcl: 0} %{?!_without_tcl: 1}
4 %define with_ruby %{?_without_ruby: 0} %{?!_without_ruby: 1}
5 %define php_extdir %(php-config --extension-dir 2>/dev/null || echo %{_libdir}/php4)
6 %define svnrev r1190
7 #define pretag 1.2.99908020600
8 %define rrdcached_user rrdcached
9
10 Summary: Round Robin Database Tool to store and display time-series data
11 Name: rrdtool
12 Version: 1.4.3
13 Release: 0.20%{?dist}
14 License: GPLv2+ with exceptions
15 Group: Applications/Databases
16 URL: http://oss.oetiker.ch/rrdtool/
17 #Source0: http://oss.oetiker.ch/%{name}/pub/%{name}-%{version}.tar.gz
18 Source0: http://oss.oetiker.ch/rrdtool/pub/beta/%{name}-%{version}.tar.gz
19 %if %{with_php}
20 Source1: php4-%{svnrev}.tar.gz
21 Patch1: rrdtool-1.3.0-beta4-fix-rrd_update-in-php-bindings.patch
22 %endif
23 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
24 Requires: dejavu-lgc-fonts
25 BuildRequires: gcc-c++, openssl-devel, freetype-devel
26 BuildRequires: libpng-devel, zlib-devel, intltool >= 0.35.0
27 BuildRequires: cairo-devel >= 1.2, pango-devel >= 1.14
28 BuildRequires: libtool, groff
29 BuildRequires: gettext, libxml2-devel
30 %if 0%{?fedora} >= 7
31 BuildRequires: perl-ExtUtils-MakeMaker perl-devel
32 %endif
33
34 %description
35 RRD is the Acronym for Round Robin Database. RRD is a system to store and
36 display time-series data (i.e. network bandwidth, machine-room temperature,
37 server load average). It stores the data in a very compact way that will not
38 expand over time, and it presents useful graphs by processing the data to
39 enforce a certain data density. It can be used either via simple wrapper
40 scripts (from shell or Perl) or via frontends that poll network devices and
41 put a friendly user interface on it.
42
43 %package devel
44 Summary: RRDtool libraries and header files
45 Group: Development/Libraries
46 Requires: %{name} = %{version}-%{release}
47
48 %description devel
49 RRD is the Acronym for Round Robin Database. RRD is a system to store and
50 display time-series data (i.e. network bandwidth, machine-room temperature,
51 server load average). This package allow you to use directly this library.
52
53 %package doc
54 Summary: RRDtool documentation
55 Group: Documentation
56
57 %description doc
58 RRD is the Acronym for Round Robin Database. RRD is a system to store and
59 display time-series data (i.e. network bandwidth, machine-room temperature,
60 server load average). This package contains documentation on using RRD.
61
62 %package perl
63 Summary: Perl RRDtool bindings
64 Group: Development/Languages
65 Requires: %{name} = %{version}-%{release}
66 Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
67 Obsoletes: perl-%{name} < %{version}-%{release}
68 Provides: perl-%{name} = %{version}-%{release}
69
70 %description perl
71 The Perl RRDtool bindings
72
73 %if %{with_python}
74 %{!?python_sitearch: %define python_sitearch %(%{__python} -c 'from distutils import sysconfig; print sysconfig.get_python_lib(1)')}
75 # eval to 2.3 if python isn't yet present, workaround for no python in fc4 minimal buildroot
76 %{!?python_version: %define python_version %(%{__python} -c 'import sys; print sys.version.split(" ")[0]' || echo "2.3")}
77
78 %package python
79 Summary: Python RRDtool bindings
80 Group: Development/Languages
81 BuildRequires: python-devel >= 2.3
82 Requires: python >= %{python_version}
83 Requires: %{name} = %{version}-%{release}
84 Obsoletes: python-%{name} < %{version}-%{release}
85 Provides: python-%{name} = %{version}-%{release}
86
87 %description python
88 Python RRDtool bindings.
89 %endif
90
91 %ifarch ppc64
92 # php bits busted on ppc64 at the moment
93 %define with_php 0
94 %endif
95
96 %if %{with_php}
97 %package php
98 Summary: PHP RRDtool bindings
99 Group: Development/Languages
100 BuildRequires: php-devel >= 4.0
101 Requires: php >= 4.0
102 Requires: %{name} = %{version}-%{release}
103 %if 0%{?php_zend_api}
104 Requires: php(zend-abi) = %{php_zend_api}
105 Requires: php(api) = %{php_core_api}
106 %else
107 Requires: php-api = %{php_apiver}
108 %endif
109 Obsoletes: php-%{name} < %{version}-%{release}
110 Provides: php-%{name} = %{version}-%{release}
111 Provides: php-pecl(rrdtool)
112
113 %description php
114 The %{name}-php package includes a dynamic shared object (DSO) that adds
115 RRDtool bindings to the PHP HTML-embedded scripting language.
116 %endif
117
118 %if %{with_tcl}
119 %package tcl
120 Summary: Tcl RRDtool bindings
121 Group: Development/Languages
122 BuildRequires: tcl-devel >= 8.0
123 Requires: tcl >= 8.0
124 Requires: %{name} = %{version}-%{release}
125 Obsoletes: tcl-%{name} < %{version}-%{release}
126 Provides: tcl-%{name} = %{version}-%{release}
127
128 %description tcl
129 The %{name}-tcl package includes RRDtool bindings for Tcl.
130 %endif
131
132 %if %{with_ruby}
133 %{!?ruby_sitearch: %define ruby_sitearch %(ruby -rrbconfig -e 'puts Config::CONFIG["sitearchdir"]')}
134
135 %package ruby
136 Summary: Ruby RRDtool bindings
137 Group: Development/Languages
138 BuildRequires: ruby, ruby-devel
139 Requires: ruby(abi) = 1.8
140 Requires: %{name} = %{version}-%{release}
141
142 %description ruby
143 The %{name}-ruby package includes RRDtool bindings for Ruby.
144 %endif
145
146 %package cached
147 Summary: Data caching daemon for RRDtool
148 Group: Applications/Databases
149 Requires: %{name} = %{version}-%{release}
150
151 %description cached
152 rrdcached is a daemon that receives updates to existing RRD files,
153 accumulates them and, if enough have been received or a defined time has
154 passed, writes the updates to the RRD file.  The daemon was written with
155 big setups in mind which usually runs into I/O related problems.  This
156 daemon was written to alleviate these problems.
157
158 %prep
159 %if %{with_php}
160 %setup -q -n %{name}-%{version} -a 1
161 %patch1 -p1
162 %else
163 %setup -q -n %{name}-%{version}
164 %endif
165
166 # Fix to find correct python dir on lib64
167 %{__perl} -pi -e 's|get_python_lib\(0,0,prefix|get_python_lib\(1,0,prefix|g' \
168     configure
169
170 # Most edits shouldn't be necessary when using --libdir, but
171 # w/o, some introduce hardcoded rpaths where they shouldn't
172 %{__perl} -pi.orig -e 's|/lib\b|/%{_lib}|g' configure Makefile.in*
173 %if %{with_php}
174 %{__perl} -pi.orig -e 's|/lib\b|/%{_lib}|g' php4/configure php4/ltconfig*
175 %endif
176
177 # Perl 5.10 seems to not like long version strings, hack around it
178 %{__perl} -pi.orig -e 's|1.299907080300|1.29990708|' \
179     bindings/perl-shared/RRDs.pm bindings/perl-piped/RRDp.pm
180
181 #
182 # fix config files for php4 bindings
183 # workaround needed due to https://bugzilla.redhat.com/show_bug.cgi?id=211069
184 %if %{with_php}
185 cp -p /usr/lib/rpm/config.{guess,sub} php4/
186 %endif
187
188
189 %build
190 %configure \
191     CFLAGS="-g -O0" \
192     --with-perl-options='INSTALLDIRS="vendor"' \
193 %if %{with_tcl}
194     --enable-tcl-site \
195     --with-tcllib=%{_libdir} \
196 %else
197     --disable-tcl \
198 %endif
199 %if %{with_python}
200     --enable-python \
201 %else
202     --disable-python \
203 %endif
204 %if %{with_ruby}
205     --enable-ruby \
206 %endif
207     --disable-static \
208     --with-pic
209
210 # Fix another rpath issue
211 %{__perl} -pi.orig -e 's|-Wl,--rpath -Wl,\$rp||g' \
212     bindings/perl-shared/Makefile.PL
213
214 # Force RRDp bits where we want 'em, not sure yet why the
215 # --with-perl-options and --libdir don't take
216 pushd bindings/perl-piped/
217 %{__perl} Makefile.PL INSTALLDIRS=vendor
218 %{__perl} -pi.orig -e 's|/lib/perl|/%{_lib}/perl|g' Makefile
219 popd
220
221 #{__make} %{?_smp_mflags}
222 make
223
224 # Build the php module, the tmp install is required
225 %if %{with_php}
226 %define rrdtmp %{_tmppath}/%{name}-%{version}-tmpinstall
227 %{__make} install DESTDIR="%{rrdtmp}"
228 pushd php4/
229 %configure \
230     --with-rrdtool="%{rrdtmp}%{_prefix}" \
231     --disable-static
232 #{__make} %{?_smp_mflags}
233 make
234 popd
235 %{__rm} -rf %{rrdtmp}
236 %endif
237
238 # Fix @perl@ and @PERL@
239 find examples/ -type f \
240     -exec %{__perl} -pi -e 's|^#! \@perl\@|#!%{__perl}|gi' {} \;
241 find examples/ -name "*.pl" \
242     -exec %{__perl} -pi -e 's|\015||gi' {} \;
243
244 %install
245 rm -rf $RPM_BUILD_ROOT
246 make DESTDIR="$RPM_BUILD_ROOT" install
247
248 # Install the php module
249 %if %{with_php}
250 %{__install} -D -m0755 php4/modules/rrdtool.so \
251     %{buildroot}%{php_extdir}/rrdtool.so
252 # Clean up the examples for inclusion as docs
253 %{__rm} -rf php4/examples/.svn
254 # Put the php config bit into place
255 %{__mkdir_p} %{buildroot}%{_sysconfdir}/php.d
256 %{__cat} << __EOF__ > %{buildroot}%{_sysconfdir}/php.d/rrdtool.ini
257 ; Enable rrdtool extension module
258 extension=rrdtool.so
259 __EOF__
260 %endif
261
262 # Pesky RRDp.pm...
263 %{__mv} $RPM_BUILD_ROOT%{perl_vendorarch}/../RRDp.pm $RPM_BUILD_ROOT%{perl_vendorarch}/
264
265 # Dunno why this is getting installed here...
266 %{__rm} -f $RPM_BUILD_ROOT%{perl_vendorarch}/../leaktest.pl
267
268 # We only want .txt and .html files for the main documentation
269 %{__mkdir_p} doc2/html doc2/txt
270 %{__cp} -a doc/*.txt doc2/txt/
271 %{__cp} -a doc/*.html doc2/html/
272
273 # Put perl docs in perl package
274 %{__mkdir_p} doc3/html
275 %{__mv} doc2/html/RRD*.html doc3/html/
276
277 # Clean up the examples
278 %{__rm} -f examples/Makefile* examples/*.in
279
280 # This is so rpm doesn't pick up perl module dependencies automatically
281 find examples/ -type f -exec chmod 0644 {} \;
282
283 # Clean up the buildroot
284 %{__rm} -rf $RPM_BUILD_ROOT%{_docdir}/%{name}-* \
285         $RPM_BUILD_ROOT%{perl_vendorarch}/ntmake.pl \
286         $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod \
287         $RPM_BUILD_ROOT%{_datadir}/%{name}/examples \
288         $RPM_BUILD_ROOT%{perl_vendorarch}/auto/*/{.packlist,*.bs}
289
290 # Set up rrdcached
291 %__install -d -m 0755 $RPM_BUILD_ROOT/%{_sysconfdir}/default
292 %__install -d -m 0755 $RPM_BUILD_ROOT/%{_sysconfdir}/rc.d/init.d
293 %__install -m 0644 etc/rrdcached-default $RPM_BUILD_ROOT/%{_sysconfdir}/default/rrdcached
294 %__install -m 0755 etc/rrdcached-init $RPM_BUILD_ROOT/%{_sysconfdir}/rc.d/init.d/rrdcached
295 %__install -d -m 0755 -o nobody -g nobody $RPM_BUILD_ROOT/%{_localstatedir}/run/rrdcached
296
297 %clean
298 %{__rm} -rf $RPM_BUILD_ROOT
299
300 %pre cached
301 /usr/sbin/groupadd %rrdcached_user &>/dev/null ||:
302 /usr/sbin/useradd -s /sbin/nologin -g %rrdcached_user -c %rrdcached_user -d %{_localstatedir}/run/rrdcached  %rrdcached_user &>/dev/null || :
303
304 %post -p /sbin/ldconfig
305
306 %post cached
307 /sbin/chkconfig --add rrdcached
308 /sbin/service rrdcached start
309
310 %preun cached
311 /sbin/service rrdcached stop
312
313 %postun -p /sbin/ldconfig
314
315 %postun cached
316 /sbin/chkconfig --del rrdcached
317 test "$1" != 0 || /usr/sbin/userdel %rrdcached_user &>/dev/null || :
318 #test "$1" != 0 || /usr/sbin/groupdel %rrdcached_user &>/dev/null || :
319
320 %files
321 %defattr(-,root,root,-)
322 %{_bindir}/*
323 %exclude %{_bindir}/rrdcached
324 %{_libdir}/*.so.*
325 %{_datadir}/%{name}
326 %{_mandir}/man1/*
327 %exclude %{_mandir}/man1/rrdcached*
328
329 %files devel
330 %defattr(-,root,root,-)
331 %{_includedir}/*.h
332 %exclude %{_libdir}/*.la
333 %{_libdir}/*.so
334 %{_libdir}/pkgconfig/librrd.pc
335
336 %files doc
337 %defattr(-,root,root,-)
338 %doc CONTRIBUTORS COPYING COPYRIGHT README TODO NEWS THREADS
339 %doc examples doc2/html doc2/txt
340
341 %files perl
342 %defattr(-,root,root,-)
343 %doc doc3/html
344 %{_mandir}/man3/*
345 %{perl_vendorarch}/*.pm
346 %attr(0755,root,root) %{perl_vendorarch}/auto/RRDs/
347
348 %if %{with_python}
349 %files python
350 %defattr(-,root,root,-)
351 %doc bindings/python/AUTHORS bindings/python/COPYING bindings/python/README
352 %{python_sitearch}/*
353 %endif
354
355 %if %{with_php}
356 %files php
357 %defattr(-,root,root,0755)
358 %doc php4/examples php4/README
359 %config(noreplace) %{_sysconfdir}/php.d/rrdtool.ini
360 %{php_extdir}/rrdtool.so
361 %endif
362
363 %if %{with_tcl}
364 %files tcl
365 %defattr(-,root,root,-)
366 %doc bindings/tcl/README
367 %{_libdir}/tclrrd*.so
368 %{_libdir}/rrdtool/*.tcl
369 %endif
370
371 %if %{with_ruby}
372 %files ruby
373 %defattr(-,root,root,-)
374 %doc bindings/ruby/README
375 %{ruby_sitearch}/RRD.so
376 %endif
377
378 %files cached
379 %{_bindir}/rrdcached
380 %config %{_sysconfdir}/default/*
381 %config %{_sysconfdir}/rc.d/init.d/*
382 %{_mandir}/man1/rrdcached*
383 %attr(0775 %rrdcached_user %rrdcached_user) %dir %{_localstatedir}/run/rrdcached
384
385 %changelog
386 * Wed Oct 08 2008 Bernard Li <bernard@vanhpc.org>
387 - Split rrdcached related files to -cached subpackage
388 - Create rrdcached user and make rrdcached related files owned by it
389
390 * Tue Oct 07 2008 Bernard Li <bernard@vanhpc.org>
391 - Include librrd.pc file in -devel package
392
393 * Sun Jun 08 2008 Jarod Wilson <jwilson@redhat.com> 1.3-0.20.rc9
394 - Update to rrdtool 1.3 rc9
395 - Minor spec tweaks to permit building on older EL
396
397 * Wed Jun 04 2008 Chris Ricker <kaboom@oobleck.net> 1.3-0.19.rc7
398 - Update to rrdtool 1.3 rc7
399
400 * Tue May 27 2008 Chris Ricker <kaboom@oobleck.net> 1.3-0.18.rc6
401 - Update to rrdtool 1.3 rc6
402
403 * Wed May 21 2008 Chris Ricker <kaboom@oobleck.net> 1.3-0.17.rc4
404 - Bump version and rebuild
405
406 * Wed May 21 2008 Chris Ricker <kaboom@oobleck.net> 1.3-0.16.rc4
407 - Fix php bindings compile on x86_64
408
409 * Mon May 19 2008 Chris Ricker <kaboom@oobleck.net> 1.3-0.15.rc4
410 - Update to rrdtool 1.3 rc4
411
412 * Tue May 13 2008 Jarod Wilson <jwilson@redhat.com> 1.3-0.15.rc1
413 - Update to rrdtool 1.3 rc1
414 - Fix versioning in changelog entries, had an extra 0 in there...
415 - Drop cairo and python patches, they're in 1.3 rc1
416 - Add Requires: gettext and libxml2-devel for new translations
417
418 * Wed Apr 30 2008 Jarod Wilson <jwilson@redhat.com> 1.3-0.14.beta4
419 - Drop some conditional flags, they're not working at the moment...
420
421 * Wed Apr 30 2008 Jarod Wilson <jwilson@redhat.com> 1.3-0.13.beta4
422 - Fix problem with cairo_save/cairo_restore (#444827)
423
424 * Wed Apr 23 2008 Jarod Wilson <jwilson@redhat.com> 1.3-0.12.beta4
425 - Fix python bindings rrdtool info implementation (#435468)
426
427 * Tue Apr 08 2008 Jarod Wilson <jwilson@redhat.com> 1.3-0.11.beta4
428 - Work around apparent version string length issue w/perl 5.10 (#441359)
429
430 * Sat Apr 05 2008 Jarod Wilson <jwilson@redhat.com> 1.3-0.10.beta4
431 - Fix use of rrd_update in php bindings (#437558)
432
433 * Mon Mar  3 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.3-0.9.beta4
434 - rebuild for new perl (again)
435
436 * Wed Feb 13 2008 Jarod Wilson <jwilson@redhat.com> 1.3-0.8.beta4
437 - Update to rrdtool 1.3 beta4
438
439 * Tue Feb 05 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.3-0.7.beta3
440 - rebuild for new perl (and fix license tag)
441
442 * Mon Feb 04 2008 Jarod Wilson <jwilson@redhat.com> 1.3-0.6.beta3
443 - Plug memory leak (#430879)
444
445 * Mon Jan 07 2008 Jarod Wilson <jwilson@redhat.com> 1.3-0.5.beta3
446 - Fix right-aligned text alignment and scaling (Resolves: #427609)
447
448 * Wed Jan 02 2008 Jarod Wilson <jwilson@redhat.com> 1.3-0.4.beta3
449 - Add newly built python egg to %%files
450
451 * Wed Jan 02 2008 Jarod Wilson <jwilson@redhat.com> 1.3-0.3.beta3
452 - Update to rrdtool 1.3 beta3
453 - Return properly from errors in RRDp.pm (Resolves: #427040)
454 - Requires: dejavu-lgc-fonts (Resolves: #426935)
455
456 * Thu Dec 06 2007 Jarod Wilson <jwilson@redhat.com> 1.3-0.2.beta2
457 - Update to rrdtool 1.3 beta2
458
459 * Wed Aug 08 2007 Jarod Wilson <jwilson@redhat.com> 1.3-0.1.beta1
460 - Update to rrdtool 1.3 beta1
461
462 * Tue Jul 10 2007 Jarod Wilson <jwilson@redhat.com> 1.2.999-0.3.r1144
463 - Update to latest rrdtool pre-1.3 svn snapshot (svn r1144)
464 - Add php abi check (Resolves: #247339)
465
466 * Fri Jun 15 2007 Jarod Wilson <jwilson@redhat.com> 1.2.999-0.2.r1127
467 - Fix up BuildRequires
468
469 * Fri Jun 15 2007 Jarod Wilson <jwilson@redhat.com> 1.2.999-0.1.r1127
470 - Update to rrdtool pre-1.3 svn snapshot (svn r1127)
471
472 * Mon May 21 2007 Jarod Wilson <jwilson@redhat.com> 1.2.23-5
473 - BR: ruby so %%ruby_sitearch gets set
474
475 * Mon May 21 2007 Jarod Wilson <jwilson@redhat.com> 1.2.23-4
476 - Build ruby bindings
477
478 * Thu May 03 2007 Jarod Wilson <jwilson@redhat.com> 1.2.23-3
479 - Disable php bits on ppc64 for now, they fail to build
480
481 * Thu May 03 2007 Jarod Wilson <jwilson@redhat.com> 1.2.23-2
482 - Add BR: perl-devel for Fedora 7 and later
483
484 * Tue May 01 2007 Jarod Wilson <jwilson@redhat.com> 1.2.23-1
485 - New upstream release
486
487 * Tue May 01 2007 Jarod Wilson <jwilson@redhat.com> 1.2.21-1
488 - New upstream release
489
490 * Wed Apr 25 2007 Jarod Wilson <jwilson@redhat.com> 1.2.19-2
491 - Define %%python_version *before* its needed (#237826)
492
493 * Mon Apr 09 2007 Jarod Wilson <jwilson@redhat.com> 1.2.19-1
494 - New upstream release
495
496 * Tue Jan 23 2007 Jarod Wilson <jwilson@redhat.com> 1.2.18-1
497 - New upstream release
498
499 * Mon Jan 22 2007 Jarod Wilson <jwilson@redhat.com> 1.2.17-1
500 - New upstream release
501
502 * Tue Jan 02 2007 Jarod Wilson <jwilson@redhat.com> 1.2.15-9
503 - Fix crash with long error strings (upstream
504   changesets 929 and 935)
505
506 * Thu Dec 14 2006 Jarod Wilson <jwilson@redhat.com> 1.2.15-8
507 - Fix for log grid memory leak (#201241)
508
509 * Tue Dec 12 2006 Jarod Wilson <jwilson@redhat.com> 1.2.15-7
510 - Rebuild for python 2.5
511
512 * Tue Nov 14 2006 Jarod Wilson <jwilson@redhat.com> 1.2.15-6
513 - Conditionalize python, php and tcl bits (Resolves #203275)
514
515 * Wed Oct 25 2006 Jarod Wilson <jwilson@redhat.com> 1.2.15-5
516 - Add tcl sub-package (#203275)
517
518 * Tue Sep 05 2006 Jarod Wilson <jwilson@redhat.com> 1.2.15-4
519 - Rebuild for new glibc
520
521 * Wed Aug 02 2006 Jarod Wilson <jwilson@redhat.com> 1.2.15-3
522 - One more addition to initrrdtool patch, to fully revert
523   and correct upstream changeset 839
524 - Fix for no python in minimal fc4 buildroots
525
526 * Tue Aug  1 2006 Mihai Ibanescu <misa@redhat.com> 1.2.15-2
527 - Fixed rrdtool-python to import the module properly (patch
528   rrdtool-1.2.15-initrrdtool.patch)
529
530 * Mon Jul 17 2006 Jarod Wilson <jwilson@redhat.com> 1.2.15-1
531 - Update to 1.2.15
532 - Minor spec cleanups
533
534 * Sat Jun 24 2006 Jarod Wilson <jwilson@redhat.com> 1.2.13-7
535 - Fix up Obsoletes
536
537 * Mon Jun 19 2006 Jarod Wilson <jwilson@redhat.com> 1.2.13-6
538 - Flip perl, php and python sub-package names around to 
539   conform with general practices
540
541 * Sat Jun 10 2006 Jarod Wilson <jwilson@redhat.com> 1.2.13-5
542 - Minor fixes to make package own created directories
543
544 * Wed Jun 07 2006 Jarod Wilson <jwilson@redhat.com> 1.2.13-4
545 - Add php bits back into the mix
546
547 * Mon Jun 05 2006 Jarod Wilson <jwilson@redhat.com> 1.2.13-3
548 - Merge spec fixes from bz 185909
549
550 * Sun Jun 04 2006 Jarod Wilson <jwilson@redhat.com> 1.2.13-2
551 - Remove explicit perl dep, version grabbing using rpm during
552   rpmbuild not guaranteed to work (fails on ppc in plague),
553   and auto-gen perl deps are sufficient
554
555 * Sat Jun 03 2006 Jarod Wilson <jwilson@redhat.com> 1.2.13-1
556 - Update to release 1.2.13
557 - Merge spec changes from dag, atrpms and mdk builds
558 - Additional hacktastic contortions for lib64 & rpath messiness
559 - Add missing post/postun ldconfig
560 - Fix a bunch of rpmlint errors
561 - Disable static libs, per FE guidelines
562 - Split off docs
563
564 * Wed Apr 19 2006 Chris Ricker <kaboom@oobleck.net> 1.2.12-1
565 - Rev to 1.2
566
567 * Fri May 20 2005 Matthias Saou <http://freshrpms.net/> 1.0.49-5
568 - Include patch from Michael to fix perl module compilation on FC4 (#156242).
569
570 * Fri May 20 2005 Matthias Saou <http://freshrpms.net/> 1.0.49-4
571 - Fix for the php module patch (Joe Pruett, Dag Wieers), #156716.
572 - Update source URL to new location since 1.2 is now the default stable.
573 - Don't (yet) update to 1.0.50, as it introduces some changes in the perl
574   modules install.
575
576 * Mon Jan 31 2005 Matthias Saou <http://freshrpms.net/> 1.0.49-3
577 - Put perl modules in vendor_perl and not site_perl. #146513
578
579 * Thu Jan 13 2005 Matthias Saou <http://freshrpms.net/> 1.0.49-2
580 - Minor cleanups.
581
582 * Thu Aug 25 2004 Dag Wieers <dag@wieers.com> - 1.0.49-1
583 - Updated to release 1.0.49.
584
585 * Wed Aug 25 2004 Dag Wieers <dag@wieers.com> - 1.0.48-3
586 - Fixes for x86_64. (Garrick Staples)
587
588 * Fri Jul  2 2004 Matthias Saou <http://freshrpms.net/> 1.0.48-3
589 - Actually apply the patch for fixing the php module, doh!
590
591 * Thu May 27 2004 Matthias Saou <http://freshrpms.net/> 1.0.48-2
592 - Added php.d config entry to load the module once installed.
593
594 * Thu May 13 2004 Dag Wieers <dag@wieers.com> - 1.0.48-1
595 - Updated to release 1.0.48.
596
597 * Tue Apr 06 2004 Dag Wieers <dag@wieers.com> - 1.0.47-1
598 - Updated to release 1.0.47.
599
600 * Thu Mar  4 2004 Matthias Saou <http://freshrpms.net/> 1.0.46-2
601 - Change the strict dependency on perl to fix problem with the recent
602   update.
603
604 * Mon Jan  5 2004 Matthias Saou <http://freshrpms.net/> 1.0.46-1
605 - Update to 1.0.46.
606 - Use system libpng and zlib instead of bundled ones.
607 - Added php-rrdtool sub-package for the php4 module.
608
609 * Fri Dec  5 2003 Matthias Saou <http://freshrpms.net/> 1.0.45-4
610 - Added epoch to the perl dependency to work with rpm > 4.2.
611 - Fixed the %% escaping in the perl dep.
612
613 * Mon Nov 17 2003 Matthias Saou <http://freshrpms.net/> 1.0.45-2
614 - Rebuild for Fedora Core 1.
615
616 * Sun Aug  3 2003 Matthias Saou <http://freshrpms.net/>
617 - Update to 1.0.45.
618
619 * Wed Apr 16 2003 Matthias Saou <http://freshrpms.net/>
620 - Update to 1.0.42.
621
622 * Mon Mar 31 2003 Matthias Saou <http://freshrpms.net/>
623 - Rebuilt for Red Hat Linux 9.
624
625 * Wed Mar  5 2003 Matthias Saou <http://freshrpms.net/>
626 - Added explicit perl version dependency.
627
628 * Sun Feb 23 2003 Matthias Saou <http://freshrpms.net/>
629 - Update to 1.0.41.
630
631 * Fri Jan 31 2003 Matthias Saou <http://freshrpms.net/>
632 - Update to 1.0.40.
633 - Spec file cleanup.
634
635 * Fri Jul 05 2002 Henri Gomez <hgomez@users.sourceforge.net>
636 - 1.0.39
637
638 * Mon Jun 03 2002 Henri Gomez <hgomez@users.sourceforge.net>
639 - 1.0.38
640
641 * Fri Apr 19 2002 Henri Gomez <hgomez@users.sourceforge.net>
642 - 1.0.37
643
644 * Tue Mar 12 2002 Henri Gomez <hgomez@users.sourceforge.net>
645 - 1.0.34
646 - rrdtools include zlib 1.1.4 which fix vulnerabilities in 1.1.3
647