fix some issues with the
[rrdtool.git] / rrdtool.spec
1 %define with_python %{?_without_python: 0} %{?!_without_python: 1}
2 %define with_php %{?_without_php: 0} %{?!_without_php: 1}
3 %define with_tcl %{?_without_tcl: 0} %{?!_without_tcl: 1}
4 %define with_ruby %{?_without_ruby: 0} %{?!_without_ruby: 1}
5 %define with_lua %{?_without_lua: 0} %{?!_without_lua: 1}
6 %define php_extdir %(php-config --extension-dir 2>/dev/null || echo %{_libdir}/php4)
7 %define svnrev r1190
8 #define pretag 1.2.99908020600
9 %define rrdcached_user rrdcached
10
11 Summary: Round Robin Database Tool to store and display time-series data
12 Name: rrdtool
13 Version: 1.4.999
14 Release: 1%{?dist}
15 License: GPLv2+ with exceptions
16 Group: Applications/Databases
17 URL: http://oss.oetiker.ch/rrdtool/
18 #Source0: http://oss.oetiker.ch/%{name}/pub/%{name}-%{version}.tar.gz
19 Source0: http://oss.oetiker.ch/rrdtool/pub/beta/%{name}-%{version}.tar.gz
20 %if %{with_php}
21 Source1: php4-%{svnrev}.tar.gz
22 Patch1: rrdtool-1.3.0-beta4-fix-rrd_update-in-php-bindings.patch
23 %endif
24 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
25 Requires: dejavu-lgc-fonts
26 BuildRequires: gcc-c++, openssl-devel, freetype-devel
27 BuildRequires: libpng-devel, zlib-devel, intltool >= 0.35.0
28 BuildRequires: cairo-devel >= 1.2, pango-devel >= 1.14
29 BuildRequires: libtool, groff
30 BuildRequires: gettext, libxml2-devel
31 %if 0%{?fedora} >= 7
32 BuildRequires: perl-ExtUtils-MakeMaker perl-devel
33 %endif
34
35 %description
36 RRD is the Acronym for Round Robin Database. RRD is a system to store and
37 display time-series data (i.e. network bandwidth, machine-room temperature,
38 server load average). It stores the data in a very compact way that will not
39 expand over time, and it presents useful graphs by processing the data to
40 enforce a certain data density. It can be used either via simple wrapper
41 scripts (from shell or Perl) or via frontends that poll network devices and
42 put a friendly user interface on it.
43
44 %package devel
45 Summary: RRDtool libraries and header files
46 Group: Development/Libraries
47 Requires: %{name} = %{version}-%{release}
48
49 %description devel
50 RRD is the Acronym for Round Robin Database. RRD is a system to store and
51 display time-series data (i.e. network bandwidth, machine-room temperature,
52 server load average). This package allow you to use directly this library.
53
54 %package doc
55 Summary: RRDtool documentation
56 Group: Documentation
57
58 %description doc
59 RRD is the Acronym for Round Robin Database. RRD is a system to store and
60 display time-series data (i.e. network bandwidth, machine-room temperature,
61 server load average). This package contains documentation on using RRD.
62
63 %define perl_vendorarch %(eval "`%{__perl} -V:installvendorarch`"; echo $installvendorarch)
64 %define perl_vendorlib %(eval "`%{__perl} -V:installvendorlib`"; echo $installvendorlib)
65
66 %package perl
67 Summary: Perl RRDtool bindings
68 Group: Development/Languages
69 Requires: %{name} = %{version}-%{release}
70 Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
71 Obsoletes: perl-%{name} < %{version}-%{release}
72 Provides: perl-%{name} = %{version}-%{release}
73
74 %description perl
75 The Perl RRDtool bindings
76
77 %if %{with_python}
78 %{!?python_sitearch: %define python_sitearch %(%{__python} -c 'from distutils import sysconfig; print sysconfig.get_python_lib(1)')}
79 # eval to 2.3 if python isn't yet present, workaround for no python in fc4 minimal buildroot
80 %{!?python_version: %define python_version %(%{__python} -c 'import sys; print sys.version.split(" ")[0]' || echo "2.3")}
81
82 %package python
83 Summary: Python RRDtool bindings
84 Group: Development/Languages
85 BuildRequires: python-devel >= 2.3
86 Requires: python >= %{python_version}
87 Requires: %{name} = %{version}-%{release}
88 Obsoletes: python-%{name} < %{version}-%{release}
89 Provides: python-%{name} = %{version}-%{release}
90
91 %description python
92 Python RRDtool bindings.
93 %endif
94
95 %ifarch ppc64
96 # php bits busted on ppc64 at the moment
97 %define with_php 0
98 %endif
99
100 %if %{with_php}
101 %package php
102 Summary: PHP RRDtool bindings
103 Group: Development/Languages
104 BuildRequires: php-devel >= 4.0
105 Requires: php >= 4.0
106 Requires: %{name} = %{version}-%{release}
107 %if 0%{?php_zend_api}
108 Requires: php(zend-abi) = %{php_zend_api}
109 Requires: php(api) = %{php_core_api}
110 %else
111 Requires: php-api = %{php_apiver}
112 %endif
113 Obsoletes: php-%{name} < %{version}-%{release}
114 Provides: php-%{name} = %{version}-%{release}
115 Provides: php-pecl(rrdtool)
116
117 %description php
118 The %{name}-php package includes a dynamic shared object (DSO) that adds
119 RRDtool bindings to the PHP HTML-embedded scripting language.
120 %endif
121
122 %if %{with_tcl}
123 %package tcl
124 Summary: Tcl RRDtool bindings
125 Group: Development/Languages
126 BuildRequires: tcl-devel >= 8.0
127 Requires: tcl >= 8.0
128 Requires: %{name} = %{version}-%{release}
129 Obsoletes: tcl-%{name} < %{version}-%{release}
130 Provides: tcl-%{name} = %{version}-%{release}
131
132 %description tcl
133 The %{name}-tcl package includes RRDtool bindings for Tcl.
134 %endif
135
136 %if %{with_ruby}
137 %{!?ruby_sitearch: %define ruby_sitearch %(ruby -rrbconfig -e 'puts Config::CONFIG["sitearchdir"]')}
138
139 %package ruby
140 Summary: Ruby RRDtool bindings
141 Group: Development/Languages
142 BuildRequires: ruby, ruby-devel
143 Requires: ruby(abi) = 1.8
144 Requires: %{name} = %{version}-%{release}
145
146 %description ruby
147 The %{name}-ruby package includes RRDtool bindings for Ruby.
148 %endif
149
150 %if %{with_lua}
151 %{!?lua_version: %define lua_version %(lua -v 2>&1 | cut -f2 -d' ' | cut -f1,2 -d '.')}
152
153 %package lua
154 Summary: Lua RRDtool bindings
155 Group: Development/Languages
156 BuildRequires: lua-devel
157 Requires: lua
158 Requires: %{name} = %{version}-%{release}
159
160 %description lua
161 The %{name}-lua package includes RRDtool bindings for Lua.
162 %endif
163
164 %package cached
165 Summary: Data caching daemon for RRDtool
166 Group: Applications/Databases
167 Requires: %{name} = %{version}-%{release}
168
169 %description cached
170 rrdcached is a daemon that receives updates to existing RRD files,
171 accumulates them and, if enough have been received or a defined time has
172 passed, writes the updates to the RRD file.  The daemon was written with
173 big setups in mind which usually runs into I/O related problems.  This
174 daemon was written to alleviate these problems.
175
176 %prep
177 %if %{with_php}
178 %setup -q -n %{name}-%{version} -a 1
179 %patch1 -p1
180 %else
181 %setup -q -n %{name}-%{version}
182 %endif
183
184 # Fix to find correct python dir on lib64
185 %{__perl} -pi -e 's|get_python_lib\(0,0,prefix|get_python_lib\(1,0,prefix|g' \
186     configure
187
188 # Most edits shouldn't be necessary when using --libdir, but
189 # w/o, some introduce hardcoded rpaths where they shouldn't
190 %{__perl} -pi.orig -e 's|/lib\b|/%{_lib}|g' configure Makefile.in*
191 %if %{with_php}
192 %{__perl} -pi.orig -e 's|/lib\b|/%{_lib}|g' php4/configure php4/ltconfig*
193 %endif
194
195 # Perl 5.10 seems to not like long version strings, hack around it
196 %{__perl} -pi.orig -e 's|1.299907080300|1.29990708|' \
197     bindings/perl-shared/RRDs.pm bindings/perl-piped/RRDp.pm
198
199 #
200 # fix config files for php4 bindings
201 # workaround needed due to https://bugzilla.redhat.com/show_bug.cgi?id=211069
202 %if %{with_php}
203 cp -p /usr/lib/rpm/config.{guess,sub} php4/
204 %endif
205
206
207 %build
208 %configure \
209     CFLAGS="-g -O0" \
210     --with-perl-options='INSTALLDIRS="vendor"' \
211 %if %{with_tcl}
212     --enable-tcl-site \
213     --with-tcllib=%{_libdir} \
214 %else
215     --disable-tcl \
216 %endif
217 %if %{with_python}
218     --enable-python \
219 %else
220     --disable-python \
221 %endif
222 %if %{with_ruby}
223     --enable-ruby \
224 %else
225     --disable-ruby \
226 %endif
227 %if %{with_lua}
228     --enable-lua \
229 %else
230     --disable-lua \
231 %endif
232     --enable-perl-site-install \
233     --disable-static \
234     --with-pic
235
236 # Fix another rpath issue
237 %{__perl} -pi.orig -e 's|-Wl,--rpath -Wl,\$rp||g' \
238     bindings/perl-shared/Makefile.PL
239
240 #{__make} %{?_smp_mflags}
241 make
242
243 # Build the php module, the tmp install is required
244 %if %{with_php}
245 %define rrdtmp %{_tmppath}/%{name}-%{version}-tmpinstall
246 %{__make} install DESTDIR="%{rrdtmp}"
247 pushd php4/
248 %configure \
249     --with-rrdtool="%{rrdtmp}%{_prefix}" \
250     --disable-static
251 #{__make} %{?_smp_mflags}
252 make
253 popd
254 %{__rm} -rf %{rrdtmp}
255 %endif
256
257 # Fix @perl@ and @PERL@
258 find examples/ -type f \
259     -exec %{__perl} -pi -e 's|^#! \@perl\@|#!%{__perl}|gi' {} \;
260 find examples/ -name "*.pl" \
261     -exec %{__perl} -pi -e 's|\015||gi' {} \;
262
263 %install
264 rm -rf $RPM_BUILD_ROOT
265 make DESTDIR="$RPM_BUILD_ROOT" install
266
267 # Install the php module
268 %if %{with_php}
269 %{__install} -D -m0755 php4/modules/rrdtool.so \
270     %{buildroot}%{php_extdir}/rrdtool.so
271 # Clean up the examples for inclusion as docs
272 %{__rm} -rf php4/examples/.svn
273 # Put the php config bit into place
274 %{__mkdir_p} %{buildroot}%{_sysconfdir}/php.d
275 %{__cat} << __EOF__ > %{buildroot}%{_sysconfdir}/php.d/rrdtool.ini
276 ; Enable rrdtool extension module
277 extension=rrdtool.so
278 __EOF__
279 %endif
280
281 # Dunno why this is getting installed here...
282 %{__rm} -f $RPM_BUILD_ROOT%{perl_vendorarch}/../leaktest.pl
283
284 # We only want .txt and .html files for the main documentation
285 %{__mkdir_p} doc2/html doc2/txt
286 %{__cp} -a doc/*.txt doc2/txt/
287 %{__cp} -a doc/*.html doc2/html/
288
289 # Put perl docs in perl package
290 %{__mkdir_p} doc3/html
291 %{__mv} doc2/html/RRD*.html doc3/html/
292
293 # Clean up the examples
294 %{__rm} -f examples/Makefile* examples/*.in
295
296 # This is so rpm doesn't pick up perl module dependencies automatically
297 find examples/ -type f -exec chmod 0644 {} \;
298
299 # Clean up the buildroot
300 %{__rm} -rf $RPM_BUILD_ROOT%{_docdir}/%{name}-* \
301         $RPM_BUILD_ROOT%{perl_vendorarch}/ntmake.pl \
302         $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod \
303         $RPM_BUILD_ROOT%{_datadir}/%{name}/examples \
304         $RPM_BUILD_ROOT%{perl_vendorarch}/auto/*/{.packlist,*.bs}
305
306 # Set up rrdcached
307 %__install -d -m 0755 $RPM_BUILD_ROOT/%{_sysconfdir}/default
308 %__install -d -m 0755 $RPM_BUILD_ROOT/%{_sysconfdir}/rc.d/init.d
309 %__install -m 0644 etc/rrdcached-default $RPM_BUILD_ROOT/%{_sysconfdir}/default/rrdcached
310 %__install -m 0755 etc/rrdcached-init $RPM_BUILD_ROOT/%{_sysconfdir}/rc.d/init.d/rrdcached
311 %__install -d -m 0755 -o nobody -g nobody $RPM_BUILD_ROOT/%{_localstatedir}/run/rrdcached
312
313 %clean
314 %{__rm} -rf $RPM_BUILD_ROOT
315
316 %pre cached
317 /usr/sbin/groupadd %rrdcached_user &>/dev/null ||:
318 /usr/sbin/useradd -s /sbin/nologin -g %rrdcached_user -c %rrdcached_user -d %{_localstatedir}/run/rrdcached  %rrdcached_user &>/dev/null || :
319
320 %post -p /sbin/ldconfig
321
322 %post cached
323 /sbin/chkconfig --add rrdcached
324 /sbin/service rrdcached start
325
326 %preun cached
327 /sbin/service rrdcached stop
328
329 %postun -p /sbin/ldconfig
330
331 %postun cached
332 /sbin/chkconfig --del rrdcached
333 test "$1" != 0 || /usr/sbin/userdel %rrdcached_user &>/dev/null || :
334 #test "$1" != 0 || /usr/sbin/groupdel %rrdcached_user &>/dev/null || :
335
336 %files
337 %defattr(-,root,root,-)
338 %{_bindir}/*
339 %exclude %{_bindir}/rrdcached
340 %{_libdir}/*.so.*
341 %{_datadir}/%{name}
342 %{_mandir}/man1/*
343 %exclude %{_mandir}/man1/rrdcached*
344
345 %files devel
346 %defattr(-,root,root,-)
347 %{_includedir}/*.h
348 %exclude %{_libdir}/*.la
349 %{_libdir}/*.so
350 %{_libdir}/pkgconfig/librrd.pc
351
352 %files doc
353 %defattr(-,root,root,-)
354 %doc CONTRIBUTORS COPYING COPYRIGHT README TODO NEWS THREADS
355 %doc examples doc2/html doc2/txt
356
357 %files perl
358 %defattr(-,root,root,-)
359 %doc doc3/html
360 %{_mandir}/man3/*
361 %{perl_vendorarch}/*.pm
362 %attr(0755,root,root) %{perl_vendorarch}/auto/RRDs/
363 %{perl_vendorlib}/*.pm
364
365 %if %{with_python}
366 %files python
367 %defattr(-,root,root,-)
368 %doc bindings/python/AUTHORS bindings/python/COPYING bindings/python/README
369 %{python_sitearch}/*
370 %endif
371
372 %if %{with_php}
373 %files php
374 %defattr(-,root,root,0755)
375 %doc php4/examples php4/README
376 %config(noreplace) %{_sysconfdir}/php.d/rrdtool.ini
377 %{php_extdir}/rrdtool.so
378 %endif
379
380 %if %{with_tcl}
381 %files tcl
382 %defattr(-,root,root,-)
383 %doc bindings/tcl/README
384 %{_libdir}/tclrrd*.so
385 %{_libdir}/rrdtool/*.tcl
386 %endif
387
388 %if %{with_ruby}
389 %files ruby
390 %defattr(-,root,root,-)
391 %doc bindings/ruby/README
392 %{ruby_sitearch}/RRD.so
393 %endif
394
395 %if %{with_lua}
396 %files lua
397 %defattr(-,root,root,-)
398 %{_libdir}/lua/%{lua_version}/rrd.*
399 %endif
400
401 %files cached
402 %{_bindir}/rrdcached
403 %config %{_sysconfdir}/default/*
404 %config %{_sysconfdir}/rc.d/init.d/*
405 %{_mandir}/man1/rrdcached*
406 %attr(0775 %rrdcached_user %rrdcached_user) %dir %{_localstatedir}/run/rrdcached
407
408 %changelog
409 * Tue Jan 25 2011 Bernard Li <bernard@vanhpc.org>
410 - Reset Release to 1
411 - Add -lua subpackage
412 - Fix -perl subpackage so it includes the correct Perl package paths
413
414 * Wed Oct 08 2008 Bernard Li <bernard@vanhpc.org>
415 - Split rrdcached related files to -cached subpackage
416 - Create rrdcached user and make rrdcached related files owned by it
417
418 * Tue Oct 07 2008 Bernard Li <bernard@vanhpc.org>
419 - Include librrd.pc file in -devel package
420
421 * Sun Jun 08 2008 Jarod Wilson <jwilson@redhat.com> 1.3-0.20.rc9
422 - Update to rrdtool 1.3 rc9
423 - Minor spec tweaks to permit building on older EL
424
425 * Wed Jun 04 2008 Chris Ricker <kaboom@oobleck.net> 1.3-0.19.rc7
426 - Update to rrdtool 1.3 rc7
427
428 * Tue May 27 2008 Chris Ricker <kaboom@oobleck.net> 1.3-0.18.rc6
429 - Update to rrdtool 1.3 rc6
430
431 * Wed May 21 2008 Chris Ricker <kaboom@oobleck.net> 1.3-0.17.rc4
432 - Bump version and rebuild
433
434 * Wed May 21 2008 Chris Ricker <kaboom@oobleck.net> 1.3-0.16.rc4
435 - Fix php bindings compile on x86_64
436
437 * Mon May 19 2008 Chris Ricker <kaboom@oobleck.net> 1.3-0.15.rc4
438 - Update to rrdtool 1.3 rc4
439
440 * Tue May 13 2008 Jarod Wilson <jwilson@redhat.com> 1.3-0.15.rc1
441 - Update to rrdtool 1.3 rc1
442 - Fix versioning in changelog entries, had an extra 0 in there...
443 - Drop cairo and python patches, they're in 1.3 rc1
444 - Add Requires: gettext and libxml2-devel for new translations
445
446 * Wed Apr 30 2008 Jarod Wilson <jwilson@redhat.com> 1.3-0.14.beta4
447 - Drop some conditional flags, they're not working at the moment...
448
449 * Wed Apr 30 2008 Jarod Wilson <jwilson@redhat.com> 1.3-0.13.beta4
450 - Fix problem with cairo_save/cairo_restore (#444827)
451
452 * Wed Apr 23 2008 Jarod Wilson <jwilson@redhat.com> 1.3-0.12.beta4
453 - Fix python bindings rrdtool info implementation (#435468)
454
455 * Tue Apr 08 2008 Jarod Wilson <jwilson@redhat.com> 1.3-0.11.beta4
456 - Work around apparent version string length issue w/perl 5.10 (#441359)
457
458 * Sat Apr 05 2008 Jarod Wilson <jwilson@redhat.com> 1.3-0.10.beta4
459 - Fix use of rrd_update in php bindings (#437558)
460
461 * Mon Mar  3 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.3-0.9.beta4
462 - rebuild for new perl (again)
463
464 * Wed Feb 13 2008 Jarod Wilson <jwilson@redhat.com> 1.3-0.8.beta4
465 - Update to rrdtool 1.3 beta4
466
467 * Tue Feb 05 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.3-0.7.beta3
468 - rebuild for new perl (and fix license tag)
469
470 * Mon Feb 04 2008 Jarod Wilson <jwilson@redhat.com> 1.3-0.6.beta3
471 - Plug memory leak (#430879)
472
473 * Mon Jan 07 2008 Jarod Wilson <jwilson@redhat.com> 1.3-0.5.beta3
474 - Fix right-aligned text alignment and scaling (Resolves: #427609)
475
476 * Wed Jan 02 2008 Jarod Wilson <jwilson@redhat.com> 1.3-0.4.beta3
477 - Add newly built python egg to %%files
478
479 * Wed Jan 02 2008 Jarod Wilson <jwilson@redhat.com> 1.3-0.3.beta3
480 - Update to rrdtool 1.3 beta3
481 - Return properly from errors in RRDp.pm (Resolves: #427040)
482 - Requires: dejavu-lgc-fonts (Resolves: #426935)
483
484 * Thu Dec 06 2007 Jarod Wilson <jwilson@redhat.com> 1.3-0.2.beta2
485 - Update to rrdtool 1.3 beta2
486
487 * Wed Aug 08 2007 Jarod Wilson <jwilson@redhat.com> 1.3-0.1.beta1
488 - Update to rrdtool 1.3 beta1
489
490 * Tue Jul 10 2007 Jarod Wilson <jwilson@redhat.com> 1.2.999-0.3.r1144
491 - Update to latest rrdtool pre-1.3 svn snapshot (svn r1144)
492 - Add php abi check (Resolves: #247339)
493
494 * Fri Jun 15 2007 Jarod Wilson <jwilson@redhat.com> 1.2.999-0.2.r1127
495 - Fix up BuildRequires
496
497 * Fri Jun 15 2007 Jarod Wilson <jwilson@redhat.com> 1.2.999-0.1.r1127
498 - Update to rrdtool pre-1.3 svn snapshot (svn r1127)
499
500 * Mon May 21 2007 Jarod Wilson <jwilson@redhat.com> 1.2.23-5
501 - BR: ruby so %%ruby_sitearch gets set
502
503 * Mon May 21 2007 Jarod Wilson <jwilson@redhat.com> 1.2.23-4
504 - Build ruby bindings
505
506 * Thu May 03 2007 Jarod Wilson <jwilson@redhat.com> 1.2.23-3
507 - Disable php bits on ppc64 for now, they fail to build
508
509 * Thu May 03 2007 Jarod Wilson <jwilson@redhat.com> 1.2.23-2
510 - Add BR: perl-devel for Fedora 7 and later
511
512 * Tue May 01 2007 Jarod Wilson <jwilson@redhat.com> 1.2.23-1
513 - New upstream release
514
515 * Tue May 01 2007 Jarod Wilson <jwilson@redhat.com> 1.2.21-1
516 - New upstream release
517
518 * Wed Apr 25 2007 Jarod Wilson <jwilson@redhat.com> 1.2.19-2
519 - Define %%python_version *before* its needed (#237826)
520
521 * Mon Apr 09 2007 Jarod Wilson <jwilson@redhat.com> 1.2.19-1
522 - New upstream release
523
524 * Tue Jan 23 2007 Jarod Wilson <jwilson@redhat.com> 1.2.18-1
525 - New upstream release
526
527 * Mon Jan 22 2007 Jarod Wilson <jwilson@redhat.com> 1.2.17-1
528 - New upstream release
529
530 * Tue Jan 02 2007 Jarod Wilson <jwilson@redhat.com> 1.2.15-9
531 - Fix crash with long error strings (upstream
532   changesets 929 and 935)
533
534 * Thu Dec 14 2006 Jarod Wilson <jwilson@redhat.com> 1.2.15-8
535 - Fix for log grid memory leak (#201241)
536
537 * Tue Dec 12 2006 Jarod Wilson <jwilson@redhat.com> 1.2.15-7
538 - Rebuild for python 2.5
539
540 * Tue Nov 14 2006 Jarod Wilson <jwilson@redhat.com> 1.2.15-6
541 - Conditionalize python, php and tcl bits (Resolves #203275)
542
543 * Wed Oct 25 2006 Jarod Wilson <jwilson@redhat.com> 1.2.15-5
544 - Add tcl sub-package (#203275)
545
546 * Tue Sep 05 2006 Jarod Wilson <jwilson@redhat.com> 1.2.15-4
547 - Rebuild for new glibc
548
549 * Wed Aug 02 2006 Jarod Wilson <jwilson@redhat.com> 1.2.15-3
550 - One more addition to initrrdtool patch, to fully revert
551   and correct upstream changeset 839
552 - Fix for no python in minimal fc4 buildroots
553
554 * Tue Aug  1 2006 Mihai Ibanescu <misa@redhat.com> 1.2.15-2
555 - Fixed rrdtool-python to import the module properly (patch
556   rrdtool-1.2.15-initrrdtool.patch)
557
558 * Mon Jul 17 2006 Jarod Wilson <jwilson@redhat.com> 1.2.15-1
559 - Update to 1.2.15
560 - Minor spec cleanups
561
562 * Sat Jun 24 2006 Jarod Wilson <jwilson@redhat.com> 1.2.13-7
563 - Fix up Obsoletes
564
565 * Mon Jun 19 2006 Jarod Wilson <jwilson@redhat.com> 1.2.13-6
566 - Flip perl, php and python sub-package names around to 
567   conform with general practices
568
569 * Sat Jun 10 2006 Jarod Wilson <jwilson@redhat.com> 1.2.13-5
570 - Minor fixes to make package own created directories
571
572 * Wed Jun 07 2006 Jarod Wilson <jwilson@redhat.com> 1.2.13-4
573 - Add php bits back into the mix
574
575 * Mon Jun 05 2006 Jarod Wilson <jwilson@redhat.com> 1.2.13-3
576 - Merge spec fixes from bz 185909
577
578 * Sun Jun 04 2006 Jarod Wilson <jwilson@redhat.com> 1.2.13-2
579 - Remove explicit perl dep, version grabbing using rpm during
580   rpmbuild not guaranteed to work (fails on ppc in plague),
581   and auto-gen perl deps are sufficient
582
583 * Sat Jun 03 2006 Jarod Wilson <jwilson@redhat.com> 1.2.13-1
584 - Update to release 1.2.13
585 - Merge spec changes from dag, atrpms and mdk builds
586 - Additional hacktastic contortions for lib64 & rpath messiness
587 - Add missing post/postun ldconfig
588 - Fix a bunch of rpmlint errors
589 - Disable static libs, per FE guidelines
590 - Split off docs
591
592 * Wed Apr 19 2006 Chris Ricker <kaboom@oobleck.net> 1.2.12-1
593 - Rev to 1.2
594
595 * Fri May 20 2005 Matthias Saou <http://freshrpms.net/> 1.0.49-5
596 - Include patch from Michael to fix perl module compilation on FC4 (#156242).
597
598 * Fri May 20 2005 Matthias Saou <http://freshrpms.net/> 1.0.49-4
599 - Fix for the php module patch (Joe Pruett, Dag Wieers), #156716.
600 - Update source URL to new location since 1.2 is now the default stable.
601 - Don't (yet) update to 1.0.50, as it introduces some changes in the perl
602   modules install.
603
604 * Mon Jan 31 2005 Matthias Saou <http://freshrpms.net/> 1.0.49-3
605 - Put perl modules in vendor_perl and not site_perl. #146513
606
607 * Thu Jan 13 2005 Matthias Saou <http://freshrpms.net/> 1.0.49-2
608 - Minor cleanups.
609
610 * Thu Aug 25 2004 Dag Wieers <dag@wieers.com> - 1.0.49-1
611 - Updated to release 1.0.49.
612
613 * Wed Aug 25 2004 Dag Wieers <dag@wieers.com> - 1.0.48-3
614 - Fixes for x86_64. (Garrick Staples)
615
616 * Fri Jul  2 2004 Matthias Saou <http://freshrpms.net/> 1.0.48-3
617 - Actually apply the patch for fixing the php module, doh!
618
619 * Thu May 27 2004 Matthias Saou <http://freshrpms.net/> 1.0.48-2
620 - Added php.d config entry to load the module once installed.
621
622 * Thu May 13 2004 Dag Wieers <dag@wieers.com> - 1.0.48-1
623 - Updated to release 1.0.48.
624
625 * Tue Apr 06 2004 Dag Wieers <dag@wieers.com> - 1.0.47-1
626 - Updated to release 1.0.47.
627
628 * Thu Mar  4 2004 Matthias Saou <http://freshrpms.net/> 1.0.46-2
629 - Change the strict dependency on perl to fix problem with the recent
630   update.
631
632 * Mon Jan  5 2004 Matthias Saou <http://freshrpms.net/> 1.0.46-1
633 - Update to 1.0.46.
634 - Use system libpng and zlib instead of bundled ones.
635 - Added php-rrdtool sub-package for the php4 module.
636
637 * Fri Dec  5 2003 Matthias Saou <http://freshrpms.net/> 1.0.45-4
638 - Added epoch to the perl dependency to work with rpm > 4.2.
639 - Fixed the %% escaping in the perl dep.
640
641 * Mon Nov 17 2003 Matthias Saou <http://freshrpms.net/> 1.0.45-2
642 - Rebuild for Fedora Core 1.
643
644 * Sun Aug  3 2003 Matthias Saou <http://freshrpms.net/>
645 - Update to 1.0.45.
646
647 * Wed Apr 16 2003 Matthias Saou <http://freshrpms.net/>
648 - Update to 1.0.42.
649
650 * Mon Mar 31 2003 Matthias Saou <http://freshrpms.net/>
651 - Rebuilt for Red Hat Linux 9.
652
653 * Wed Mar  5 2003 Matthias Saou <http://freshrpms.net/>
654 - Added explicit perl version dependency.
655
656 * Sun Feb 23 2003 Matthias Saou <http://freshrpms.net/>
657 - Update to 1.0.41.
658
659 * Fri Jan 31 2003 Matthias Saou <http://freshrpms.net/>
660 - Update to 1.0.40.
661 - Spec file cleanup.
662
663 * Fri Jul 05 2002 Henri Gomez <hgomez@users.sourceforge.net>
664 - 1.0.39
665
666 * Mon Jun 03 2002 Henri Gomez <hgomez@users.sourceforge.net>
667 - 1.0.38
668
669 * Fri Apr 19 2002 Henri Gomez <hgomez@users.sourceforge.net>
670 - 1.0.37
671
672 * Tue Mar 12 2002 Henri Gomez <hgomez@users.sourceforge.net>
673 - 1.0.34
674 - rrdtools include zlib 1.1.4 which fix vulnerabilities in 1.1.3
675