This patch introduces "fast shutdown" mode and two new signals.
[rrdtool.git] / rrdtool.spec
1 %define with_python %{?_without_python: 0} %{?!_without_python: 1}
2 %define with_php %{?_without_php: 0} %{?!_without_php: 1}
3 %define with_tcl %{?_without_tcl: 0} %{?!_without_tcl: 1}
4 %define with_ruby %{?_without_ruby: 0} %{?!_without_ruby: 1}
5 %define php_extdir %(php-config --extension-dir 2>/dev/null || echo %{_libdir}/php4)
6 %define svnrev r1190
7 %define pre rc9
8 #define pretag 1.2.99908020600
9
10 Summary: Round Robin Database Tool to store and display time-series data
11 Name: rrdtool
12 Version: 1.3.2
13 Release: 0.20%{?pre:.%{pre}}%{?dist}
14 License: GPLv2+ with exceptions
15 Group: Applications/Databases
16 URL: http://oss.oetiker.ch/rrdtool/
17 #Source0: http://oss.oetiker.ch/%{name}/pub/%{name}-%{version}.tar.gz
18 Source0: http://oss.oetiker.ch/rrdtool/pub/beta/%{name}-%{version}%{pre}.tar.gz
19 %if %{with_php}
20 Source1: php4-%{svnrev}.tar.gz
21 Patch1: rrdtool-1.3.0-beta4-fix-rrd_update-in-php-bindings.patch
22 %endif
23 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
24 Requires: dejavu-lgc-fonts
25 BuildRequires: gcc-c++, openssl-devel, freetype-devel
26 BuildRequires: libpng-devel, zlib-devel, intltool >= 0.35.0
27 BuildRequires: cairo-devel >= 1.4.6, pango-devel >= 1.17
28 BuildRequires: libtool, groff
29 BuildRequires: gettext, libxml2-devel
30 %if 0%{?fedora} >= 7
31 BuildRequires: perl-ExtUtils-MakeMaker perl-devel
32 %endif
33
34 %description
35 RRD is the Acronym for Round Robin Database. RRD is a system to store and
36 display time-series data (i.e. network bandwidth, machine-room temperature,
37 server load average). It stores the data in a very compact way that will not
38 expand over time, and it presents useful graphs by processing the data to
39 enforce a certain data density. It can be used either via simple wrapper
40 scripts (from shell or Perl) or via frontends that poll network devices and
41 put a friendly user interface on it.
42
43 %package devel
44 Summary: RRDtool libraries and header files
45 Group: Development/Libraries
46 Requires: %{name} = %{version}-%{release}
47
48 %description devel
49 RRD is the Acronym for Round Robin Database. RRD is a system to store and
50 display time-series data (i.e. network bandwidth, machine-room temperature,
51 server load average). This package allow you to use directly this library.
52
53 %package doc
54 Summary: RRDtool documentation
55 Group: Documentation
56
57 %description doc
58 RRD is the Acronym for Round Robin Database. RRD is a system to store and
59 display time-series data (i.e. network bandwidth, machine-room temperature,
60 server load average). This package contains documentation on using RRD.
61
62 %package perl
63 Summary: Perl RRDtool bindings
64 Group: Development/Languages
65 Requires: %{name} = %{version}-%{release}
66 Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
67 Obsoletes: perl-%{name} < %{version}-%{release}
68 Provides: perl-%{name} = %{version}-%{release}
69
70 %description perl
71 The Perl RRDtool bindings
72
73 %if %{with_python}
74 %{!?python_sitearch: %define python_sitearch %(%{__python} -c 'from distutils import sysconfig; print sysconfig.get_python_lib(1)')}
75 # eval to 2.3 if python isn't yet present, workaround for no python in fc4 minimal buildroot
76 %{!?python_version: %define python_version %(%{__python} -c 'import sys; print sys.version.split(" ")[0]' || echo "2.3")}
77
78 %package python
79 Summary: Python RRDtool bindings
80 Group: Development/Languages
81 BuildRequires: python-devel >= 2.3
82 Requires: python >= %{python_version}
83 Requires: %{name} = %{version}-%{release}
84 Obsoletes: python-%{name} < %{version}-%{release}
85 Provides: python-%{name} = %{version}-%{release}
86
87 %description python
88 Python RRDtool bindings.
89 %endif
90
91 %ifarch ppc64
92 # php bits busted on ppc64 at the moment
93 %define with_php 0
94 %endif
95
96 %if %{with_php}
97 %package php
98 Summary: PHP RRDtool bindings
99 Group: Development/Languages
100 BuildRequires: php-devel >= 4.0
101 Requires: php >= 4.0
102 Requires: %{name} = %{version}-%{release}
103 %if 0%{?php_zend_api}
104 Requires: php(zend-abi) = %{php_zend_api}
105 Requires: php(api) = %{php_core_api}
106 %else
107 Requires: php-api = %{php_apiver}
108 %endif
109 Obsoletes: php-%{name} < %{version}-%{release}
110 Provides: php-%{name} = %{version}-%{release}
111 Provides: php-pecl(rrdtool)
112
113 %description php
114 The %{name}-php package includes a dynamic shared object (DSO) that adds
115 RRDtool bindings to the PHP HTML-embedded scripting language.
116 %endif
117
118 %if %{with_tcl}
119 %package tcl
120 Summary: Tcl RRDtool bindings
121 Group: Development/Languages
122 BuildRequires: tcl-devel >= 8.0
123 Requires: tcl >= 8.0
124 Requires: %{name} = %{version}-%{release}
125 Obsoletes: tcl-%{name} < %{version}-%{release}
126 Provides: tcl-%{name} = %{version}-%{release}
127
128 %description tcl
129 The %{name}-tcl package includes RRDtool bindings for Tcl.
130 %endif
131
132 %if %{with_ruby}
133 %{!?ruby_sitearch: %define ruby_sitearch %(ruby -rrbconfig -e 'puts Config::CONFIG["sitearchdir"]')}
134
135 %package ruby
136 Summary: Ruby RRDtool bindings
137 Group: Development/Languages
138 BuildRequires: ruby, ruby-devel
139 Requires: ruby(abi) = 1.8
140 Requires: %{name} = %{version}-%{release}
141
142 %description ruby
143 The %{name}-ruby package includes RRDtool bindings for Ruby.
144 %endif
145
146 %prep
147 %if %{with_php}
148 %setup -q -n %{name}-%{version}%{pre} -a 1
149 %patch1 -p1
150 %else
151 %setup -q -n %{name}-%{version}%{pre}
152 %endif
153
154 # Fix to find correct python dir on lib64
155 %{__perl} -pi -e 's|get_python_lib\(0,0,prefix|get_python_lib\(1,0,prefix|g' \
156     configure
157
158 # Most edits shouldn't be necessary when using --libdir, but
159 # w/o, some introduce hardcoded rpaths where they shouldn't
160 %{__perl} -pi.orig -e 's|/lib\b|/%{_lib}|g' configure Makefile.in*
161 %if %{with_php}
162 %{__perl} -pi.orig -e 's|/lib\b|/%{_lib}|g' php4/configure php4/ltconfig*
163 %endif
164
165 # Perl 5.10 seems to not like long version strings, hack around it
166 %{__perl} -pi.orig -e 's|1.299907080300|1.29990708|' \
167     bindings/perl-shared/RRDs.pm bindings/perl-piped/RRDp.pm
168
169 #
170 # fix config files for php4 bindings
171 # workaround needed due to https://bugzilla.redhat.com/show_bug.cgi?id=211069
172 %if %{with_php}
173 cp -p /usr/lib/rpm/config.{guess,sub} php4/
174 %endif
175
176
177 %build
178 %configure \
179     --with-perl-options='INSTALLDIRS="vendor"' \
180 %if %{with_tcl}
181     --enable-tcl-site \
182     --with-tcllib=%{_libdir} \
183 %else
184     --disable-tcl \
185 %endif
186 %if %{with_python}
187     --enable-python \
188 %else
189     --disable-python \
190 %endif
191 %if %{with_ruby}
192     --enable-ruby \
193 %endif
194     --disable-static \
195     --with-pic
196
197 # Fix another rpath issue
198 %{__perl} -pi.orig -e 's|-Wl,--rpath -Wl,\$rp||g' \
199     bindings/perl-shared/Makefile.PL
200
201 # Force RRDp bits where we want 'em, not sure yet why the
202 # --with-perl-options and --libdir don't take
203 pushd bindings/perl-piped/
204 %{__perl} Makefile.PL INSTALLDIRS=vendor
205 %{__perl} -pi.orig -e 's|/lib/perl|/%{_lib}/perl|g' Makefile
206 popd
207
208 #{__make} %{?_smp_mflags}
209 make
210
211 # Build the php module, the tmp install is required
212 %if %{with_php}
213 %define rrdtmp %{_tmppath}/%{name}-%{version}-tmpinstall
214 %{__make} install DESTDIR="%{rrdtmp}"
215 pushd php4/
216 %configure \
217     --with-rrdtool="%{rrdtmp}%{_prefix}" \
218     --disable-static
219 #{__make} %{?_smp_mflags}
220 make
221 popd
222 %{__rm} -rf %{rrdtmp}
223 %endif
224
225 # Fix @perl@ and @PERL@
226 find examples/ -type f \
227     -exec %{__perl} -pi -e 's|^#! \@perl\@|#!%{__perl}|gi' {} \;
228 find examples/ -name "*.pl" \
229     -exec %{__perl} -pi -e 's|\015||gi' {} \;
230
231 %install
232 rm -rf $RPM_BUILD_ROOT
233 make DESTDIR="$RPM_BUILD_ROOT" install
234
235 # Install the php module
236 %if %{with_php}
237 %{__install} -D -m0755 php4/modules/rrdtool.so \
238     %{buildroot}%{php_extdir}/rrdtool.so
239 # Clean up the examples for inclusion as docs
240 %{__rm} -rf php4/examples/.svn
241 # Put the php config bit into place
242 %{__mkdir_p} %{buildroot}%{_sysconfdir}/php.d
243 %{__cat} << __EOF__ > %{buildroot}%{_sysconfdir}/php.d/rrdtool.ini
244 ; Enable rrdtool extension module
245 extension=rrdtool.so
246 __EOF__
247 %endif
248
249 # Pesky RRDp.pm...
250 %{__mv} $RPM_BUILD_ROOT%{perl_vendorarch}/../RRDp.pm $RPM_BUILD_ROOT%{perl_vendorarch}/
251
252 # Dunno why this is getting installed here...
253 %{__rm} -f $RPM_BUILD_ROOT%{perl_vendorarch}/../leaktest.pl
254
255 # We only want .txt and .html files for the main documentation
256 %{__mkdir_p} doc2/html doc2/txt
257 %{__cp} -a doc/*.txt doc2/txt/
258 %{__cp} -a doc/*.html doc2/html/
259
260 # Put perl docs in perl package
261 %{__mkdir_p} doc3/html
262 %{__mv} doc2/html/RRD*.html doc3/html/
263
264 # Clean up the examples
265 %{__rm} -f examples/Makefile* examples/*.in
266
267 # This is so rpm doesn't pick up perl module dependencies automatically
268 find examples/ -type f -exec chmod 0644 {} \;
269
270 # Clean up the buildroot
271 %{__rm} -rf $RPM_BUILD_ROOT%{_docdir}/%{name}-* \
272         $RPM_BUILD_ROOT%{perl_vendorarch}/ntmake.pl \
273         $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod \
274         $RPM_BUILD_ROOT%{_datadir}/%{name}/examples \
275         $RPM_BUILD_ROOT%{perl_vendorarch}/auto/*/{.packlist,*.bs}
276
277 %clean
278 %{__rm} -rf $RPM_BUILD_ROOT
279
280 %post -p /sbin/ldconfig
281
282 %postun -p /sbin/ldconfig
283
284 %files
285 %defattr(-,root,root,-)
286 %{_bindir}/*
287 %{_libdir}/*.so.*
288 %{_datadir}/%{name}
289 %{_mandir}/man1/*
290
291 %files devel
292 %defattr(-,root,root,-)
293 %{_includedir}/*.h
294 %exclude %{_libdir}/*.la
295 %{_libdir}/*.so
296
297 %files doc
298 %defattr(-,root,root,-)
299 %doc CONTRIBUTORS COPYING COPYRIGHT README TODO NEWS THREADS
300 %doc examples doc2/html doc2/txt
301
302 %files perl
303 %defattr(-,root,root,-)
304 %doc doc3/html
305 %{_mandir}/man3/*
306 %{perl_vendorarch}/*.pm
307 %attr(0755,root,root) %{perl_vendorarch}/auto/RRDs/
308
309 %if %{with_python}
310 %files python
311 %defattr(-,root,root,-)
312 %doc bindings/python/AUTHORS bindings/python/COPYING bindings/python/README
313 %{python_sitearch}/rrdtoolmodule.so
314 %{python_sitearch}/py_rrdtool-*.egg-info
315 %endif
316
317 %if %{with_php}
318 %files php
319 %defattr(-,root,root,0755)
320 %doc php4/examples php4/README
321 %config(noreplace) %{_sysconfdir}/php.d/rrdtool.ini
322 %{php_extdir}/rrdtool.so
323 %endif
324
325 %if %{with_tcl}
326 %files tcl
327 %defattr(-,root,root,-)
328 %doc bindings/tcl/README
329 %{_libdir}/tclrrd*.so
330 %{_libdir}/rrdtool/*.tcl
331 %endif
332
333 %if %{with_ruby}
334 %files ruby
335 %defattr(-,root,root,-)
336 %doc bindings/ruby/README
337 %{ruby_sitearch}/RRD.so
338 %endif
339
340 %changelog
341 * Sun Jun 08 2008 Jarod Wilson <jwilson@redhat.com> 1.3-0.20.rc9
342 - Update to rrdtool 1.3 rc9
343 - Minor spec tweaks to permit building on older EL
344
345 * Wed Jun 04 2008 Chris Ricker <kaboom@oobleck.net> 1.3-0.19.rc7
346 - Update to rrdtool 1.3 rc7
347
348 * Tue May 27 2008 Chris Ricker <kaboom@oobleck.net> 1.3-0.18.rc6
349 - Update to rrdtool 1.3 rc6
350
351 * Wed May 21 2008 Chris Ricker <kaboom@oobleck.net> 1.3-0.17.rc4
352 - Bump version and rebuild
353
354 * Wed May 21 2008 Chris Ricker <kaboom@oobleck.net> 1.3-0.16.rc4
355 - Fix php bindings compile on x86_64
356
357 * Mon May 19 2008 Chris Ricker <kaboom@oobleck.net> 1.3-0.15.rc4
358 - Update to rrdtool 1.3 rc4
359
360 * Tue May 13 2008 Jarod Wilson <jwilson@redhat.com> 1.3-0.15.rc1
361 - Update to rrdtool 1.3 rc1
362 - Fix versioning in changelog entries, had an extra 0 in there...
363 - Drop cairo and python patches, they're in 1.3 rc1
364 - Add Requires: gettext and libxml2-devel for new translations
365
366 * Wed Apr 30 2008 Jarod Wilson <jwilson@redhat.com> 1.3-0.14.beta4
367 - Drop some conditional flags, they're not working at the moment...
368
369 * Wed Apr 30 2008 Jarod Wilson <jwilson@redhat.com> 1.3-0.13.beta4
370 - Fix problem with cairo_save/cairo_restore (#444827)
371
372 * Wed Apr 23 2008 Jarod Wilson <jwilson@redhat.com> 1.3-0.12.beta4
373 - Fix python bindings rrdtool info implementation (#435468)
374
375 * Tue Apr 08 2008 Jarod Wilson <jwilson@redhat.com> 1.3-0.11.beta4
376 - Work around apparent version string length issue w/perl 5.10 (#441359)
377
378 * Sat Apr 05 2008 Jarod Wilson <jwilson@redhat.com> 1.3-0.10.beta4
379 - Fix use of rrd_update in php bindings (#437558)
380
381 * Mon Mar  3 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.3-0.9.beta4
382 - rebuild for new perl (again)
383
384 * Wed Feb 13 2008 Jarod Wilson <jwilson@redhat.com> 1.3-0.8.beta4
385 - Update to rrdtool 1.3 beta4
386
387 * Tue Feb 05 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.3-0.7.beta3
388 - rebuild for new perl (and fix license tag)
389
390 * Mon Feb 04 2008 Jarod Wilson <jwilson@redhat.com> 1.3-0.6.beta3
391 - Plug memory leak (#430879)
392
393 * Mon Jan 07 2008 Jarod Wilson <jwilson@redhat.com> 1.3-0.5.beta3
394 - Fix right-aligned text alignment and scaling (Resolves: #427609)
395
396 * Wed Jan 02 2008 Jarod Wilson <jwilson@redhat.com> 1.3-0.4.beta3
397 - Add newly built python egg to %%files
398
399 * Wed Jan 02 2008 Jarod Wilson <jwilson@redhat.com> 1.3-0.3.beta3
400 - Update to rrdtool 1.3 beta3
401 - Return properly from errors in RRDp.pm (Resolves: #427040)
402 - Requires: dejavu-lgc-fonts (Resolves: #426935)
403
404 * Thu Dec 06 2007 Jarod Wilson <jwilson@redhat.com> 1.3-0.2.beta2
405 - Update to rrdtool 1.3 beta2
406
407 * Wed Aug 08 2007 Jarod Wilson <jwilson@redhat.com> 1.3-0.1.beta1
408 - Update to rrdtool 1.3 beta1
409
410 * Tue Jul 10 2007 Jarod Wilson <jwilson@redhat.com> 1.2.999-0.3.r1144
411 - Update to latest rrdtool pre-1.3 svn snapshot (svn r1144)
412 - Add php abi check (Resolves: #247339)
413
414 * Fri Jun 15 2007 Jarod Wilson <jwilson@redhat.com> 1.2.999-0.2.r1127
415 - Fix up BuildRequires
416
417 * Fri Jun 15 2007 Jarod Wilson <jwilson@redhat.com> 1.2.999-0.1.r1127
418 - Update to rrdtool pre-1.3 svn snapshot (svn r1127)
419
420 * Mon May 21 2007 Jarod Wilson <jwilson@redhat.com> 1.2.23-5
421 - BR: ruby so %%ruby_sitearch gets set
422
423 * Mon May 21 2007 Jarod Wilson <jwilson@redhat.com> 1.2.23-4
424 - Build ruby bindings
425
426 * Thu May 03 2007 Jarod Wilson <jwilson@redhat.com> 1.2.23-3
427 - Disable php bits on ppc64 for now, they fail to build
428
429 * Thu May 03 2007 Jarod Wilson <jwilson@redhat.com> 1.2.23-2
430 - Add BR: perl-devel for Fedora 7 and later
431
432 * Tue May 01 2007 Jarod Wilson <jwilson@redhat.com> 1.2.23-1
433 - New upstream release
434
435 * Tue May 01 2007 Jarod Wilson <jwilson@redhat.com> 1.2.21-1
436 - New upstream release
437
438 * Wed Apr 25 2007 Jarod Wilson <jwilson@redhat.com> 1.2.19-2
439 - Define %%python_version *before* its needed (#237826)
440
441 * Mon Apr 09 2007 Jarod Wilson <jwilson@redhat.com> 1.2.19-1
442 - New upstream release
443
444 * Tue Jan 23 2007 Jarod Wilson <jwilson@redhat.com> 1.2.18-1
445 - New upstream release
446
447 * Mon Jan 22 2007 Jarod Wilson <jwilson@redhat.com> 1.2.17-1
448 - New upstream release
449
450 * Tue Jan 02 2007 Jarod Wilson <jwilson@redhat.com> 1.2.15-9
451 - Fix crash with long error strings (upstream
452   changesets 929 and 935)
453
454 * Thu Dec 14 2006 Jarod Wilson <jwilson@redhat.com> 1.2.15-8
455 - Fix for log grid memory leak (#201241)
456
457 * Tue Dec 12 2006 Jarod Wilson <jwilson@redhat.com> 1.2.15-7
458 - Rebuild for python 2.5
459
460 * Tue Nov 14 2006 Jarod Wilson <jwilson@redhat.com> 1.2.15-6
461 - Conditionalize python, php and tcl bits (Resolves #203275)
462
463 * Wed Oct 25 2006 Jarod Wilson <jwilson@redhat.com> 1.2.15-5
464 - Add tcl sub-package (#203275)
465
466 * Tue Sep 05 2006 Jarod Wilson <jwilson@redhat.com> 1.2.15-4
467 - Rebuild for new glibc
468
469 * Wed Aug 02 2006 Jarod Wilson <jwilson@redhat.com> 1.2.15-3
470 - One more addition to initrrdtool patch, to fully revert
471   and correct upstream changeset 839
472 - Fix for no python in minimal fc4 buildroots
473
474 * Tue Aug  1 2006 Mihai Ibanescu <misa@redhat.com> 1.2.15-2
475 - Fixed rrdtool-python to import the module properly (patch
476   rrdtool-1.2.15-initrrdtool.patch)
477
478 * Mon Jul 17 2006 Jarod Wilson <jwilson@redhat.com> 1.2.15-1
479 - Update to 1.2.15
480 - Minor spec cleanups
481
482 * Sat Jun 24 2006 Jarod Wilson <jwilson@redhat.com> 1.2.13-7
483 - Fix up Obsoletes
484
485 * Mon Jun 19 2006 Jarod Wilson <jwilson@redhat.com> 1.2.13-6
486 - Flip perl, php and python sub-package names around to 
487   conform with general practices
488
489 * Sat Jun 10 2006 Jarod Wilson <jwilson@redhat.com> 1.2.13-5
490 - Minor fixes to make package own created directories
491
492 * Wed Jun 07 2006 Jarod Wilson <jwilson@redhat.com> 1.2.13-4
493 - Add php bits back into the mix
494
495 * Mon Jun 05 2006 Jarod Wilson <jwilson@redhat.com> 1.2.13-3
496 - Merge spec fixes from bz 185909
497
498 * Sun Jun 04 2006 Jarod Wilson <jwilson@redhat.com> 1.2.13-2
499 - Remove explicit perl dep, version grabbing using rpm during
500   rpmbuild not guaranteed to work (fails on ppc in plague),
501   and auto-gen perl deps are sufficient
502
503 * Sat Jun 03 2006 Jarod Wilson <jwilson@redhat.com> 1.2.13-1
504 - Update to release 1.2.13
505 - Merge spec changes from dag, atrpms and mdk builds
506 - Additional hacktastic contortions for lib64 & rpath messiness
507 - Add missing post/postun ldconfig
508 - Fix a bunch of rpmlint errors
509 - Disable static libs, per FE guidelines
510 - Split off docs
511
512 * Wed Apr 19 2006 Chris Ricker <kaboom@oobleck.net> 1.2.12-1
513 - Rev to 1.2
514
515 * Fri May 20 2005 Matthias Saou <http://freshrpms.net/> 1.0.49-5
516 - Include patch from Michael to fix perl module compilation on FC4 (#156242).
517
518 * Fri May 20 2005 Matthias Saou <http://freshrpms.net/> 1.0.49-4
519 - Fix for the php module patch (Joe Pruett, Dag Wieers), #156716.
520 - Update source URL to new location since 1.2 is now the default stable.
521 - Don't (yet) update to 1.0.50, as it introduces some changes in the perl
522   modules install.
523
524 * Mon Jan 31 2005 Matthias Saou <http://freshrpms.net/> 1.0.49-3
525 - Put perl modules in vendor_perl and not site_perl. #146513
526
527 * Thu Jan 13 2005 Matthias Saou <http://freshrpms.net/> 1.0.49-2
528 - Minor cleanups.
529
530 * Thu Aug 25 2004 Dag Wieers <dag@wieers.com> - 1.0.49-1
531 - Updated to release 1.0.49.
532
533 * Wed Aug 25 2004 Dag Wieers <dag@wieers.com> - 1.0.48-3
534 - Fixes for x86_64. (Garrick Staples)
535
536 * Fri Jul  2 2004 Matthias Saou <http://freshrpms.net/> 1.0.48-3
537 - Actually apply the patch for fixing the php module, doh!
538
539 * Thu May 27 2004 Matthias Saou <http://freshrpms.net/> 1.0.48-2
540 - Added php.d config entry to load the module once installed.
541
542 * Thu May 13 2004 Dag Wieers <dag@wieers.com> - 1.0.48-1
543 - Updated to release 1.0.48.
544
545 * Tue Apr 06 2004 Dag Wieers <dag@wieers.com> - 1.0.47-1
546 - Updated to release 1.0.47.
547
548 * Thu Mar  4 2004 Matthias Saou <http://freshrpms.net/> 1.0.46-2
549 - Change the strict dependency on perl to fix problem with the recent
550   update.
551
552 * Mon Jan  5 2004 Matthias Saou <http://freshrpms.net/> 1.0.46-1
553 - Update to 1.0.46.
554 - Use system libpng and zlib instead of bundled ones.
555 - Added php-rrdtool sub-package for the php4 module.
556
557 * Fri Dec  5 2003 Matthias Saou <http://freshrpms.net/> 1.0.45-4
558 - Added epoch to the perl dependency to work with rpm > 4.2.
559 - Fixed the %% escaping in the perl dep.
560
561 * Mon Nov 17 2003 Matthias Saou <http://freshrpms.net/> 1.0.45-2
562 - Rebuild for Fedora Core 1.
563
564 * Sun Aug  3 2003 Matthias Saou <http://freshrpms.net/>
565 - Update to 1.0.45.
566
567 * Wed Apr 16 2003 Matthias Saou <http://freshrpms.net/>
568 - Update to 1.0.42.
569
570 * Mon Mar 31 2003 Matthias Saou <http://freshrpms.net/>
571 - Rebuilt for Red Hat Linux 9.
572
573 * Wed Mar  5 2003 Matthias Saou <http://freshrpms.net/>
574 - Added explicit perl version dependency.
575
576 * Sun Feb 23 2003 Matthias Saou <http://freshrpms.net/>
577 - Update to 1.0.41.
578
579 * Fri Jan 31 2003 Matthias Saou <http://freshrpms.net/>
580 - Update to 1.0.40.
581 - Spec file cleanup.
582
583 * Fri Jul 05 2002 Henri Gomez <hgomez@users.sourceforge.net>
584 - 1.0.39
585
586 * Mon Jun 03 2002 Henri Gomez <hgomez@users.sourceforge.net>
587 - 1.0.38
588
589 * Fri Apr 19 2002 Henri Gomez <hgomez@users.sourceforge.net>
590 - 1.0.37
591
592 * Tue Mar 12 2002 Henri Gomez <hgomez@users.sourceforge.net>
593 - 1.0.34
594 - rrdtools include zlib 1.1.4 which fix vulnerabilities in 1.1.3
595