8df98fa921097b581ad4c41f5685dab73d09013d
[rrdtool.git] / rrdtool.spec
1 %define with_python %{?_without_python: 0} %{?!_without_python: 1}
2 %define with_php %{?_without_php: 0} %{?!_without_php: 1}
3 %define with_tcl %{?_without_tcl: 0} %{?!_without_tcl: 1}
4 %define with_ruby %{?_without_ruby: 0} %{?!_without_ruby: 1}
5 %define php_extdir %(php-config --extension-dir 2>/dev/null || echo %{_libdir}/php4)
6 %define svnrev r1190
7 %define pre rc9
8 #define pretag 1.2.99908020600
9
10 Summary: Round Robin Database Tool to store and display time-series data
11 Name: rrdtool
12 Version: 1.3.99908093000
13 Release: 0.20%{?pre:.%{pre}}%{?dist}
14 License: GPLv2+ with exceptions
15 Group: Applications/Databases
16 URL: http://oss.oetiker.ch/rrdtool/
17 #Source0: http://oss.oetiker.ch/%{name}/pub/%{name}-%{version}.tar.gz
18 Source0: http://oss.oetiker.ch/rrdtool/pub/beta/%{name}-%{version}.tar.gz
19 %if %{with_php}
20 Source1: php4-%{svnrev}.tar.gz
21 Patch1: rrdtool-1.3.0-beta4-fix-rrd_update-in-php-bindings.patch
22 %endif
23 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
24 Requires: dejavu-lgc-fonts
25 BuildRequires: gcc-c++, openssl-devel, freetype-devel
26 BuildRequires: libpng-devel, zlib-devel, intltool >= 0.35.0
27 BuildRequires: cairo-devel >= 1.2, pango-devel >= 1.14
28 BuildRequires: libtool, groff
29 BuildRequires: gettext, libxml2-devel
30 %if 0%{?fedora} >= 7
31 BuildRequires: perl-ExtUtils-MakeMaker perl-devel
32 %endif
33
34 %description
35 RRD is the Acronym for Round Robin Database. RRD is a system to store and
36 display time-series data (i.e. network bandwidth, machine-room temperature,
37 server load average). It stores the data in a very compact way that will not
38 expand over time, and it presents useful graphs by processing the data to
39 enforce a certain data density. It can be used either via simple wrapper
40 scripts (from shell or Perl) or via frontends that poll network devices and
41 put a friendly user interface on it.
42
43 %package devel
44 Summary: RRDtool libraries and header files
45 Group: Development/Libraries
46 Requires: %{name} = %{version}-%{release}
47
48 %description devel
49 RRD is the Acronym for Round Robin Database. RRD is a system to store and
50 display time-series data (i.e. network bandwidth, machine-room temperature,
51 server load average). This package allow you to use directly this library.
52
53 %package doc
54 Summary: RRDtool documentation
55 Group: Documentation
56
57 %description doc
58 RRD is the Acronym for Round Robin Database. RRD is a system to store and
59 display time-series data (i.e. network bandwidth, machine-room temperature,
60 server load average). This package contains documentation on using RRD.
61
62 %package perl
63 Summary: Perl RRDtool bindings
64 Group: Development/Languages
65 Requires: %{name} = %{version}-%{release}
66 Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
67 Obsoletes: perl-%{name} < %{version}-%{release}
68 Provides: perl-%{name} = %{version}-%{release}
69
70 %description perl
71 The Perl RRDtool bindings
72
73 %if %{with_python}
74 %{!?python_sitearch: %define python_sitearch %(%{__python} -c 'from distutils import sysconfig; print sysconfig.get_python_lib(1)')}
75 # eval to 2.3 if python isn't yet present, workaround for no python in fc4 minimal buildroot
76 %{!?python_version: %define python_version %(%{__python} -c 'import sys; print sys.version.split(" ")[0]' || echo "2.3")}
77
78 %package python
79 Summary: Python RRDtool bindings
80 Group: Development/Languages
81 BuildRequires: python-devel >= 2.3
82 Requires: python >= %{python_version}
83 Requires: %{name} = %{version}-%{release}
84 Obsoletes: python-%{name} < %{version}-%{release}
85 Provides: python-%{name} = %{version}-%{release}
86
87 %description python
88 Python RRDtool bindings.
89 %endif
90
91 %ifarch ppc64
92 # php bits busted on ppc64 at the moment
93 %define with_php 0
94 %endif
95
96 %if %{with_php}
97 %package php
98 Summary: PHP RRDtool bindings
99 Group: Development/Languages
100 BuildRequires: php-devel >= 4.0
101 Requires: php >= 4.0
102 Requires: %{name} = %{version}-%{release}
103 %if 0%{?php_zend_api}
104 Requires: php(zend-abi) = %{php_zend_api}
105 Requires: php(api) = %{php_core_api}
106 %else
107 Requires: php-api = %{php_apiver}
108 %endif
109 Obsoletes: php-%{name} < %{version}-%{release}
110 Provides: php-%{name} = %{version}-%{release}
111 Provides: php-pecl(rrdtool)
112
113 %description php
114 The %{name}-php package includes a dynamic shared object (DSO) that adds
115 RRDtool bindings to the PHP HTML-embedded scripting language.
116 %endif
117
118 %if %{with_tcl}
119 %package tcl
120 Summary: Tcl RRDtool bindings
121 Group: Development/Languages
122 BuildRequires: tcl-devel >= 8.0
123 Requires: tcl >= 8.0
124 Requires: %{name} = %{version}-%{release}
125 Obsoletes: tcl-%{name} < %{version}-%{release}
126 Provides: tcl-%{name} = %{version}-%{release}
127
128 %description tcl
129 The %{name}-tcl package includes RRDtool bindings for Tcl.
130 %endif
131
132 %if %{with_ruby}
133 %{!?ruby_sitearch: %define ruby_sitearch %(ruby -rrbconfig -e 'puts Config::CONFIG["sitearchdir"]')}
134
135 %package ruby
136 Summary: Ruby RRDtool bindings
137 Group: Development/Languages
138 BuildRequires: ruby, ruby-devel
139 Requires: ruby(abi) = 1.8
140 Requires: %{name} = %{version}-%{release}
141
142 %description ruby
143 The %{name}-ruby package includes RRDtool bindings for Ruby.
144 %endif
145
146 %prep
147 %if %{with_php}
148 %setup -q -n %{name}-%{version} -a 1
149 %patch1 -p1
150 %else
151 %setup -q -n %{name}-%{version}
152 %endif
153
154 # Fix to find correct python dir on lib64
155 %{__perl} -pi -e 's|get_python_lib\(0,0,prefix|get_python_lib\(1,0,prefix|g' \
156     configure
157
158 # Most edits shouldn't be necessary when using --libdir, but
159 # w/o, some introduce hardcoded rpaths where they shouldn't
160 %{__perl} -pi.orig -e 's|/lib\b|/%{_lib}|g' configure Makefile.in*
161 %if %{with_php}
162 %{__perl} -pi.orig -e 's|/lib\b|/%{_lib}|g' php4/configure php4/ltconfig*
163 %endif
164
165 # Perl 5.10 seems to not like long version strings, hack around it
166 %{__perl} -pi.orig -e 's|1.299907080300|1.29990708|' \
167     bindings/perl-shared/RRDs.pm bindings/perl-piped/RRDp.pm
168
169 #
170 # fix config files for php4 bindings
171 # workaround needed due to https://bugzilla.redhat.com/show_bug.cgi?id=211069
172 %if %{with_php}
173 cp -p /usr/lib/rpm/config.{guess,sub} php4/
174 %endif
175
176
177 %build
178 %configure \
179     CFLAGS="-g -O0" \
180     --with-perl-options='INSTALLDIRS="vendor"' \
181 %if %{with_tcl}
182     --enable-tcl-site \
183     --with-tcllib=%{_libdir} \
184 %else
185     --disable-tcl \
186 %endif
187 %if %{with_python}
188     --enable-python \
189 %else
190     --disable-python \
191 %endif
192 %if %{with_ruby}
193     --enable-ruby \
194 %endif
195     --disable-static \
196     --with-pic
197
198 # Fix another rpath issue
199 %{__perl} -pi.orig -e 's|-Wl,--rpath -Wl,\$rp||g' \
200     bindings/perl-shared/Makefile.PL
201
202 # Force RRDp bits where we want 'em, not sure yet why the
203 # --with-perl-options and --libdir don't take
204 pushd bindings/perl-piped/
205 %{__perl} Makefile.PL INSTALLDIRS=vendor
206 %{__perl} -pi.orig -e 's|/lib/perl|/%{_lib}/perl|g' Makefile
207 popd
208
209 #{__make} %{?_smp_mflags}
210 make
211
212 # Build the php module, the tmp install is required
213 %if %{with_php}
214 %define rrdtmp %{_tmppath}/%{name}-%{version}-tmpinstall
215 %{__make} install DESTDIR="%{rrdtmp}"
216 pushd php4/
217 %configure \
218     --with-rrdtool="%{rrdtmp}%{_prefix}" \
219     --disable-static
220 #{__make} %{?_smp_mflags}
221 make
222 popd
223 %{__rm} -rf %{rrdtmp}
224 %endif
225
226 # Fix @perl@ and @PERL@
227 find examples/ -type f \
228     -exec %{__perl} -pi -e 's|^#! \@perl\@|#!%{__perl}|gi' {} \;
229 find examples/ -name "*.pl" \
230     -exec %{__perl} -pi -e 's|\015||gi' {} \;
231
232 %install
233 rm -rf $RPM_BUILD_ROOT
234 make DESTDIR="$RPM_BUILD_ROOT" install
235
236 # Install the php module
237 %if %{with_php}
238 %{__install} -D -m0755 php4/modules/rrdtool.so \
239     %{buildroot}%{php_extdir}/rrdtool.so
240 # Clean up the examples for inclusion as docs
241 %{__rm} -rf php4/examples/.svn
242 # Put the php config bit into place
243 %{__mkdir_p} %{buildroot}%{_sysconfdir}/php.d
244 %{__cat} << __EOF__ > %{buildroot}%{_sysconfdir}/php.d/rrdtool.ini
245 ; Enable rrdtool extension module
246 extension=rrdtool.so
247 __EOF__
248 %endif
249
250 # Pesky RRDp.pm...
251 %{__mv} $RPM_BUILD_ROOT%{perl_vendorarch}/../RRDp.pm $RPM_BUILD_ROOT%{perl_vendorarch}/
252
253 # Dunno why this is getting installed here...
254 %{__rm} -f $RPM_BUILD_ROOT%{perl_vendorarch}/../leaktest.pl
255
256 # We only want .txt and .html files for the main documentation
257 %{__mkdir_p} doc2/html doc2/txt
258 %{__cp} -a doc/*.txt doc2/txt/
259 %{__cp} -a doc/*.html doc2/html/
260
261 # Put perl docs in perl package
262 %{__mkdir_p} doc3/html
263 %{__mv} doc2/html/RRD*.html doc3/html/
264
265 # Clean up the examples
266 %{__rm} -f examples/Makefile* examples/*.in
267
268 # This is so rpm doesn't pick up perl module dependencies automatically
269 find examples/ -type f -exec chmod 0644 {} \;
270
271 # Clean up the buildroot
272 %{__rm} -rf $RPM_BUILD_ROOT%{_docdir}/%{name}-* \
273         $RPM_BUILD_ROOT%{perl_vendorarch}/ntmake.pl \
274         $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod \
275         $RPM_BUILD_ROOT%{_datadir}/%{name}/examples \
276         $RPM_BUILD_ROOT%{perl_vendorarch}/auto/*/{.packlist,*.bs}
277
278 # Set up rrdcached
279 %__install -d -m 0755 $RPM_BUILD_ROOT/%{_sysconfdir}/default
280 %__install -d -m 0755 $RPM_BUILD_ROOT/%{_sysconfdir}/rc.d/init.d
281 %__install -m 0644 etc/rrdcached-default $RPM_BUILD_ROOT/%{_sysconfdir}/default/rrdcached
282 %__install -m 0755 etc/rrdcached-init $RPM_BUILD_ROOT/%{_sysconfdir}/rc.d/init.d/rrdcached
283 %__install -d -m 0755 -o nobody -g nobody $RPM_BUILD_ROOT/%{_localstatedir}/run/rrdcached
284
285 %clean
286 %{__rm} -rf $RPM_BUILD_ROOT
287
288 %post
289 /sbin/ldconfig
290 /sbin/chkconfig --add rrdcached
291 /sbin/service rrdcached start
292
293 %preun
294 /sbin/service rrdcached stop
295
296 %postun
297 /sbin/chkconfig --del rrdcached
298 /sbin/ldconfig
299
300 %files
301 %defattr(-,root,root,-)
302 %{_bindir}/*
303 %{_libdir}/*.so.*
304 %{_datadir}/%{name}
305 %{_mandir}/man1/*
306 %config %{_sysconfdir}/default/*
307 %config %{_sysconfdir}/rc.d/init.d/*
308 %attr(0775 nobody nobody) %dir %{_localstatedir}/run/rrdcached
309
310 %files devel
311 %defattr(-,root,root,-)
312 %{_includedir}/*.h
313 %exclude %{_libdir}/*.la
314 %{_libdir}/*.so
315
316 %files doc
317 %defattr(-,root,root,-)
318 %doc CONTRIBUTORS COPYING COPYRIGHT README TODO NEWS THREADS
319 %doc examples doc2/html doc2/txt
320
321 %files perl
322 %defattr(-,root,root,-)
323 %doc doc3/html
324 %{_mandir}/man3/*
325 %{perl_vendorarch}/*.pm
326 %attr(0755,root,root) %{perl_vendorarch}/auto/RRDs/
327
328 %if %{with_python}
329 %files python
330 %defattr(-,root,root,-)
331 %doc bindings/python/AUTHORS bindings/python/COPYING bindings/python/README
332 %{python_sitearch}/rrdtoolmodule.so
333 %{python_sitearch}/py_rrdtool-*.egg-info
334 %endif
335
336 %if %{with_php}
337 %files php
338 %defattr(-,root,root,0755)
339 %doc php4/examples php4/README
340 %config(noreplace) %{_sysconfdir}/php.d/rrdtool.ini
341 %{php_extdir}/rrdtool.so
342 %endif
343
344 %if %{with_tcl}
345 %files tcl
346 %defattr(-,root,root,-)
347 %doc bindings/tcl/README
348 %{_libdir}/tclrrd*.so
349 %{_libdir}/rrdtool/*.tcl
350 %endif
351
352 %if %{with_ruby}
353 %files ruby
354 %defattr(-,root,root,-)
355 %doc bindings/ruby/README
356 %{ruby_sitearch}/RRD.so
357 %endif
358
359 %changelog
360 * Sun Jun 08 2008 Jarod Wilson <jwilson@redhat.com> 1.3-0.20.rc9
361 - Update to rrdtool 1.3 rc9
362 - Minor spec tweaks to permit building on older EL
363
364 * Wed Jun 04 2008 Chris Ricker <kaboom@oobleck.net> 1.3-0.19.rc7
365 - Update to rrdtool 1.3 rc7
366
367 * Tue May 27 2008 Chris Ricker <kaboom@oobleck.net> 1.3-0.18.rc6
368 - Update to rrdtool 1.3 rc6
369
370 * Wed May 21 2008 Chris Ricker <kaboom@oobleck.net> 1.3-0.17.rc4
371 - Bump version and rebuild
372
373 * Wed May 21 2008 Chris Ricker <kaboom@oobleck.net> 1.3-0.16.rc4
374 - Fix php bindings compile on x86_64
375
376 * Mon May 19 2008 Chris Ricker <kaboom@oobleck.net> 1.3-0.15.rc4
377 - Update to rrdtool 1.3 rc4
378
379 * Tue May 13 2008 Jarod Wilson <jwilson@redhat.com> 1.3-0.15.rc1
380 - Update to rrdtool 1.3 rc1
381 - Fix versioning in changelog entries, had an extra 0 in there...
382 - Drop cairo and python patches, they're in 1.3 rc1
383 - Add Requires: gettext and libxml2-devel for new translations
384
385 * Wed Apr 30 2008 Jarod Wilson <jwilson@redhat.com> 1.3-0.14.beta4
386 - Drop some conditional flags, they're not working at the moment...
387
388 * Wed Apr 30 2008 Jarod Wilson <jwilson@redhat.com> 1.3-0.13.beta4
389 - Fix problem with cairo_save/cairo_restore (#444827)
390
391 * Wed Apr 23 2008 Jarod Wilson <jwilson@redhat.com> 1.3-0.12.beta4
392 - Fix python bindings rrdtool info implementation (#435468)
393
394 * Tue Apr 08 2008 Jarod Wilson <jwilson@redhat.com> 1.3-0.11.beta4
395 - Work around apparent version string length issue w/perl 5.10 (#441359)
396
397 * Sat Apr 05 2008 Jarod Wilson <jwilson@redhat.com> 1.3-0.10.beta4
398 - Fix use of rrd_update in php bindings (#437558)
399
400 * Mon Mar  3 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.3-0.9.beta4
401 - rebuild for new perl (again)
402
403 * Wed Feb 13 2008 Jarod Wilson <jwilson@redhat.com> 1.3-0.8.beta4
404 - Update to rrdtool 1.3 beta4
405
406 * Tue Feb 05 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.3-0.7.beta3
407 - rebuild for new perl (and fix license tag)
408
409 * Mon Feb 04 2008 Jarod Wilson <jwilson@redhat.com> 1.3-0.6.beta3
410 - Plug memory leak (#430879)
411
412 * Mon Jan 07 2008 Jarod Wilson <jwilson@redhat.com> 1.3-0.5.beta3
413 - Fix right-aligned text alignment and scaling (Resolves: #427609)
414
415 * Wed Jan 02 2008 Jarod Wilson <jwilson@redhat.com> 1.3-0.4.beta3
416 - Add newly built python egg to %%files
417
418 * Wed Jan 02 2008 Jarod Wilson <jwilson@redhat.com> 1.3-0.3.beta3
419 - Update to rrdtool 1.3 beta3
420 - Return properly from errors in RRDp.pm (Resolves: #427040)
421 - Requires: dejavu-lgc-fonts (Resolves: #426935)
422
423 * Thu Dec 06 2007 Jarod Wilson <jwilson@redhat.com> 1.3-0.2.beta2
424 - Update to rrdtool 1.3 beta2
425
426 * Wed Aug 08 2007 Jarod Wilson <jwilson@redhat.com> 1.3-0.1.beta1
427 - Update to rrdtool 1.3 beta1
428
429 * Tue Jul 10 2007 Jarod Wilson <jwilson@redhat.com> 1.2.999-0.3.r1144
430 - Update to latest rrdtool pre-1.3 svn snapshot (svn r1144)
431 - Add php abi check (Resolves: #247339)
432
433 * Fri Jun 15 2007 Jarod Wilson <jwilson@redhat.com> 1.2.999-0.2.r1127
434 - Fix up BuildRequires
435
436 * Fri Jun 15 2007 Jarod Wilson <jwilson@redhat.com> 1.2.999-0.1.r1127
437 - Update to rrdtool pre-1.3 svn snapshot (svn r1127)
438
439 * Mon May 21 2007 Jarod Wilson <jwilson@redhat.com> 1.2.23-5
440 - BR: ruby so %%ruby_sitearch gets set
441
442 * Mon May 21 2007 Jarod Wilson <jwilson@redhat.com> 1.2.23-4
443 - Build ruby bindings
444
445 * Thu May 03 2007 Jarod Wilson <jwilson@redhat.com> 1.2.23-3
446 - Disable php bits on ppc64 for now, they fail to build
447
448 * Thu May 03 2007 Jarod Wilson <jwilson@redhat.com> 1.2.23-2
449 - Add BR: perl-devel for Fedora 7 and later
450
451 * Tue May 01 2007 Jarod Wilson <jwilson@redhat.com> 1.2.23-1
452 - New upstream release
453
454 * Tue May 01 2007 Jarod Wilson <jwilson@redhat.com> 1.2.21-1
455 - New upstream release
456
457 * Wed Apr 25 2007 Jarod Wilson <jwilson@redhat.com> 1.2.19-2
458 - Define %%python_version *before* its needed (#237826)
459
460 * Mon Apr 09 2007 Jarod Wilson <jwilson@redhat.com> 1.2.19-1
461 - New upstream release
462
463 * Tue Jan 23 2007 Jarod Wilson <jwilson@redhat.com> 1.2.18-1
464 - New upstream release
465
466 * Mon Jan 22 2007 Jarod Wilson <jwilson@redhat.com> 1.2.17-1
467 - New upstream release
468
469 * Tue Jan 02 2007 Jarod Wilson <jwilson@redhat.com> 1.2.15-9
470 - Fix crash with long error strings (upstream
471   changesets 929 and 935)
472
473 * Thu Dec 14 2006 Jarod Wilson <jwilson@redhat.com> 1.2.15-8
474 - Fix for log grid memory leak (#201241)
475
476 * Tue Dec 12 2006 Jarod Wilson <jwilson@redhat.com> 1.2.15-7
477 - Rebuild for python 2.5
478
479 * Tue Nov 14 2006 Jarod Wilson <jwilson@redhat.com> 1.2.15-6
480 - Conditionalize python, php and tcl bits (Resolves #203275)
481
482 * Wed Oct 25 2006 Jarod Wilson <jwilson@redhat.com> 1.2.15-5
483 - Add tcl sub-package (#203275)
484
485 * Tue Sep 05 2006 Jarod Wilson <jwilson@redhat.com> 1.2.15-4
486 - Rebuild for new glibc
487
488 * Wed Aug 02 2006 Jarod Wilson <jwilson@redhat.com> 1.2.15-3
489 - One more addition to initrrdtool patch, to fully revert
490   and correct upstream changeset 839
491 - Fix for no python in minimal fc4 buildroots
492
493 * Tue Aug  1 2006 Mihai Ibanescu <misa@redhat.com> 1.2.15-2
494 - Fixed rrdtool-python to import the module properly (patch
495   rrdtool-1.2.15-initrrdtool.patch)
496
497 * Mon Jul 17 2006 Jarod Wilson <jwilson@redhat.com> 1.2.15-1
498 - Update to 1.2.15
499 - Minor spec cleanups
500
501 * Sat Jun 24 2006 Jarod Wilson <jwilson@redhat.com> 1.2.13-7
502 - Fix up Obsoletes
503
504 * Mon Jun 19 2006 Jarod Wilson <jwilson@redhat.com> 1.2.13-6
505 - Flip perl, php and python sub-package names around to 
506   conform with general practices
507
508 * Sat Jun 10 2006 Jarod Wilson <jwilson@redhat.com> 1.2.13-5
509 - Minor fixes to make package own created directories
510
511 * Wed Jun 07 2006 Jarod Wilson <jwilson@redhat.com> 1.2.13-4
512 - Add php bits back into the mix
513
514 * Mon Jun 05 2006 Jarod Wilson <jwilson@redhat.com> 1.2.13-3
515 - Merge spec fixes from bz 185909
516
517 * Sun Jun 04 2006 Jarod Wilson <jwilson@redhat.com> 1.2.13-2
518 - Remove explicit perl dep, version grabbing using rpm during
519   rpmbuild not guaranteed to work (fails on ppc in plague),
520   and auto-gen perl deps are sufficient
521
522 * Sat Jun 03 2006 Jarod Wilson <jwilson@redhat.com> 1.2.13-1
523 - Update to release 1.2.13
524 - Merge spec changes from dag, atrpms and mdk builds
525 - Additional hacktastic contortions for lib64 & rpath messiness
526 - Add missing post/postun ldconfig
527 - Fix a bunch of rpmlint errors
528 - Disable static libs, per FE guidelines
529 - Split off docs
530
531 * Wed Apr 19 2006 Chris Ricker <kaboom@oobleck.net> 1.2.12-1
532 - Rev to 1.2
533
534 * Fri May 20 2005 Matthias Saou <http://freshrpms.net/> 1.0.49-5
535 - Include patch from Michael to fix perl module compilation on FC4 (#156242).
536
537 * Fri May 20 2005 Matthias Saou <http://freshrpms.net/> 1.0.49-4
538 - Fix for the php module patch (Joe Pruett, Dag Wieers), #156716.
539 - Update source URL to new location since 1.2 is now the default stable.
540 - Don't (yet) update to 1.0.50, as it introduces some changes in the perl
541   modules install.
542
543 * Mon Jan 31 2005 Matthias Saou <http://freshrpms.net/> 1.0.49-3
544 - Put perl modules in vendor_perl and not site_perl. #146513
545
546 * Thu Jan 13 2005 Matthias Saou <http://freshrpms.net/> 1.0.49-2
547 - Minor cleanups.
548
549 * Thu Aug 25 2004 Dag Wieers <dag@wieers.com> - 1.0.49-1
550 - Updated to release 1.0.49.
551
552 * Wed Aug 25 2004 Dag Wieers <dag@wieers.com> - 1.0.48-3
553 - Fixes for x86_64. (Garrick Staples)
554
555 * Fri Jul  2 2004 Matthias Saou <http://freshrpms.net/> 1.0.48-3
556 - Actually apply the patch for fixing the php module, doh!
557
558 * Thu May 27 2004 Matthias Saou <http://freshrpms.net/> 1.0.48-2
559 - Added php.d config entry to load the module once installed.
560
561 * Thu May 13 2004 Dag Wieers <dag@wieers.com> - 1.0.48-1
562 - Updated to release 1.0.48.
563
564 * Tue Apr 06 2004 Dag Wieers <dag@wieers.com> - 1.0.47-1
565 - Updated to release 1.0.47.
566
567 * Thu Mar  4 2004 Matthias Saou <http://freshrpms.net/> 1.0.46-2
568 - Change the strict dependency on perl to fix problem with the recent
569   update.
570
571 * Mon Jan  5 2004 Matthias Saou <http://freshrpms.net/> 1.0.46-1
572 - Update to 1.0.46.
573 - Use system libpng and zlib instead of bundled ones.
574 - Added php-rrdtool sub-package for the php4 module.
575
576 * Fri Dec  5 2003 Matthias Saou <http://freshrpms.net/> 1.0.45-4
577 - Added epoch to the perl dependency to work with rpm > 4.2.
578 - Fixed the %% escaping in the perl dep.
579
580 * Mon Nov 17 2003 Matthias Saou <http://freshrpms.net/> 1.0.45-2
581 - Rebuild for Fedora Core 1.
582
583 * Sun Aug  3 2003 Matthias Saou <http://freshrpms.net/>
584 - Update to 1.0.45.
585
586 * Wed Apr 16 2003 Matthias Saou <http://freshrpms.net/>
587 - Update to 1.0.42.
588
589 * Mon Mar 31 2003 Matthias Saou <http://freshrpms.net/>
590 - Rebuilt for Red Hat Linux 9.
591
592 * Wed Mar  5 2003 Matthias Saou <http://freshrpms.net/>
593 - Added explicit perl version dependency.
594
595 * Sun Feb 23 2003 Matthias Saou <http://freshrpms.net/>
596 - Update to 1.0.41.
597
598 * Fri Jan 31 2003 Matthias Saou <http://freshrpms.net/>
599 - Update to 1.0.40.
600 - Spec file cleanup.
601
602 * Fri Jul 05 2002 Henri Gomez <hgomez@users.sourceforge.net>
603 - 1.0.39
604
605 * Mon Jun 03 2002 Henri Gomez <hgomez@users.sourceforge.net>
606 - 1.0.38
607
608 * Fri Apr 19 2002 Henri Gomez <hgomez@users.sourceforge.net>
609 - 1.0.37
610
611 * Tue Mar 12 2002 Henri Gomez <hgomez@users.sourceforge.net>
612 - 1.0.34
613 - rrdtools include zlib 1.1.4 which fix vulnerabilities in 1.1.3
614