Initial revision
[rrdtool.git] / rrdtool.spec
1 %define name rrdtool
2 %define ver 1.0.21
3 %define extension tar.gz
4
5 Summary: Round Robin Database Tools
6 Name: %name
7 Version: %{ver}
8 Release: 2
9 Copyright: GPL
10 Group: Applications/Networking
11 Source: %{name}-%{ver}.%{extension}
12 Patch0: rrdtool-perldestdir.patch
13 Patch1: rrdtool-tcldestdir.patch
14 URL: http://ee-staff.ethz.ch/~oetiker/webtools/rrdtool/
15 Buildroot: /tmp/%{name}-%{ver}-root
16
17 %description
18 It is pretty easy to gather status information from all sorts of things,
19 ranging from the temperature in your office to the number of octets which
20 have passed through the FDDI interface of your router. But it is not so
21 trivial to store this data in a efficient and systematic manner. This is
22 where RRDtool kicks in. It lets you log and analyze the data you gather from
23 all kinds of data-sources (DS). The data analysis part of RRDtool is based
24 on the ability to quickly generate graphical representations of the data
25 values collected over a definable time period.
26
27 %prep
28 %setup
29 %patch0 -p1
30 %patch1 -p1
31 %build
32 ./configure --with-tcllib=/usr/lib --prefix=/usr
33 make
34
35 %install
36 make install DESTDIR=${RPM_BUILD_ROOT}
37 # install tcl interface...
38 make site-tcl-install DESTDIR=${RPM_BUILD_ROOT}
39 # rpm uses /doc for its file restructuring...
40 mv ${RPM_BUILD_ROOT}/usr/doc ${RPM_BUILD_ROOT}/usr/txt
41
42 %clean
43 rm -rf $RPM_BUILD_ROOT
44
45 %files
46 %doc CHANGES CONTRIBUTORS COPYING COPYRIGHT NT-BUILD-TIPS.txt README TODO 
47 %doc ${RPM_BUILD_ROOT}/usr/contrib/
48 %doc ${RPM_BUILD_ROOT}/usr/txt/
49 %doc ${RPM_BUILD_ROOT}/usr/examples/
50 %doc ${RPM_BUILD_ROOT}/usr/html/
51 /usr/man/
52 /usr/bin/
53 /usr/lib/
54