rrdtool dump is now backward compatible with rrdtool 1.3 dump again. Default is ...
[rrdtool.git] / rrdtool.spec
1 %define with_python %{?_without_python: 0} %{?!_without_python: 1}
2 %define with_php %{?_without_php: 0} %{?!_without_php: 1}
3 %define with_tcl %{?_without_tcl: 0} %{?!_without_tcl: 1}
4 %define with_ruby %{?_without_ruby: 0} %{?!_without_ruby: 1}
5 %define php_extdir %(php-config --extension-dir 2>/dev/null || echo %{_libdir}/php4)
6 %define svnrev r1190
7 #define pretag 1.2.99908020600
8 %define rrdcached_user rrdcached
9
10 Summary: Round Robin Database Tool to store and display time-series data
11 Name: rrdtool
12 Version: 1.3.99908093000
13 Release: 0.20%{?dist}
14 License: GPLv2+ with exceptions
15 Group: Applications/Databases
16 URL: http://oss.oetiker.ch/rrdtool/
17 #Source0: http://oss.oetiker.ch/%{name}/pub/%{name}-%{version}.tar.gz
18 Source0: http://oss.oetiker.ch/rrdtool/pub/beta/%{name}-%{version}.tar.gz
19 %if %{with_php}
20 Source1: php4-%{svnrev}.tar.gz
21 Patch1: rrdtool-1.3.0-beta4-fix-rrd_update-in-php-bindings.patch
22 %endif
23 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
24 Requires: dejavu-lgc-fonts
25 BuildRequires: gcc-c++, openssl-devel, freetype-devel
26 BuildRequires: libpng-devel, zlib-devel, intltool >= 0.35.0
27 BuildRequires: cairo-devel >= 1.2, pango-devel >= 1.14
28 BuildRequires: libtool, groff
29 BuildRequires: gettext, libxml2-devel
30 %if 0%{?fedora} >= 7
31 BuildRequires: perl-ExtUtils-MakeMaker perl-devel
32 %endif
33
34 %description
35 RRD is the Acronym for Round Robin Database. RRD is a system to store and
36 display time-series data (i.e. network bandwidth, machine-room temperature,
37 server load average). It stores the data in a very compact way that will not
38 expand over time, and it presents useful graphs by processing the data to
39 enforce a certain data density. It can be used either via simple wrapper
40 scripts (from shell or Perl) or via frontends that poll network devices and
41 put a friendly user interface on it.
42
43 %package devel
44 Summary: RRDtool libraries and header files
45 Group: Development/Libraries
46 Requires: %{name} = %{version}-%{release}
47
48 %description devel
49 RRD is the Acronym for Round Robin Database. RRD is a system to store and
50 display time-series data (i.e. network bandwidth, machine-room temperature,
51 server load average). This package allow you to use directly this library.
52
53 %package doc
54 Summary: RRDtool documentation
55 Group: Documentation
56
57 %description doc
58 RRD is the Acronym for Round Robin Database. RRD is a system to store and
59 display time-series data (i.e. network bandwidth, machine-room temperature,
60 server load average). This package contains documentation on using RRD.
61
62 %package perl
63 Summary: Perl RRDtool bindings
64 Group: Development/Languages
65 Requires: %{name} = %{version}-%{release}
66 Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
67 Obsoletes: perl-%{name} < %{version}-%{release}
68 Provides: perl-%{name} = %{version}-%{release}
69
70 %description perl
71 The Perl RRDtool bindings
72
73 %if %{with_python}
74 %{!?python_sitearch: %define python_sitearch %(%{__python} -c 'from distutils import sysconfig; print sysconfig.get_python_lib(1)')}
75 # eval to 2.3 if python isn't yet present, workaround for no python in fc4 minimal buildroot
76 %{!?python_version: %define python_version %(%{__python} -c 'import sys; print sys.version.split(" ")[0]' || echo "2.3")}
77
78 %package python
79 Summary: Python RRDtool bindings
80 Group: Development/Languages
81 BuildRequires: python-devel >= 2.3
82 Requires: python >= %{python_version}
83 Requires: %{name} = %{version}-%{release}
84 Obsoletes: python-%{name} < %{version}-%{release}
85 Provides: python-%{name} = %{version}-%{release}
86
87 %description python
88 Python RRDtool bindings.
89 %endif
90
91 %ifarch ppc64
92 # php bits busted on ppc64 at the moment
93 %define with_php 0
94 %endif
95
96 %if %{with_php}
97 %package php
98 Summary: PHP RRDtool bindings
99 Group: Development/Languages
100 BuildRequires: php-devel >= 4.0
101 Requires: php >= 4.0
102 Requires: %{name} = %{version}-%{release}
103 %if 0%{?php_zend_api}
104 Requires: php(zend-abi) = %{php_zend_api}
105 Requires: php(api) = %{php_core_api}
106 %else
107 Requires: php-api = %{php_apiver}
108 %endif
109 Obsoletes: php-%{name} < %{version}-%{release}
110 Provides: php-%{name} = %{version}-%{release}
111 Provides: php-pecl(rrdtool)
112
113 %description php
114 The %{name}-php package includes a dynamic shared object (DSO) that adds
115 RRDtool bindings to the PHP HTML-embedded scripting language.
116 %endif
117
118 %if %{with_tcl}
119 %package tcl
120 Summary: Tcl RRDtool bindings
121 Group: Development/Languages
122 BuildRequires: tcl-devel >= 8.0
123 Requires: tcl >= 8.0
124 Requires: %{name} = %{version}-%{release}
125 Obsoletes: tcl-%{name} < %{version}-%{release}
126 Provides: tcl-%{name} = %{version}-%{release}
127
128 %description tcl
129 The %{name}-tcl package includes RRDtool bindings for Tcl.
130 %endif
131
132 %if %{with_ruby}
133 %{!?ruby_sitearch: %define ruby_sitearch %(ruby -rrbconfig -e 'puts Config::CONFIG["sitearchdir"]')}
134
135 %package ruby
136 Summary: Ruby RRDtool bindings
137 Group: Development/Languages
138 BuildRequires: ruby, ruby-devel
139 Requires: ruby(abi) = 1.8
140 Requires: %{name} = %{version}-%{release}
141
142 %description ruby
143 The %{name}-ruby package includes RRDtool bindings for Ruby.
144 %endif
145
146 %package cached
147 Summary: Data caching daemon for RRDtool
148 Group: Applications/Databases
149 Requires: %{name} = %{version}-%{release}
150
151 %description cached
152 rrdcached is a daemon that receives updates to existing RRD files,
153 accumulates them and, if enough have been received or a defined time has
154 passed, writes the updates to the RRD file.  The daemon was written with
155 big setups in mind which usually runs into I/O related problems.  This
156 daemon was written to alleviate these problems.
157
158 %prep
159 %if %{with_php}
160 %setup -q -n %{name}-%{version} -a 1
161 %patch1 -p1
162 %else
163 %setup -q -n %{name}-%{version}
164 %endif
165
166 # Fix to find correct python dir on lib64
167 %{__perl} -pi -e 's|get_python_lib\(0,0,prefix|get_python_lib\(1,0,prefix|g' \
168     configure
169
170 # Most edits shouldn't be necessary when using --libdir, but
171 # w/o, some introduce hardcoded rpaths where they shouldn't
172 %{__perl} -pi.orig -e 's|/lib\b|/%{_lib}|g' configure Makefile.in*
173 %if %{with_php}
174 %{__perl} -pi.orig -e 's|/lib\b|/%{_lib}|g' php4/configure php4/ltconfig*
175 %endif
176
177 # Perl 5.10 seems to not like long version strings, hack around it
178 %{__perl} -pi.orig -e 's|1.299907080300|1.29990708|' \
179     bindings/perl-shared/RRDs.pm bindings/perl-piped/RRDp.pm
180
181 #
182 # fix config files for php4 bindings
183 # workaround needed due to https://bugzilla.redhat.com/show_bug.cgi?id=211069
184 %if %{with_php}
185 cp -p /usr/lib/rpm/config.{guess,sub} php4/
186 %endif
187
188
189 %build
190 %configure \
191     CFLAGS="-g -O0" \
192     --with-perl-options='INSTALLDIRS="vendor"' \
193 %if %{with_tcl}
194     --enable-tcl-site \
195     --with-tcllib=%{_libdir} \
196 %else
197     --disable-tcl \
198 %endif
199 %if %{with_python}
200     --enable-python \
201 %else
202     --disable-python \
203 %endif
204 %if %{with_ruby}
205     --enable-ruby \
206 %endif
207     --disable-static \
208     --with-pic
209
210 # Fix another rpath issue
211 %{__perl} -pi.orig -e 's|-Wl,--rpath -Wl,\$rp||g' \
212     bindings/perl-shared/Makefile.PL
213
214 # Force RRDp bits where we want 'em, not sure yet why the
215 # --with-perl-options and --libdir don't take
216 pushd bindings/perl-piped/
217 %{__perl} Makefile.PL INSTALLDIRS=vendor
218 %{__perl} -pi.orig -e 's|/lib/perl|/%{_lib}/perl|g' Makefile
219 popd
220
221 #{__make} %{?_smp_mflags}
222 make
223
224 # Build the php module, the tmp install is required
225 %if %{with_php}
226 %define rrdtmp %{_tmppath}/%{name}-%{version}-tmpinstall
227 %{__make} install DESTDIR="%{rrdtmp}"
228 pushd php4/
229 %configure \
230     --with-rrdtool="%{rrdtmp}%{_prefix}" \
231     --disable-static
232 #{__make} %{?_smp_mflags}
233 make
234 popd
235 %{__rm} -rf %{rrdtmp}
236 %endif
237
238 # Fix @perl@ and @PERL@
239 find examples/ -type f \
240     -exec %{__perl} -pi -e 's|^#! \@perl\@|#!%{__perl}|gi' {} \;
241 find examples/ -name "*.pl" \
242     -exec %{__perl} -pi -e 's|\015||gi' {} \;
243
244 %install
245 rm -rf $RPM_BUILD_ROOT
246 make DESTDIR="$RPM_BUILD_ROOT" install
247
248 # Install the php module
249 %if %{with_php}
250 %{__install} -D -m0755 php4/modules/rrdtool.so \
251     %{buildroot}%{php_extdir}/rrdtool.so
252 # Clean up the examples for inclusion as docs
253 %{__rm} -rf php4/examples/.svn
254 # Put the php config bit into place
255 %{__mkdir_p} %{buildroot}%{_sysconfdir}/php.d
256 %{__cat} << __EOF__ > %{buildroot}%{_sysconfdir}/php.d/rrdtool.ini
257 ; Enable rrdtool extension module
258 extension=rrdtool.so
259 __EOF__
260 %endif
261
262 # Pesky RRDp.pm...
263 %{__mv} $RPM_BUILD_ROOT%{perl_vendorarch}/../RRDp.pm $RPM_BUILD_ROOT%{perl_vendorarch}/
264
265 # Dunno why this is getting installed here...
266 %{__rm} -f $RPM_BUILD_ROOT%{perl_vendorarch}/../leaktest.pl
267
268 # We only want .txt and .html files for the main documentation
269 %{__mkdir_p} doc2/html doc2/txt
270 %{__cp} -a doc/*.txt doc2/txt/
271 %{__cp} -a doc/*.html doc2/html/
272
273 # Put perl docs in perl package
274 %{__mkdir_p} doc3/html
275 %{__mv} doc2/html/RRD*.html doc3/html/
276
277 # Clean up the examples
278 %{__rm} -f examples/Makefile* examples/*.in
279
280 # This is so rpm doesn't pick up perl module dependencies automatically
281 find examples/ -type f -exec chmod 0644 {} \;
282
283 # Clean up the buildroot
284 %{__rm} -rf $RPM_BUILD_ROOT%{_docdir}/%{name}-* \
285         $RPM_BUILD_ROOT%{perl_vendorarch}/ntmake.pl \
286         $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod \
287         $RPM_BUILD_ROOT%{_datadir}/%{name}/examples \
288         $RPM_BUILD_ROOT%{perl_vendorarch}/auto/*/{.packlist,*.bs}
289
290 # Set up rrdcached
291 %__install -d -m 0755 $RPM_BUILD_ROOT/%{_sysconfdir}/default
292 %__install -d -m 0755 $RPM_BUILD_ROOT/%{_sysconfdir}/rc.d/init.d
293 %__install -m 0644 etc/rrdcached-default $RPM_BUILD_ROOT/%{_sysconfdir}/default/rrdcached
294 %__install -m 0755 etc/rrdcached-init $RPM_BUILD_ROOT/%{_sysconfdir}/rc.d/init.d/rrdcached
295 %__install -d -m 0755 -o nobody -g nobody $RPM_BUILD_ROOT/%{_localstatedir}/run/rrdcached
296
297 %clean
298 %{__rm} -rf $RPM_BUILD_ROOT
299
300 %pre cached
301 /usr/sbin/groupadd %rrdcached_user &>/dev/null ||:
302 /usr/sbin/useradd -s /sbin/nologin -g %rrdcached_user -c %rrdcached_user -d %{_localstatedir}/run/rrdcached  %rrdcached_user &>/dev/null || :
303
304 %post -p /sbin/ldconfig
305
306 %post cached
307 /sbin/chkconfig --add rrdcached
308 /sbin/service rrdcached start
309
310 %preun cached
311 /sbin/service rrdcached stop
312
313 %postun -p /sbin/ldconfig
314
315 %postun cached
316 /sbin/chkconfig --del rrdcached
317 test "$1" != 0 || /usr/sbin/userdel %rrdcached_user &>/dev/null || :
318 #test "$1" != 0 || /usr/sbin/groupdel %rrdcached_user &>/dev/null || :
319
320 %files
321 %defattr(-,root,root,-)
322 %{_bindir}/*
323 %exclude %{_bindir}/rrdcached
324 %{_libdir}/*.so.*
325 %{_datadir}/%{name}
326 %{_mandir}/man1/*
327 %exclude %{_mandir}/man1/rrdcached*
328
329 %files devel
330 %defattr(-,root,root,-)
331 %{_includedir}/*.h
332 %exclude %{_libdir}/*.la
333 %{_libdir}/*.so
334 %{_libdir}/pkgconfig/librrd.pc
335
336 %files doc
337 %defattr(-,root,root,-)
338 %doc CONTRIBUTORS COPYING COPYRIGHT README TODO NEWS THREADS
339 %doc examples doc2/html doc2/txt
340
341 %files perl
342 %defattr(-,root,root,-)
343 %doc doc3/html
344 %{_mandir}/man3/*
345 %{perl_vendorarch}/*.pm
346 %attr(0755,root,root) %{perl_vendorarch}/auto/RRDs/
347
348 %if %{with_python}
349 %files python
350 %defattr(-,root,root,-)
351 %doc bindings/python/AUTHORS bindings/python/COPYING bindings/python/README
352 %{python_sitearch}/rrdtoolmodule.so
353 %{python_sitearch}/py_rrdtool-*.egg-info
354 %endif
355
356 %if %{with_php}
357 %files php
358 %defattr(-,root,root,0755)
359 %doc php4/examples php4/README
360 %config(noreplace) %{_sysconfdir}/php.d/rrdtool.ini
361 %{php_extdir}/rrdtool.so
362 %endif
363
364 %if %{with_tcl}
365 %files tcl
366 %defattr(-,root,root,-)
367 %doc bindings/tcl/README
368 %{_libdir}/tclrrd*.so
369 %{_libdir}/rrdtool/*.tcl
370 %endif
371
372 %if %{with_ruby}
373 %files ruby
374 %defattr(-,root,root,-)
375 %doc bindings/ruby/README
376 %{ruby_sitearch}/RRD.so
377 %endif
378
379 %files cached
380 %{_bindir}/rrdcached
381 %config %{_sysconfdir}/default/*
382 %config %{_sysconfdir}/rc.d/init.d/*
383 %{_mandir}/man1/rrdcached*
384 %attr(0775 %rrdcached_user %rrdcached_user) %dir %{_localstatedir}/run/rrdcached
385
386 %changelog
387 * Wed Oct 08 2008 Bernard Li <bernard@vanhpc.org>
388 - Split rrdcached related files to -cached subpackage
389 - Create rrdcached user and make rrdcached related files owned by it
390
391 * Tue Oct 07 2008 Bernard Li <bernard@vanhpc.org>
392 - Include librrd.pc file in -devel package
393
394 * Sun Jun 08 2008 Jarod Wilson <jwilson@redhat.com> 1.3-0.20.rc9
395 - Update to rrdtool 1.3 rc9
396 - Minor spec tweaks to permit building on older EL
397
398 * Wed Jun 04 2008 Chris Ricker <kaboom@oobleck.net> 1.3-0.19.rc7
399 - Update to rrdtool 1.3 rc7
400
401 * Tue May 27 2008 Chris Ricker <kaboom@oobleck.net> 1.3-0.18.rc6
402 - Update to rrdtool 1.3 rc6
403
404 * Wed May 21 2008 Chris Ricker <kaboom@oobleck.net> 1.3-0.17.rc4
405 - Bump version and rebuild
406
407 * Wed May 21 2008 Chris Ricker <kaboom@oobleck.net> 1.3-0.16.rc4
408 - Fix php bindings compile on x86_64
409
410 * Mon May 19 2008 Chris Ricker <kaboom@oobleck.net> 1.3-0.15.rc4
411 - Update to rrdtool 1.3 rc4
412
413 * Tue May 13 2008 Jarod Wilson <jwilson@redhat.com> 1.3-0.15.rc1
414 - Update to rrdtool 1.3 rc1
415 - Fix versioning in changelog entries, had an extra 0 in there...
416 - Drop cairo and python patches, they're in 1.3 rc1
417 - Add Requires: gettext and libxml2-devel for new translations
418
419 * Wed Apr 30 2008 Jarod Wilson <jwilson@redhat.com> 1.3-0.14.beta4
420 - Drop some conditional flags, they're not working at the moment...
421
422 * Wed Apr 30 2008 Jarod Wilson <jwilson@redhat.com> 1.3-0.13.beta4
423 - Fix problem with cairo_save/cairo_restore (#444827)
424
425 * Wed Apr 23 2008 Jarod Wilson <jwilson@redhat.com> 1.3-0.12.beta4
426 - Fix python bindings rrdtool info implementation (#435468)
427
428 * Tue Apr 08 2008 Jarod Wilson <jwilson@redhat.com> 1.3-0.11.beta4
429 - Work around apparent version string length issue w/perl 5.10 (#441359)
430
431 * Sat Apr 05 2008 Jarod Wilson <jwilson@redhat.com> 1.3-0.10.beta4
432 - Fix use of rrd_update in php bindings (#437558)
433
434 * Mon Mar  3 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.3-0.9.beta4
435 - rebuild for new perl (again)
436
437 * Wed Feb 13 2008 Jarod Wilson <jwilson@redhat.com> 1.3-0.8.beta4
438 - Update to rrdtool 1.3 beta4
439
440 * Tue Feb 05 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.3-0.7.beta3
441 - rebuild for new perl (and fix license tag)
442
443 * Mon Feb 04 2008 Jarod Wilson <jwilson@redhat.com> 1.3-0.6.beta3
444 - Plug memory leak (#430879)
445
446 * Mon Jan 07 2008 Jarod Wilson <jwilson@redhat.com> 1.3-0.5.beta3
447 - Fix right-aligned text alignment and scaling (Resolves: #427609)
448
449 * Wed Jan 02 2008 Jarod Wilson <jwilson@redhat.com> 1.3-0.4.beta3
450 - Add newly built python egg to %%files
451
452 * Wed Jan 02 2008 Jarod Wilson <jwilson@redhat.com> 1.3-0.3.beta3
453 - Update to rrdtool 1.3 beta3
454 - Return properly from errors in RRDp.pm (Resolves: #427040)
455 - Requires: dejavu-lgc-fonts (Resolves: #426935)
456
457 * Thu Dec 06 2007 Jarod Wilson <jwilson@redhat.com> 1.3-0.2.beta2
458 - Update to rrdtool 1.3 beta2
459
460 * Wed Aug 08 2007 Jarod Wilson <jwilson@redhat.com> 1.3-0.1.beta1
461 - Update to rrdtool 1.3 beta1
462
463 * Tue Jul 10 2007 Jarod Wilson <jwilson@redhat.com> 1.2.999-0.3.r1144
464 - Update to latest rrdtool pre-1.3 svn snapshot (svn r1144)
465 - Add php abi check (Resolves: #247339)
466
467 * Fri Jun 15 2007 Jarod Wilson <jwilson@redhat.com> 1.2.999-0.2.r1127
468 - Fix up BuildRequires
469
470 * Fri Jun 15 2007 Jarod Wilson <jwilson@redhat.com> 1.2.999-0.1.r1127
471 - Update to rrdtool pre-1.3 svn snapshot (svn r1127)
472
473 * Mon May 21 2007 Jarod Wilson <jwilson@redhat.com> 1.2.23-5
474 - BR: ruby so %%ruby_sitearch gets set
475
476 * Mon May 21 2007 Jarod Wilson <jwilson@redhat.com> 1.2.23-4
477 - Build ruby bindings
478
479 * Thu May 03 2007 Jarod Wilson <jwilson@redhat.com> 1.2.23-3
480 - Disable php bits on ppc64 for now, they fail to build
481
482 * Thu May 03 2007 Jarod Wilson <jwilson@redhat.com> 1.2.23-2
483 - Add BR: perl-devel for Fedora 7 and later
484
485 * Tue May 01 2007 Jarod Wilson <jwilson@redhat.com> 1.2.23-1
486 - New upstream release
487
488 * Tue May 01 2007 Jarod Wilson <jwilson@redhat.com> 1.2.21-1
489 - New upstream release
490
491 * Wed Apr 25 2007 Jarod Wilson <jwilson@redhat.com> 1.2.19-2
492 - Define %%python_version *before* its needed (#237826)
493
494 * Mon Apr 09 2007 Jarod Wilson <jwilson@redhat.com> 1.2.19-1
495 - New upstream release
496
497 * Tue Jan 23 2007 Jarod Wilson <jwilson@redhat.com> 1.2.18-1
498 - New upstream release
499
500 * Mon Jan 22 2007 Jarod Wilson <jwilson@redhat.com> 1.2.17-1
501 - New upstream release
502
503 * Tue Jan 02 2007 Jarod Wilson <jwilson@redhat.com> 1.2.15-9
504 - Fix crash with long error strings (upstream
505   changesets 929 and 935)
506
507 * Thu Dec 14 2006 Jarod Wilson <jwilson@redhat.com> 1.2.15-8
508 - Fix for log grid memory leak (#201241)
509
510 * Tue Dec 12 2006 Jarod Wilson <jwilson@redhat.com> 1.2.15-7
511 - Rebuild for python 2.5
512
513 * Tue Nov 14 2006 Jarod Wilson <jwilson@redhat.com> 1.2.15-6
514 - Conditionalize python, php and tcl bits (Resolves #203275)
515
516 * Wed Oct 25 2006 Jarod Wilson <jwilson@redhat.com> 1.2.15-5
517 - Add tcl sub-package (#203275)
518
519 * Tue Sep 05 2006 Jarod Wilson <jwilson@redhat.com> 1.2.15-4
520 - Rebuild for new glibc
521
522 * Wed Aug 02 2006 Jarod Wilson <jwilson@redhat.com> 1.2.15-3
523 - One more addition to initrrdtool patch, to fully revert
524   and correct upstream changeset 839
525 - Fix for no python in minimal fc4 buildroots
526
527 * Tue Aug  1 2006 Mihai Ibanescu <misa@redhat.com> 1.2.15-2
528 - Fixed rrdtool-python to import the module properly (patch
529   rrdtool-1.2.15-initrrdtool.patch)
530
531 * Mon Jul 17 2006 Jarod Wilson <jwilson@redhat.com> 1.2.15-1
532 - Update to 1.2.15
533 - Minor spec cleanups
534
535 * Sat Jun 24 2006 Jarod Wilson <jwilson@redhat.com> 1.2.13-7
536 - Fix up Obsoletes
537
538 * Mon Jun 19 2006 Jarod Wilson <jwilson@redhat.com> 1.2.13-6
539 - Flip perl, php and python sub-package names around to 
540   conform with general practices
541
542 * Sat Jun 10 2006 Jarod Wilson <jwilson@redhat.com> 1.2.13-5
543 - Minor fixes to make package own created directories
544
545 * Wed Jun 07 2006 Jarod Wilson <jwilson@redhat.com> 1.2.13-4
546 - Add php bits back into the mix
547
548 * Mon Jun 05 2006 Jarod Wilson <jwilson@redhat.com> 1.2.13-3
549 - Merge spec fixes from bz 185909
550
551 * Sun Jun 04 2006 Jarod Wilson <jwilson@redhat.com> 1.2.13-2
552 - Remove explicit perl dep, version grabbing using rpm during
553   rpmbuild not guaranteed to work (fails on ppc in plague),
554   and auto-gen perl deps are sufficient
555
556 * Sat Jun 03 2006 Jarod Wilson <jwilson@redhat.com> 1.2.13-1
557 - Update to release 1.2.13
558 - Merge spec changes from dag, atrpms and mdk builds
559 - Additional hacktastic contortions for lib64 & rpath messiness
560 - Add missing post/postun ldconfig
561 - Fix a bunch of rpmlint errors
562 - Disable static libs, per FE guidelines
563 - Split off docs
564
565 * Wed Apr 19 2006 Chris Ricker <kaboom@oobleck.net> 1.2.12-1
566 - Rev to 1.2
567
568 * Fri May 20 2005 Matthias Saou <http://freshrpms.net/> 1.0.49-5
569 - Include patch from Michael to fix perl module compilation on FC4 (#156242).
570
571 * Fri May 20 2005 Matthias Saou <http://freshrpms.net/> 1.0.49-4
572 - Fix for the php module patch (Joe Pruett, Dag Wieers), #156716.
573 - Update source URL to new location since 1.2 is now the default stable.
574 - Don't (yet) update to 1.0.50, as it introduces some changes in the perl
575   modules install.
576
577 * Mon Jan 31 2005 Matthias Saou <http://freshrpms.net/> 1.0.49-3
578 - Put perl modules in vendor_perl and not site_perl. #146513
579
580 * Thu Jan 13 2005 Matthias Saou <http://freshrpms.net/> 1.0.49-2
581 - Minor cleanups.
582
583 * Thu Aug 25 2004 Dag Wieers <dag@wieers.com> - 1.0.49-1
584 - Updated to release 1.0.49.
585
586 * Wed Aug 25 2004 Dag Wieers <dag@wieers.com> - 1.0.48-3
587 - Fixes for x86_64. (Garrick Staples)
588
589 * Fri Jul  2 2004 Matthias Saou <http://freshrpms.net/> 1.0.48-3
590 - Actually apply the patch for fixing the php module, doh!
591
592 * Thu May 27 2004 Matthias Saou <http://freshrpms.net/> 1.0.48-2
593 - Added php.d config entry to load the module once installed.
594
595 * Thu May 13 2004 Dag Wieers <dag@wieers.com> - 1.0.48-1
596 - Updated to release 1.0.48.
597
598 * Tue Apr 06 2004 Dag Wieers <dag@wieers.com> - 1.0.47-1
599 - Updated to release 1.0.47.
600
601 * Thu Mar  4 2004 Matthias Saou <http://freshrpms.net/> 1.0.46-2
602 - Change the strict dependency on perl to fix problem with the recent
603   update.
604
605 * Mon Jan  5 2004 Matthias Saou <http://freshrpms.net/> 1.0.46-1
606 - Update to 1.0.46.
607 - Use system libpng and zlib instead of bundled ones.
608 - Added php-rrdtool sub-package for the php4 module.
609
610 * Fri Dec  5 2003 Matthias Saou <http://freshrpms.net/> 1.0.45-4
611 - Added epoch to the perl dependency to work with rpm > 4.2.
612 - Fixed the %% escaping in the perl dep.
613
614 * Mon Nov 17 2003 Matthias Saou <http://freshrpms.net/> 1.0.45-2
615 - Rebuild for Fedora Core 1.
616
617 * Sun Aug  3 2003 Matthias Saou <http://freshrpms.net/>
618 - Update to 1.0.45.
619
620 * Wed Apr 16 2003 Matthias Saou <http://freshrpms.net/>
621 - Update to 1.0.42.
622
623 * Mon Mar 31 2003 Matthias Saou <http://freshrpms.net/>
624 - Rebuilt for Red Hat Linux 9.
625
626 * Wed Mar  5 2003 Matthias Saou <http://freshrpms.net/>
627 - Added explicit perl version dependency.
628
629 * Sun Feb 23 2003 Matthias Saou <http://freshrpms.net/>
630 - Update to 1.0.41.
631
632 * Fri Jan 31 2003 Matthias Saou <http://freshrpms.net/>
633 - Update to 1.0.40.
634 - Spec file cleanup.
635
636 * Fri Jul 05 2002 Henri Gomez <hgomez@users.sourceforge.net>
637 - 1.0.39
638
639 * Mon Jun 03 2002 Henri Gomez <hgomez@users.sourceforge.net>
640 - 1.0.38
641
642 * Fri Apr 19 2002 Henri Gomez <hgomez@users.sourceforge.net>
643 - 1.0.37
644
645 * Tue Mar 12 2002 Henri Gomez <hgomez@users.sourceforge.net>
646 - 1.0.34
647 - rrdtools include zlib 1.1.4 which fix vulnerabilities in 1.1.3
648