be6cb298d44ab10ac2410644a06642566dc96cf7
[rrdtool.git] / rrdtool.spec
1 %define with_python %{?_without_python: 0} %{?!_without_python: 1}
2 %define with_php %{?_without_php: 0} %{?!_without_php: 1}
3 %define with_tcl %{?_without_tcl: 0} %{?!_without_tcl: 1}
4 %define with_ruby %{?_without_ruby: 0} %{?!_without_ruby: 1}
5 %define php_extdir %(php-config --extension-dir 2>/dev/null || echo %{_libdir}/php4)
6 %define svnrev r1190
7 %define pre rc9
8 #define pretag 1.2.99908020600
9
10 Summary: Round Robin Database Tool to store and display time-series data
11 Name: rrdtool
12 Version: 1.3.99908093000
13 Release: 0.20%{?pre:.%{pre}}%{?dist}
14 License: GPLv2+ with exceptions
15 Group: Applications/Databases
16 URL: http://oss.oetiker.ch/rrdtool/
17 #Source0: http://oss.oetiker.ch/%{name}/pub/%{name}-%{version}.tar.gz
18 Source0: http://oss.oetiker.ch/rrdtool/pub/beta/%{name}-%{version}.tar.gz
19 %if %{with_php}
20 Source1: php4-%{svnrev}.tar.gz
21 Patch1: rrdtool-1.3.0-beta4-fix-rrd_update-in-php-bindings.patch
22 %endif
23 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
24 Requires: dejavu-lgc-fonts
25 BuildRequires: gcc-c++, openssl-devel, freetype-devel
26 BuildRequires: libpng-devel, zlib-devel, intltool >= 0.35.0
27 BuildRequires: cairo-devel >= 1.2, pango-devel >= 1.14
28 BuildRequires: libtool, groff
29 BuildRequires: gettext, libxml2-devel
30 %if 0%{?fedora} >= 7
31 BuildRequires: perl-ExtUtils-MakeMaker perl-devel
32 %endif
33
34 %description
35 RRD is the Acronym for Round Robin Database. RRD is a system to store and
36 display time-series data (i.e. network bandwidth, machine-room temperature,
37 server load average). It stores the data in a very compact way that will not
38 expand over time, and it presents useful graphs by processing the data to
39 enforce a certain data density. It can be used either via simple wrapper
40 scripts (from shell or Perl) or via frontends that poll network devices and
41 put a friendly user interface on it.
42
43 %package devel
44 Summary: RRDtool libraries and header files
45 Group: Development/Libraries
46 Requires: %{name} = %{version}-%{release}
47
48 %description devel
49 RRD is the Acronym for Round Robin Database. RRD is a system to store and
50 display time-series data (i.e. network bandwidth, machine-room temperature,
51 server load average). This package allow you to use directly this library.
52
53 %package doc
54 Summary: RRDtool documentation
55 Group: Documentation
56
57 %description doc
58 RRD is the Acronym for Round Robin Database. RRD is a system to store and
59 display time-series data (i.e. network bandwidth, machine-room temperature,
60 server load average). This package contains documentation on using RRD.
61
62 %package perl
63 Summary: Perl RRDtool bindings
64 Group: Development/Languages
65 Requires: %{name} = %{version}-%{release}
66 Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
67 Obsoletes: perl-%{name} < %{version}-%{release}
68 Provides: perl-%{name} = %{version}-%{release}
69
70 %description perl
71 The Perl RRDtool bindings
72
73 %if %{with_python}
74 %{!?python_sitearch: %define python_sitearch %(%{__python} -c 'from distutils import sysconfig; print sysconfig.get_python_lib(1)')}
75 # eval to 2.3 if python isn't yet present, workaround for no python in fc4 minimal buildroot
76 %{!?python_version: %define python_version %(%{__python} -c 'import sys; print sys.version.split(" ")[0]' || echo "2.3")}
77
78 %package python
79 Summary: Python RRDtool bindings
80 Group: Development/Languages
81 BuildRequires: python-devel >= 2.3
82 Requires: python >= %{python_version}
83 Requires: %{name} = %{version}-%{release}
84 Obsoletes: python-%{name} < %{version}-%{release}
85 Provides: python-%{name} = %{version}-%{release}
86
87 %description python
88 Python RRDtool bindings.
89 %endif
90
91 %ifarch ppc64
92 # php bits busted on ppc64 at the moment
93 %define with_php 0
94 %endif
95
96 %if %{with_php}
97 %package php
98 Summary: PHP RRDtool bindings
99 Group: Development/Languages
100 BuildRequires: php-devel >= 4.0
101 Requires: php >= 4.0
102 Requires: %{name} = %{version}-%{release}
103 %if 0%{?php_zend_api}
104 Requires: php(zend-abi) = %{php_zend_api}
105 Requires: php(api) = %{php_core_api}
106 %else
107 Requires: php-api = %{php_apiver}
108 %endif
109 Obsoletes: php-%{name} < %{version}-%{release}
110 Provides: php-%{name} = %{version}-%{release}
111 Provides: php-pecl(rrdtool)
112
113 %description php
114 The %{name}-php package includes a dynamic shared object (DSO) that adds
115 RRDtool bindings to the PHP HTML-embedded scripting language.
116 %endif
117
118 %if %{with_tcl}
119 %package tcl
120 Summary: Tcl RRDtool bindings
121 Group: Development/Languages
122 BuildRequires: tcl-devel >= 8.0
123 Requires: tcl >= 8.0
124 Requires: %{name} = %{version}-%{release}
125 Obsoletes: tcl-%{name} < %{version}-%{release}
126 Provides: tcl-%{name} = %{version}-%{release}
127
128 %description tcl
129 The %{name}-tcl package includes RRDtool bindings for Tcl.
130 %endif
131
132 %if %{with_ruby}
133 %{!?ruby_sitearch: %define ruby_sitearch %(ruby -rrbconfig -e 'puts Config::CONFIG["sitearchdir"]')}
134
135 %package ruby
136 Summary: Ruby RRDtool bindings
137 Group: Development/Languages
138 BuildRequires: ruby, ruby-devel
139 Requires: ruby(abi) = 1.8
140 Requires: %{name} = %{version}-%{release}
141
142 %description ruby
143 The %{name}-ruby package includes RRDtool bindings for Ruby.
144 %endif
145
146 %prep
147 %if %{with_php}
148 %setup -q -n %{name}-%{version} -a 1
149 %patch1 -p1
150 %else
151 %setup -q -n %{name}-%{version}
152 %endif
153
154 # Fix to find correct python dir on lib64
155 %{__perl} -pi -e 's|get_python_lib\(0,0,prefix|get_python_lib\(1,0,prefix|g' \
156     configure
157
158 # Most edits shouldn't be necessary when using --libdir, but
159 # w/o, some introduce hardcoded rpaths where they shouldn't
160 %{__perl} -pi.orig -e 's|/lib\b|/%{_lib}|g' configure Makefile.in*
161 %if %{with_php}
162 %{__perl} -pi.orig -e 's|/lib\b|/%{_lib}|g' php4/configure php4/ltconfig*
163 %endif
164
165 # Perl 5.10 seems to not like long version strings, hack around it
166 %{__perl} -pi.orig -e 's|1.299907080300|1.29990708|' \
167     bindings/perl-shared/RRDs.pm bindings/perl-piped/RRDp.pm
168
169 #
170 # fix config files for php4 bindings
171 # workaround needed due to https://bugzilla.redhat.com/show_bug.cgi?id=211069
172 %if %{with_php}
173 cp -p /usr/lib/rpm/config.{guess,sub} php4/
174 %endif
175
176
177 %build
178 %configure \
179     CFLAGS="-g -O0" \
180     --with-perl-options='INSTALLDIRS="vendor"' \
181 %if %{with_tcl}
182     --enable-tcl-site \
183     --with-tcllib=%{_libdir} \
184 %else
185     --disable-tcl \
186 %endif
187 %if %{with_python}
188     --enable-python \
189 %else
190     --disable-python \
191 %endif
192 %if %{with_ruby}
193     --enable-ruby \
194 %endif
195     --disable-static \
196     --with-pic
197
198 # Fix another rpath issue
199 %{__perl} -pi.orig -e 's|-Wl,--rpath -Wl,\$rp||g' \
200     bindings/perl-shared/Makefile.PL
201
202 # Force RRDp bits where we want 'em, not sure yet why the
203 # --with-perl-options and --libdir don't take
204 pushd bindings/perl-piped/
205 %{__perl} Makefile.PL INSTALLDIRS=vendor
206 %{__perl} -pi.orig -e 's|/lib/perl|/%{_lib}/perl|g' Makefile
207 popd
208
209 #{__make} %{?_smp_mflags}
210 make
211
212 # Build the php module, the tmp install is required
213 %if %{with_php}
214 %define rrdtmp %{_tmppath}/%{name}-%{version}-tmpinstall
215 %{__make} install DESTDIR="%{rrdtmp}"
216 pushd php4/
217 %configure \
218     --with-rrdtool="%{rrdtmp}%{_prefix}" \
219     --disable-static
220 #{__make} %{?_smp_mflags}
221 make
222 popd
223 %{__rm} -rf %{rrdtmp}
224 %endif
225
226 # Fix @perl@ and @PERL@
227 find examples/ -type f \
228     -exec %{__perl} -pi -e 's|^#! \@perl\@|#!%{__perl}|gi' {} \;
229 find examples/ -name "*.pl" \
230     -exec %{__perl} -pi -e 's|\015||gi' {} \;
231
232 %install
233 rm -rf $RPM_BUILD_ROOT
234 make DESTDIR="$RPM_BUILD_ROOT" install
235
236 # Install the php module
237 %if %{with_php}
238 %{__install} -D -m0755 php4/modules/rrdtool.so \
239     %{buildroot}%{php_extdir}/rrdtool.so
240 # Clean up the examples for inclusion as docs
241 %{__rm} -rf php4/examples/.svn
242 # Put the php config bit into place
243 %{__mkdir_p} %{buildroot}%{_sysconfdir}/php.d
244 %{__cat} << __EOF__ > %{buildroot}%{_sysconfdir}/php.d/rrdtool.ini
245 ; Enable rrdtool extension module
246 extension=rrdtool.so
247 __EOF__
248 %endif
249
250 # Pesky RRDp.pm...
251 %{__mv} $RPM_BUILD_ROOT%{perl_vendorarch}/../RRDp.pm $RPM_BUILD_ROOT%{perl_vendorarch}/
252
253 # Dunno why this is getting installed here...
254 %{__rm} -f $RPM_BUILD_ROOT%{perl_vendorarch}/../leaktest.pl
255
256 # We only want .txt and .html files for the main documentation
257 %{__mkdir_p} doc2/html doc2/txt
258 %{__cp} -a doc/*.txt doc2/txt/
259 %{__cp} -a doc/*.html doc2/html/
260
261 # Put perl docs in perl package
262 %{__mkdir_p} doc3/html
263 %{__mv} doc2/html/RRD*.html doc3/html/
264
265 # Clean up the examples
266 %{__rm} -f examples/Makefile* examples/*.in
267
268 # This is so rpm doesn't pick up perl module dependencies automatically
269 find examples/ -type f -exec chmod 0644 {} \;
270
271 # Clean up the buildroot
272 %{__rm} -rf $RPM_BUILD_ROOT%{_docdir}/%{name}-* \
273         $RPM_BUILD_ROOT%{perl_vendorarch}/ntmake.pl \
274         $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod \
275         $RPM_BUILD_ROOT%{_datadir}/%{name}/examples \
276         $RPM_BUILD_ROOT%{perl_vendorarch}/auto/*/{.packlist,*.bs}
277
278 # Set up rrdcached
279 %__install -d -m 0755 $RPM_BUILD_ROOT/%{_sysconfdir}/default
280 %__install -d -m 0755 $RPM_BUILD_ROOT/%{_sysconfdir}/rc.d/init.d
281 %__install -m 0644 etc/rrdcached-default $RPM_BUILD_ROOT/%{_sysconfdir}/default/rrdcached
282 %__install -m 0755 etc/rrdcached-init $RPM_BUILD_ROOT/%{_sysconfdir}/rc.d/init.d/rrdcached
283 %__install -d -m 0755 -o nobody -g nobody $RPM_BUILD_ROOT/%{_localstatedir}/run/rrdcached
284
285 %clean
286 %{__rm} -rf $RPM_BUILD_ROOT
287
288 %post
289 /sbin/ldconfig
290 /sbin/chkconfig --add rrdcached
291 /sbin/service rrdcached start
292
293 %preun
294 /sbin/service rrdcached stop
295
296 %postun
297 /sbin/chkconfig --del rrdcached
298 /sbin/ldconfig
299
300 %files
301 %defattr(-,root,root,-)
302 %{_bindir}/*
303 %{_libdir}/*.so.*
304 %{_datadir}/%{name}
305 %{_mandir}/man1/*
306 %config %{_sysconfdir}/default/*
307 %config %{_sysconfdir}/rc.d/init.d/*
308 %attr(0775 nobody nobody) %dir %{_localstatedir}/run/rrdcached
309
310 %files devel
311 %defattr(-,root,root,-)
312 %{_includedir}/*.h
313 %exclude %{_libdir}/*.la
314 %{_libdir}/*.so
315 %{_libdir}/pkgconfig/librrd.pc
316
317 %files doc
318 %defattr(-,root,root,-)
319 %doc CONTRIBUTORS COPYING COPYRIGHT README TODO NEWS THREADS
320 %doc examples doc2/html doc2/txt
321
322 %files perl
323 %defattr(-,root,root,-)
324 %doc doc3/html
325 %{_mandir}/man3/*
326 %{perl_vendorarch}/*.pm
327 %attr(0755,root,root) %{perl_vendorarch}/auto/RRDs/
328
329 %if %{with_python}
330 %files python
331 %defattr(-,root,root,-)
332 %doc bindings/python/AUTHORS bindings/python/COPYING bindings/python/README
333 %{python_sitearch}/rrdtoolmodule.so
334 %{python_sitearch}/py_rrdtool-*.egg-info
335 %endif
336
337 %if %{with_php}
338 %files php
339 %defattr(-,root,root,0755)
340 %doc php4/examples php4/README
341 %config(noreplace) %{_sysconfdir}/php.d/rrdtool.ini
342 %{php_extdir}/rrdtool.so
343 %endif
344
345 %if %{with_tcl}
346 %files tcl
347 %defattr(-,root,root,-)
348 %doc bindings/tcl/README
349 %{_libdir}/tclrrd*.so
350 %{_libdir}/rrdtool/*.tcl
351 %endif
352
353 %if %{with_ruby}
354 %files ruby
355 %defattr(-,root,root,-)
356 %doc bindings/ruby/README
357 %{ruby_sitearch}/RRD.so
358 %endif
359
360 %changelog
361 * Tue Oct 07 2008 Bernard Li <bernard@vanhpc.org>
362 - Include librrd.pc file in -devel package
363
364 * Sun Jun 08 2008 Jarod Wilson <jwilson@redhat.com> 1.3-0.20.rc9
365 - Update to rrdtool 1.3 rc9
366 - Minor spec tweaks to permit building on older EL
367
368 * Wed Jun 04 2008 Chris Ricker <kaboom@oobleck.net> 1.3-0.19.rc7
369 - Update to rrdtool 1.3 rc7
370
371 * Tue May 27 2008 Chris Ricker <kaboom@oobleck.net> 1.3-0.18.rc6
372 - Update to rrdtool 1.3 rc6
373
374 * Wed May 21 2008 Chris Ricker <kaboom@oobleck.net> 1.3-0.17.rc4
375 - Bump version and rebuild
376
377 * Wed May 21 2008 Chris Ricker <kaboom@oobleck.net> 1.3-0.16.rc4
378 - Fix php bindings compile on x86_64
379
380 * Mon May 19 2008 Chris Ricker <kaboom@oobleck.net> 1.3-0.15.rc4
381 - Update to rrdtool 1.3 rc4
382
383 * Tue May 13 2008 Jarod Wilson <jwilson@redhat.com> 1.3-0.15.rc1
384 - Update to rrdtool 1.3 rc1
385 - Fix versioning in changelog entries, had an extra 0 in there...
386 - Drop cairo and python patches, they're in 1.3 rc1
387 - Add Requires: gettext and libxml2-devel for new translations
388
389 * Wed Apr 30 2008 Jarod Wilson <jwilson@redhat.com> 1.3-0.14.beta4
390 - Drop some conditional flags, they're not working at the moment...
391
392 * Wed Apr 30 2008 Jarod Wilson <jwilson@redhat.com> 1.3-0.13.beta4
393 - Fix problem with cairo_save/cairo_restore (#444827)
394
395 * Wed Apr 23 2008 Jarod Wilson <jwilson@redhat.com> 1.3-0.12.beta4
396 - Fix python bindings rrdtool info implementation (#435468)
397
398 * Tue Apr 08 2008 Jarod Wilson <jwilson@redhat.com> 1.3-0.11.beta4
399 - Work around apparent version string length issue w/perl 5.10 (#441359)
400
401 * Sat Apr 05 2008 Jarod Wilson <jwilson@redhat.com> 1.3-0.10.beta4
402 - Fix use of rrd_update in php bindings (#437558)
403
404 * Mon Mar  3 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.3-0.9.beta4
405 - rebuild for new perl (again)
406
407 * Wed Feb 13 2008 Jarod Wilson <jwilson@redhat.com> 1.3-0.8.beta4
408 - Update to rrdtool 1.3 beta4
409
410 * Tue Feb 05 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.3-0.7.beta3
411 - rebuild for new perl (and fix license tag)
412
413 * Mon Feb 04 2008 Jarod Wilson <jwilson@redhat.com> 1.3-0.6.beta3
414 - Plug memory leak (#430879)
415
416 * Mon Jan 07 2008 Jarod Wilson <jwilson@redhat.com> 1.3-0.5.beta3
417 - Fix right-aligned text alignment and scaling (Resolves: #427609)
418
419 * Wed Jan 02 2008 Jarod Wilson <jwilson@redhat.com> 1.3-0.4.beta3
420 - Add newly built python egg to %%files
421
422 * Wed Jan 02 2008 Jarod Wilson <jwilson@redhat.com> 1.3-0.3.beta3
423 - Update to rrdtool 1.3 beta3
424 - Return properly from errors in RRDp.pm (Resolves: #427040)
425 - Requires: dejavu-lgc-fonts (Resolves: #426935)
426
427 * Thu Dec 06 2007 Jarod Wilson <jwilson@redhat.com> 1.3-0.2.beta2
428 - Update to rrdtool 1.3 beta2
429
430 * Wed Aug 08 2007 Jarod Wilson <jwilson@redhat.com> 1.3-0.1.beta1
431 - Update to rrdtool 1.3 beta1
432
433 * Tue Jul 10 2007 Jarod Wilson <jwilson@redhat.com> 1.2.999-0.3.r1144
434 - Update to latest rrdtool pre-1.3 svn snapshot (svn r1144)
435 - Add php abi check (Resolves: #247339)
436
437 * Fri Jun 15 2007 Jarod Wilson <jwilson@redhat.com> 1.2.999-0.2.r1127
438 - Fix up BuildRequires
439
440 * Fri Jun 15 2007 Jarod Wilson <jwilson@redhat.com> 1.2.999-0.1.r1127
441 - Update to rrdtool pre-1.3 svn snapshot (svn r1127)
442
443 * Mon May 21 2007 Jarod Wilson <jwilson@redhat.com> 1.2.23-5
444 - BR: ruby so %%ruby_sitearch gets set
445
446 * Mon May 21 2007 Jarod Wilson <jwilson@redhat.com> 1.2.23-4
447 - Build ruby bindings
448
449 * Thu May 03 2007 Jarod Wilson <jwilson@redhat.com> 1.2.23-3
450 - Disable php bits on ppc64 for now, they fail to build
451
452 * Thu May 03 2007 Jarod Wilson <jwilson@redhat.com> 1.2.23-2
453 - Add BR: perl-devel for Fedora 7 and later
454
455 * Tue May 01 2007 Jarod Wilson <jwilson@redhat.com> 1.2.23-1
456 - New upstream release
457
458 * Tue May 01 2007 Jarod Wilson <jwilson@redhat.com> 1.2.21-1
459 - New upstream release
460
461 * Wed Apr 25 2007 Jarod Wilson <jwilson@redhat.com> 1.2.19-2
462 - Define %%python_version *before* its needed (#237826)
463
464 * Mon Apr 09 2007 Jarod Wilson <jwilson@redhat.com> 1.2.19-1
465 - New upstream release
466
467 * Tue Jan 23 2007 Jarod Wilson <jwilson@redhat.com> 1.2.18-1
468 - New upstream release
469
470 * Mon Jan 22 2007 Jarod Wilson <jwilson@redhat.com> 1.2.17-1
471 - New upstream release
472
473 * Tue Jan 02 2007 Jarod Wilson <jwilson@redhat.com> 1.2.15-9
474 - Fix crash with long error strings (upstream
475   changesets 929 and 935)
476
477 * Thu Dec 14 2006 Jarod Wilson <jwilson@redhat.com> 1.2.15-8
478 - Fix for log grid memory leak (#201241)
479
480 * Tue Dec 12 2006 Jarod Wilson <jwilson@redhat.com> 1.2.15-7
481 - Rebuild for python 2.5
482
483 * Tue Nov 14 2006 Jarod Wilson <jwilson@redhat.com> 1.2.15-6
484 - Conditionalize python, php and tcl bits (Resolves #203275)
485
486 * Wed Oct 25 2006 Jarod Wilson <jwilson@redhat.com> 1.2.15-5
487 - Add tcl sub-package (#203275)
488
489 * Tue Sep 05 2006 Jarod Wilson <jwilson@redhat.com> 1.2.15-4
490 - Rebuild for new glibc
491
492 * Wed Aug 02 2006 Jarod Wilson <jwilson@redhat.com> 1.2.15-3
493 - One more addition to initrrdtool patch, to fully revert
494   and correct upstream changeset 839
495 - Fix for no python in minimal fc4 buildroots
496
497 * Tue Aug  1 2006 Mihai Ibanescu <misa@redhat.com> 1.2.15-2
498 - Fixed rrdtool-python to import the module properly (patch
499   rrdtool-1.2.15-initrrdtool.patch)
500
501 * Mon Jul 17 2006 Jarod Wilson <jwilson@redhat.com> 1.2.15-1
502 - Update to 1.2.15
503 - Minor spec cleanups
504
505 * Sat Jun 24 2006 Jarod Wilson <jwilson@redhat.com> 1.2.13-7
506 - Fix up Obsoletes
507
508 * Mon Jun 19 2006 Jarod Wilson <jwilson@redhat.com> 1.2.13-6
509 - Flip perl, php and python sub-package names around to 
510   conform with general practices
511
512 * Sat Jun 10 2006 Jarod Wilson <jwilson@redhat.com> 1.2.13-5
513 - Minor fixes to make package own created directories
514
515 * Wed Jun 07 2006 Jarod Wilson <jwilson@redhat.com> 1.2.13-4
516 - Add php bits back into the mix
517
518 * Mon Jun 05 2006 Jarod Wilson <jwilson@redhat.com> 1.2.13-3
519 - Merge spec fixes from bz 185909
520
521 * Sun Jun 04 2006 Jarod Wilson <jwilson@redhat.com> 1.2.13-2
522 - Remove explicit perl dep, version grabbing using rpm during
523   rpmbuild not guaranteed to work (fails on ppc in plague),
524   and auto-gen perl deps are sufficient
525
526 * Sat Jun 03 2006 Jarod Wilson <jwilson@redhat.com> 1.2.13-1
527 - Update to release 1.2.13
528 - Merge spec changes from dag, atrpms and mdk builds
529 - Additional hacktastic contortions for lib64 & rpath messiness
530 - Add missing post/postun ldconfig
531 - Fix a bunch of rpmlint errors
532 - Disable static libs, per FE guidelines
533 - Split off docs
534
535 * Wed Apr 19 2006 Chris Ricker <kaboom@oobleck.net> 1.2.12-1
536 - Rev to 1.2
537
538 * Fri May 20 2005 Matthias Saou <http://freshrpms.net/> 1.0.49-5
539 - Include patch from Michael to fix perl module compilation on FC4 (#156242).
540
541 * Fri May 20 2005 Matthias Saou <http://freshrpms.net/> 1.0.49-4
542 - Fix for the php module patch (Joe Pruett, Dag Wieers), #156716.
543 - Update source URL to new location since 1.2 is now the default stable.
544 - Don't (yet) update to 1.0.50, as it introduces some changes in the perl
545   modules install.
546
547 * Mon Jan 31 2005 Matthias Saou <http://freshrpms.net/> 1.0.49-3
548 - Put perl modules in vendor_perl and not site_perl. #146513
549
550 * Thu Jan 13 2005 Matthias Saou <http://freshrpms.net/> 1.0.49-2
551 - Minor cleanups.
552
553 * Thu Aug 25 2004 Dag Wieers <dag@wieers.com> - 1.0.49-1
554 - Updated to release 1.0.49.
555
556 * Wed Aug 25 2004 Dag Wieers <dag@wieers.com> - 1.0.48-3
557 - Fixes for x86_64. (Garrick Staples)
558
559 * Fri Jul  2 2004 Matthias Saou <http://freshrpms.net/> 1.0.48-3
560 - Actually apply the patch for fixing the php module, doh!
561
562 * Thu May 27 2004 Matthias Saou <http://freshrpms.net/> 1.0.48-2
563 - Added php.d config entry to load the module once installed.
564
565 * Thu May 13 2004 Dag Wieers <dag@wieers.com> - 1.0.48-1
566 - Updated to release 1.0.48.
567
568 * Tue Apr 06 2004 Dag Wieers <dag@wieers.com> - 1.0.47-1
569 - Updated to release 1.0.47.
570
571 * Thu Mar  4 2004 Matthias Saou <http://freshrpms.net/> 1.0.46-2
572 - Change the strict dependency on perl to fix problem with the recent
573   update.
574
575 * Mon Jan  5 2004 Matthias Saou <http://freshrpms.net/> 1.0.46-1
576 - Update to 1.0.46.
577 - Use system libpng and zlib instead of bundled ones.
578 - Added php-rrdtool sub-package for the php4 module.
579
580 * Fri Dec  5 2003 Matthias Saou <http://freshrpms.net/> 1.0.45-4
581 - Added epoch to the perl dependency to work with rpm > 4.2.
582 - Fixed the %% escaping in the perl dep.
583
584 * Mon Nov 17 2003 Matthias Saou <http://freshrpms.net/> 1.0.45-2
585 - Rebuild for Fedora Core 1.
586
587 * Sun Aug  3 2003 Matthias Saou <http://freshrpms.net/>
588 - Update to 1.0.45.
589
590 * Wed Apr 16 2003 Matthias Saou <http://freshrpms.net/>
591 - Update to 1.0.42.
592
593 * Mon Mar 31 2003 Matthias Saou <http://freshrpms.net/>
594 - Rebuilt for Red Hat Linux 9.
595
596 * Wed Mar  5 2003 Matthias Saou <http://freshrpms.net/>
597 - Added explicit perl version dependency.
598
599 * Sun Feb 23 2003 Matthias Saou <http://freshrpms.net/>
600 - Update to 1.0.41.
601
602 * Fri Jan 31 2003 Matthias Saou <http://freshrpms.net/>
603 - Update to 1.0.40.
604 - Spec file cleanup.
605
606 * Fri Jul 05 2002 Henri Gomez <hgomez@users.sourceforge.net>
607 - 1.0.39
608
609 * Mon Jun 03 2002 Henri Gomez <hgomez@users.sourceforge.net>
610 - 1.0.38
611
612 * Fri Apr 19 2002 Henri Gomez <hgomez@users.sourceforge.net>
613 - 1.0.37
614
615 * Tue Mar 12 2002 Henri Gomez <hgomez@users.sourceforge.net>
616 - 1.0.34
617 - rrdtools include zlib 1.1.4 which fix vulnerabilities in 1.1.3
618