get the docs ready for the 1.2 release. remove notes about things that never got...
[rrdtool.git] / rrdtool.spec
1 %define cvsdate cvs-snap
2 %define cvsver %(echo %{cvsdate} | tr -d -)
3 %define sover 1.0.0
4
5 Summary: Round Robin Database Tools
6 Name: rrdtool
7 Version: 1.2rc6
8 Release: %{cvsver}
9 License: GPL
10 Group: Applications/Databases
11 Source: http://people.ee.ethz.ch/~oetiker/webtools/rrdtool/pub/beta/rrdtool-1.2rc1.tar.gz
12 URL: http://people.ee.ethz.ch/~oetiker/webtools/rrdtool/
13 Buildroot: /tmp/%{name}-root
14
15 BuildRequires: perl
16 BuildRequires: cgilib-devel
17 BuildRequires: freetype-devel libart_lgpl-devel libpng-devel zlib-devel
18
19 %description
20 It is pretty easy to gather status information from all sorts of things,
21 ranging from the temperature in your office to the number of octets which
22 have passed through the FDDI interface of your router. But it is not so
23 trivial to store this data in a efficient and systematic manner. This is
24 where RRDtool kicks in. It lets you log and analyze the data you gather from
25 all kinds of data-sources (DS). The data analysis part of RRDtool is based
26 on the ability to quickly generate graphical representations of the data
27 values collected over a definable time period.
28
29 %package devel
30 Summary: RRD Tool development libraries and header files
31 Group: Development/Libraries
32 Requires: %{name} = %{version}
33
34 %description devel
35 The RRD Tools development library.
36
37 %package perl
38 Summary: RRD Tool Perl interface
39 Group: Applications/Databases
40 Requires: %{name} = %{version}
41
42 %description perl
43 The RRD Tools Perl modules.
44
45 %prep
46 %setup -q -n rrdtool-%{cvsdate}
47
48 %define deffont %{_datadir}/%{name}/fonts/VeraMono.ttf
49
50 %build
51 CPPFLAGS="-I/usr/include/libart-2.0 -I/usr/include/freetype2"
52 export CPPFLAGS
53 %configure
54 make
55
56 %install
57 rm -rf %{buildroot}
58 %makeinstall
59
60 # Install the font
61 mkdir -p %{buildroot}%{_datadir}/fonts
62 install -m 644 src/VeraMono.ttf %{buildroot}%{deffont}
63
64 # Fix up the documentation
65 [ -d docs ] && mv docs docs.src
66 mv %{buildroot}/usr/doc docs
67 rm -f docs/*.pod
68 [ -d examples ] && mv examples examples.src
69 mv %{buildroot}/usr/examples examples
70 [ -d html ] && mv html html.src
71 mv %{buildroot}/usr/html html
72
73 # Fix up the perl
74 %define perlsite %(perl -MConfig -e 'print $Config{"installsitearch"}')
75 mkdir -p %{buildroot}%{perlsite}
76 mv %{buildroot}%{_libdir}/perl/* %{buildroot}%{perlsite}
77 rmdir %{buildroot}%{_libdir}/perl
78 rm -f %{buildroot}/%{perlsite}/auto/RRDs/RRDs.bs
79
80 # Fix up the man pages
81 if [ "%{_mandir}" != "/usr/share/man" ]; then
82         mkdir -p %{buildroot}%{_mandir}
83         mv %{buildroot}/usr/man/* %{buildroot}%{_mandir}/
84 fi
85
86 %post
87 /sbin/ldconfig
88
89 %postun
90 /sbin/ldconfig
91
92 %clean
93 rm -rf %{buildroot}
94
95 %files
96 %defattr (-, root, root)
97 %doc 00README CONTRIBUTORS COPYING COPYRIGHT NEWS PROJECTS
98 %doc README THREADS TODO
99 %doc docs/[a-z]* html/[a-z]*
100 %doc examples/*.cgi
101 %{_bindir}/rrdcgi
102 %{_bindir}/rrdtool
103 %{_bindir}/rrdupdate
104 %{_libdir}/librrd.so.%{sover}
105 %{_libdir}/librrd_th.so.%{sover}
106 %{_mandir}/man1/[a-z]*
107 %{deffont}
108
109 %files devel
110 %defattr (-, root, root)
111 %{_includedir}/rrd.h
112 %{_libdir}/librrd.a
113 %{_libdir}/librrd.la
114 %{_libdir}/librrd.so
115 %{_libdir}/librrd_th.a
116 %{_libdir}/librrd_th.la
117 %{_libdir}/librrd_th.so
118
119 %files perl
120 %doc examples/*.pl
121 %doc docs/RRD* html/RRD*
122 %defattr (-, root, root)
123 %{perlsite}/RRDp.pm
124 %{perlsite}/RRDs.pm
125 %dir %{perlsite}/auto/RRDs
126 %{perlsite}/auto/RRDs/RRDs.so
127 %{_mandir}/man1/RRDp.1*
128 %{_mandir}/man1/RRDs.1*
129
130 %changelog
131 * Wed May 26 2004 Mike Slifcak <slif@bellsouth.net> 1.1.0-0.1.20040526
132 - package examples with rrdtool-perl (decouple Perl from main package)
133 * Thu Apr 29 2004 Chris Adams <cmadams@hiwaay.net> 1.1.0-0.1.20040430
134 - initial build