update to rpm spec from Jarod Wilson
[rrdtool.git] / rrdtool.spec
1 %define with_python %{?_without_python: 0} %{?!_without_python: 1}
2 %define with_php %{?_without_php: 0} %{?!_without_php: 1}
3 %define with_tcl %{?_without_tcl: 0} %{?!_without_tcl: 1}
4 %define with_ruby %{?_without_ruby: 0} %{?!_without_ruby: 1}
5 %define php_extdir %(php-config --extension-dir 2>/dev/null || echo %{_libdir}/php4)
6 %define svnrev r1190
7 %define pre rc9
8 #define pretag 1.2.99908020600
9
10 Summary: Round Robin Database Tool to store and display time-series data
11 Name: rrdtool
12 Version: 1.3
13 Release: 0.20%{?pre:.%{pre}}%{?dist}
14 License: GPLv2+ with exceptions
15 Group: Applications/Databases
16 URL: http://oss.oetiker.ch/rrdtool/
17 #Source0: http://oss.oetiker.ch/%{name}/pub/%{name}-%{version}.tar.gz
18 Source0: http://oss.oetiker.ch/rrdtool/pub/beta/%{name}-%{version}%{pre}.tar.gz
19 Source1: php4-%{svnrev}.tar.gz
20 Patch1: rrdtool-1.3.0-beta4-fix-rrd_update-in-php-bindings.patch
21 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
22 Requires: dejavu-lgc-fonts
23 BuildRequires: gcc-c++, openssl-devel, freetype-devel
24 BuildRequires: libpng-devel, zlib-devel, intltool >= 0.35.0
25 BuildRequires: cairo-devel >= 1.4.6, pango-devel >= 1.17
26 BuildRequires: libtool, groff
27 BuildRequires: gettext, libxml2-devel
28 %if 0%{?fedora} >= 7
29 BuildRequires: perl-ExtUtils-MakeMaker perl-devel
30 %endif
31
32 %description
33 RRD is the Acronym for Round Robin Database. RRD is a system to store and
34 display time-series data (i.e. network bandwidth, machine-room temperature,
35 server load average). It stores the data in a very compact way that will not
36 expand over time, and it presents useful graphs by processing the data to
37 enforce a certain data density. It can be used either via simple wrapper
38 scripts (from shell or Perl) or via frontends that poll network devices and
39 put a friendly user interface on it.
40
41 %package devel
42 Summary: RRDtool libraries and header files
43 Group: Development/Libraries
44 Requires: %{name} = %{version}-%{release}
45
46 %description devel
47 RRD is the Acronym for Round Robin Database. RRD is a system to store and
48 display time-series data (i.e. network bandwidth, machine-room temperature,
49 server load average). This package allow you to use directly this library.
50
51 %package doc
52 Summary: RRDtool documentation
53 Group: Documentation
54
55 %description doc
56 RRD is the Acronym for Round Robin Database. RRD is a system to store and
57 display time-series data (i.e. network bandwidth, machine-room temperature,
58 server load average). This package contains documentation on using RRD.
59
60 %package perl
61 Summary: Perl RRDtool bindings
62 Group: Development/Languages
63 Requires: %{name} = %{version}-%{release}
64 Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
65 Obsoletes: perl-%{name} < %{version}-%{release}
66 Provides: perl-%{name} = %{version}-%{release}
67
68 %description perl
69 The Perl RRDtool bindings
70
71 %if %{with_python}
72 %{!?python_sitearch: %define python_sitearch %(%{__python} -c 'from distutils import sysconfig; print sysconfig.get_python_lib(1)')}
73 # eval to 2.3 if python isn't yet present, workaround for no python in fc4 minimal buildroot
74 %{!?python_version: %define python_version %(%{__python} -c 'import sys; print sys.version.split(" ")[0]' || echo "2.3")}
75
76 %package python
77 Summary: Python RRDtool bindings
78 Group: Development/Languages
79 BuildRequires: python-devel >= 2.3
80 Requires: python >= %{python_version}
81 Requires: %{name} = %{version}-%{release}
82 Obsoletes: python-%{name} < %{version}-%{release}
83 Provides: python-%{name} = %{version}-%{release}
84
85 %description python
86 Python RRDtool bindings.
87 %endif
88
89 %ifarch ppc64
90 # php bits busted on ppc64 at the moment
91 %define with_php 0
92 %endif
93
94 %if %{with_php}
95 %package php
96 Summary: PHP RRDtool bindings
97 Group: Development/Languages
98 BuildRequires: php-devel >= 4.0
99 Requires: php >= 4.0
100 Requires: %{name} = %{version}-%{release}
101 %if 0%{?php_zend_api}
102 Requires: php(zend-abi) = %{php_zend_api}
103 Requires: php(api) = %{php_core_api}
104 %else
105 Requires: php-api = %{php_apiver}
106 %endif
107 Obsoletes: php-%{name} < %{version}-%{release}
108 Provides: php-%{name} = %{version}-%{release}
109 Provides: php-pecl(rrdtool)
110
111 %description php
112 The %{name}-php package includes a dynamic shared object (DSO) that adds
113 RRDtool bindings to the PHP HTML-embedded scripting language.
114 %endif
115
116 %if %{with_tcl}
117 %package tcl
118 Summary: Tcl RRDtool bindings
119 Group: Development/Languages
120 BuildRequires: tcl-devel >= 8.0
121 Requires: tcl >= 8.0
122 Requires: %{name} = %{version}-%{release}
123 Obsoletes: tcl-%{name} < %{version}-%{release}
124 Provides: tcl-%{name} = %{version}-%{release}
125
126 %description tcl
127 The %{name}-tcl package includes RRDtool bindings for Tcl.
128 %endif
129
130 %if %{with_ruby}
131 %{!?ruby_sitearch: %define ruby_sitearch %(ruby -rrbconfig -e 'puts Config::CONFIG["sitearchdir"]')}
132
133 %package ruby
134 Summary: Ruby RRDtool bindings
135 Group: Development/Languages
136 BuildRequires: ruby, ruby-devel
137 Requires: ruby(abi) = 1.8
138 Requires: %{name} = %{version}-%{release}
139
140 %description ruby
141 The %{name}-ruby package includes RRDtool bindings for Ruby.
142 %endif
143
144 %prep
145 %setup -q -n %{name}-%{version}%{pre} %{?with_php: -a 1}
146 %if %{with_php}
147 %patch1 -p1
148 %endif
149
150 # Fix to find correct python dir on lib64
151 %{__perl} -pi -e 's|get_python_lib\(0,0,prefix|get_python_lib\(1,0,prefix|g' \
152     configure
153
154 # Most edits shouldn't be necessary when using --libdir, but
155 # w/o, some introduce hardcoded rpaths where they shouldn't
156 %{__perl} -pi.orig -e 's|/lib\b|/%{_lib}|g' \
157     configure Makefile.in php4/configure php4/ltconfig*
158
159 # Perl 5.10 seems to not like long version strings, hack around it
160 %{__perl} -pi.orig -e 's|1.299907080300|1.29990708|' \
161     bindings/perl-shared/RRDs.pm bindings/perl-piped/RRDp.pm
162
163 #
164 # fix config files for php4 bindings
165 # workaround needed due to https://bugzilla.redhat.com/show_bug.cgi?id=211069
166 cp -p /usr/lib/rpm/config.{guess,sub} php4/
167
168 %build
169 %configure \
170     --with-perl-options='INSTALLDIRS="vendor"' \
171 %if %{with_tcl}
172     --enable-tcl-site \
173     --with-tcllib=%{_libdir} \
174 %else
175     --disable-tcl \
176 %endif
177 %if %{with_python}
178     --enable-python \
179 %else
180     --disable-python \
181 %endif
182 %if %{with_ruby}
183     --enable-ruby \
184 %endif
185     --disable-static \
186     --with-pic
187
188 # Fix another rpath issue
189 %{__perl} -pi.orig -e 's|-Wl,--rpath -Wl,\$rp||g' \
190     bindings/perl-shared/Makefile.PL
191
192 # Force RRDp bits where we want 'em, not sure yet why the
193 # --with-perl-options and --libdir don't take
194 pushd bindings/perl-piped/
195 %{__perl} Makefile.PL INSTALLDIRS=vendor
196 %{__perl} -pi.orig -e 's|/lib/perl|/%{_lib}/perl|g' Makefile
197 popd
198
199 #{__make} %{?_smp_mflags}
200 make
201
202 # Build the php module, the tmp install is required
203 %if %{with_php}
204 %define rrdtmp %{_tmppath}/%{name}-%{version}-tmpinstall
205 %{__make} install DESTDIR="%{rrdtmp}"
206 pushd php4/
207 %configure \
208     --with-rrdtool="%{rrdtmp}%{_prefix}" \
209     --disable-static
210 #{__make} %{?_smp_mflags}
211 make
212 popd
213 %{__rm} -rf %{rrdtmp}
214 %endif
215
216 # Fix @perl@ and @PERL@
217 find examples/ -type f \
218     -exec %{__perl} -pi -e 's|^#! \@perl\@|#!%{__perl}|gi' {} \;
219 find examples/ -name "*.pl" \
220     -exec %{__perl} -pi -e 's|\015||gi' {} \;
221
222 %install
223 rm -rf $RPM_BUILD_ROOT
224 make DESTDIR="$RPM_BUILD_ROOT" install
225
226 # Install the php module
227 %if %{with_php}
228 %{__install} -D -m0755 php4/modules/rrdtool.so \
229     %{buildroot}%{php_extdir}/rrdtool.so
230 # Clean up the examples for inclusion as docs
231 %{__rm} -rf php4/examples/.svn
232 # Put the php config bit into place
233 %{__mkdir_p} %{buildroot}%{_sysconfdir}/php.d
234 %{__cat} << __EOF__ > %{buildroot}%{_sysconfdir}/php.d/rrdtool.ini
235 ; Enable rrdtool extension module
236 extension=rrdtool.so
237 __EOF__
238 %endif
239
240 # Pesky RRDp.pm...
241 %{__mv} $RPM_BUILD_ROOT%{perl_vendorarch}/../RRDp.pm $RPM_BUILD_ROOT%{perl_vendorarch}/
242
243 # Dunno why this is getting installed here...
244 %{__rm} -f $RPM_BUILD_ROOT%{perl_vendorarch}/../leaktest.pl
245
246 # We only want .txt and .html files for the main documentation
247 %{__mkdir_p} doc2/html doc2/txt
248 %{__cp} -a doc/*.txt doc2/txt/
249 %{__cp} -a doc/*.html doc2/html/
250
251 # Put perl docs in perl package
252 %{__mkdir_p} doc3/html
253 %{__mv} doc2/html/RRD*.html doc3/html/
254
255 # Clean up the examples
256 %{__rm} -f examples/Makefile* examples/*.in
257
258 # This is so rpm doesn't pick up perl module dependencies automatically
259 find examples/ -type f -exec chmod 0644 {} \;
260
261 # Clean up the buildroot
262 %{__rm} -rf $RPM_BUILD_ROOT%{_docdir}/%{name}-* \
263         $RPM_BUILD_ROOT%{perl_vendorarch}/ntmake.pl \
264         $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod \
265         $RPM_BUILD_ROOT%{_datadir}/%{name}/examples \
266         $RPM_BUILD_ROOT%{perl_vendorarch}/auto/*/{.packlist,*.bs}
267
268 %clean
269 %{__rm} -rf $RPM_BUILD_ROOT
270
271 %post -p /sbin/ldconfig
272
273 %postun -p /sbin/ldconfig
274
275 %files
276 %defattr(-,root,root,-)
277 %{_bindir}/*
278 %{_libdir}/*.so.*
279 %{_datadir}/%{name}
280 %{_mandir}/man1/*
281
282 %files devel
283 %defattr(-,root,root,-)
284 %{_includedir}/*.h
285 %exclude %{_libdir}/*.la
286 %{_libdir}/*.so
287
288 %files doc
289 %defattr(-,root,root,-)
290 %doc CONTRIBUTORS COPYING COPYRIGHT README TODO NEWS THREADS
291 %doc examples doc2/html doc2/txt
292
293 %files perl
294 %defattr(-,root,root,-)
295 %doc doc3/html
296 %{_mandir}/man3/*
297 %{perl_vendorarch}/*.pm
298 %attr(0755,root,root) %{perl_vendorarch}/auto/RRDs/
299
300 %if %{with_python}
301 %files python
302 %defattr(-,root,root,-)
303 %doc bindings/python/AUTHORS bindings/python/COPYING bindings/python/README
304 %{python_sitearch}/rrdtoolmodule.so
305 %{python_sitearch}/py_rrdtool-*.egg-info
306 %endif
307
308 %if %{with_php}
309 %files php
310 %defattr(-,root,root,0755)
311 %doc php4/examples php4/README
312 %config(noreplace) %{_sysconfdir}/php.d/rrdtool.ini
313 %{php_extdir}/rrdtool.so
314 %endif
315
316 %if %{with_tcl}
317 %files tcl
318 %defattr(-,root,root,-)
319 %doc bindings/tcl/README
320 %{_libdir}/tclrrd*.so
321 %{_libdir}/rrdtool/*.tcl
322 %endif
323
324 %if %{with_ruby}
325 %files ruby
326 %defattr(-,root,root,-)
327 %doc bindings/ruby/README
328 %{ruby_sitearch}/RRD.so
329 %endif
330
331 %changelog
332 * Sun Jun 08 2008 Jarod Wilson <jwilson@redhat.com> 1.3-0.20.rc9
333 - Update to rrdtool 1.3 rc9
334 - Minor spec tweaks to permit building on older EL
335
336 * Wed Jun 04 2008 Chris Ricker <kaboom@oobleck.net> 1.3-0.19.rc7
337 - Update to rrdtool 1.3 rc7
338
339 * Tue May 27 2008 Chris Ricker <kaboom@oobleck.net> 1.3-0.18.rc6
340 - Update to rrdtool 1.3 rc6
341
342 * Wed May 21 2008 Chris Ricker <kaboom@oobleck.net> 1.3-0.17.rc4
343 - Bump version and rebuild
344
345 * Wed May 21 2008 Chris Ricker <kaboom@oobleck.net> 1.3-0.16.rc4
346 - Fix php bindings compile on x86_64
347
348 * Mon May 19 2008 Chris Ricker <kaboom@oobleck.net> 1.3-0.15.rc4
349 - Update to rrdtool 1.3 rc4
350
351 * Tue May 13 2008 Jarod Wilson <jwilson@redhat.com> 1.3-0.15.rc1
352 - Update to rrdtool 1.3 rc1
353 - Fix versioning in changelog entries, had an extra 0 in there...
354 - Drop cairo and python patches, they're in 1.3 rc1
355 - Add Requires: gettext and libxml2-devel for new translations
356
357 * Wed Apr 30 2008 Jarod Wilson <jwilson@redhat.com> 1.3-0.14.beta4
358 - Drop some conditional flags, they're not working at the moment...
359
360 * Wed Apr 30 2008 Jarod Wilson <jwilson@redhat.com> 1.3-0.13.beta4
361 - Fix problem with cairo_save/cairo_restore (#444827)
362
363 * Wed Apr 23 2008 Jarod Wilson <jwilson@redhat.com> 1.3-0.12.beta4
364 - Fix python bindings rrdtool info implementation (#435468)
365
366 * Tue Apr 08 2008 Jarod Wilson <jwilson@redhat.com> 1.3-0.11.beta4
367 - Work around apparent version string length issue w/perl 5.10 (#441359)
368
369 * Sat Apr 05 2008 Jarod Wilson <jwilson@redhat.com> 1.3-0.10.beta4
370 - Fix use of rrd_update in php bindings (#437558)
371
372 * Mon Mar  3 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.3-0.9.beta4
373 - rebuild for new perl (again)
374
375 * Wed Feb 13 2008 Jarod Wilson <jwilson@redhat.com> 1.3-0.8.beta4
376 - Update to rrdtool 1.3 beta4
377
378 * Tue Feb 05 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.3-0.7.beta3
379 - rebuild for new perl (and fix license tag)
380
381 * Mon Feb 04 2008 Jarod Wilson <jwilson@redhat.com> 1.3-0.6.beta3
382 - Plug memory leak (#430879)
383
384 * Mon Jan 07 2008 Jarod Wilson <jwilson@redhat.com> 1.3-0.5.beta3
385 - Fix right-aligned text alignment and scaling (Resolves: #427609)
386
387 * Wed Jan 02 2008 Jarod Wilson <jwilson@redhat.com> 1.3-0.4.beta3
388 - Add newly built python egg to %%files
389
390 * Wed Jan 02 2008 Jarod Wilson <jwilson@redhat.com> 1.3-0.3.beta3
391 - Update to rrdtool 1.3 beta3
392 - Return properly from errors in RRDp.pm (Resolves: #427040)
393 - Requires: dejavu-lgc-fonts (Resolves: #426935)
394
395 * Thu Dec 06 2007 Jarod Wilson <jwilson@redhat.com> 1.3-0.2.beta2
396 - Update to rrdtool 1.3 beta2
397
398 * Wed Aug 08 2007 Jarod Wilson <jwilson@redhat.com> 1.3-0.1.beta1
399 - Update to rrdtool 1.3 beta1
400
401 * Tue Jul 10 2007 Jarod Wilson <jwilson@redhat.com> 1.2.999-0.3.r1144
402 - Update to latest rrdtool pre-1.3 svn snapshot (svn r1144)
403 - Add php abi check (Resolves: #247339)
404
405 * Fri Jun 15 2007 Jarod Wilson <jwilson@redhat.com> 1.2.999-0.2.r1127
406 - Fix up BuildRequires
407
408 * Fri Jun 15 2007 Jarod Wilson <jwilson@redhat.com> 1.2.999-0.1.r1127
409 - Update to rrdtool pre-1.3 svn snapshot (svn r1127)
410
411 * Mon May 21 2007 Jarod Wilson <jwilson@redhat.com> 1.2.23-5
412 - BR: ruby so %%ruby_sitearch gets set
413
414 * Mon May 21 2007 Jarod Wilson <jwilson@redhat.com> 1.2.23-4
415 - Build ruby bindings
416
417 * Thu May 03 2007 Jarod Wilson <jwilson@redhat.com> 1.2.23-3
418 - Disable php bits on ppc64 for now, they fail to build
419
420 * Thu May 03 2007 Jarod Wilson <jwilson@redhat.com> 1.2.23-2
421 - Add BR: perl-devel for Fedora 7 and later
422
423 * Tue May 01 2007 Jarod Wilson <jwilson@redhat.com> 1.2.23-1
424 - New upstream release
425
426 * Tue May 01 2007 Jarod Wilson <jwilson@redhat.com> 1.2.21-1
427 - New upstream release
428
429 * Wed Apr 25 2007 Jarod Wilson <jwilson@redhat.com> 1.2.19-2
430 - Define %%python_version *before* its needed (#237826)
431
432 * Mon Apr 09 2007 Jarod Wilson <jwilson@redhat.com> 1.2.19-1
433 - New upstream release
434
435 * Tue Jan 23 2007 Jarod Wilson <jwilson@redhat.com> 1.2.18-1
436 - New upstream release
437
438 * Mon Jan 22 2007 Jarod Wilson <jwilson@redhat.com> 1.2.17-1
439 - New upstream release
440
441 * Tue Jan 02 2007 Jarod Wilson <jwilson@redhat.com> 1.2.15-9
442 - Fix crash with long error strings (upstream
443   changesets 929 and 935)
444
445 * Thu Dec 14 2006 Jarod Wilson <jwilson@redhat.com> 1.2.15-8
446 - Fix for log grid memory leak (#201241)
447
448 * Tue Dec 12 2006 Jarod Wilson <jwilson@redhat.com> 1.2.15-7
449 - Rebuild for python 2.5
450
451 * Tue Nov 14 2006 Jarod Wilson <jwilson@redhat.com> 1.2.15-6
452 - Conditionalize python, php and tcl bits (Resolves #203275)
453
454 * Wed Oct 25 2006 Jarod Wilson <jwilson@redhat.com> 1.2.15-5
455 - Add tcl sub-package (#203275)
456
457 * Tue Sep 05 2006 Jarod Wilson <jwilson@redhat.com> 1.2.15-4
458 - Rebuild for new glibc
459
460 * Wed Aug 02 2006 Jarod Wilson <jwilson@redhat.com> 1.2.15-3
461 - One more addition to initrrdtool patch, to fully revert
462   and correct upstream changeset 839
463 - Fix for no python in minimal fc4 buildroots
464
465 * Tue Aug  1 2006 Mihai Ibanescu <misa@redhat.com> 1.2.15-2
466 - Fixed rrdtool-python to import the module properly (patch
467   rrdtool-1.2.15-initrrdtool.patch)
468
469 * Mon Jul 17 2006 Jarod Wilson <jwilson@redhat.com> 1.2.15-1
470 - Update to 1.2.15
471 - Minor spec cleanups
472
473 * Sat Jun 24 2006 Jarod Wilson <jwilson@redhat.com> 1.2.13-7
474 - Fix up Obsoletes
475
476 * Mon Jun 19 2006 Jarod Wilson <jwilson@redhat.com> 1.2.13-6
477 - Flip perl, php and python sub-package names around to 
478   conform with general practices
479
480 * Sat Jun 10 2006 Jarod Wilson <jwilson@redhat.com> 1.2.13-5
481 - Minor fixes to make package own created directories
482
483 * Wed Jun 07 2006 Jarod Wilson <jwilson@redhat.com> 1.2.13-4
484 - Add php bits back into the mix
485
486 * Mon Jun 05 2006 Jarod Wilson <jwilson@redhat.com> 1.2.13-3
487 - Merge spec fixes from bz 185909
488
489 * Sun Jun 04 2006 Jarod Wilson <jwilson@redhat.com> 1.2.13-2
490 - Remove explicit perl dep, version grabbing using rpm during
491   rpmbuild not guaranteed to work (fails on ppc in plague),
492   and auto-gen perl deps are sufficient
493
494 * Sat Jun 03 2006 Jarod Wilson <jwilson@redhat.com> 1.2.13-1
495 - Update to release 1.2.13
496 - Merge spec changes from dag, atrpms and mdk builds
497 - Additional hacktastic contortions for lib64 & rpath messiness
498 - Add missing post/postun ldconfig
499 - Fix a bunch of rpmlint errors
500 - Disable static libs, per FE guidelines
501 - Split off docs
502
503 * Wed Apr 19 2006 Chris Ricker <kaboom@oobleck.net> 1.2.12-1
504 - Rev to 1.2
505
506 * Fri May 20 2005 Matthias Saou <http://freshrpms.net/> 1.0.49-5
507 - Include patch from Michael to fix perl module compilation on FC4 (#156242).
508
509 * Fri May 20 2005 Matthias Saou <http://freshrpms.net/> 1.0.49-4
510 - Fix for the php module patch (Joe Pruett, Dag Wieers), #156716.
511 - Update source URL to new location since 1.2 is now the default stable.
512 - Don't (yet) update to 1.0.50, as it introduces some changes in the perl
513   modules install.
514
515 * Mon Jan 31 2005 Matthias Saou <http://freshrpms.net/> 1.0.49-3
516 - Put perl modules in vendor_perl and not site_perl. #146513
517
518 * Thu Jan 13 2005 Matthias Saou <http://freshrpms.net/> 1.0.49-2
519 - Minor cleanups.
520
521 * Thu Aug 25 2004 Dag Wieers <dag@wieers.com> - 1.0.49-1
522 - Updated to release 1.0.49.
523
524 * Wed Aug 25 2004 Dag Wieers <dag@wieers.com> - 1.0.48-3
525 - Fixes for x86_64. (Garrick Staples)
526
527 * Fri Jul  2 2004 Matthias Saou <http://freshrpms.net/> 1.0.48-3
528 - Actually apply the patch for fixing the php module, doh!
529
530 * Thu May 27 2004 Matthias Saou <http://freshrpms.net/> 1.0.48-2
531 - Added php.d config entry to load the module once installed.
532
533 * Thu May 13 2004 Dag Wieers <dag@wieers.com> - 1.0.48-1
534 - Updated to release 1.0.48.
535
536 * Tue Apr 06 2004 Dag Wieers <dag@wieers.com> - 1.0.47-1
537 - Updated to release 1.0.47.
538
539 * Thu Mar  4 2004 Matthias Saou <http://freshrpms.net/> 1.0.46-2
540 - Change the strict dependency on perl to fix problem with the recent
541   update.
542
543 * Mon Jan  5 2004 Matthias Saou <http://freshrpms.net/> 1.0.46-1
544 - Update to 1.0.46.
545 - Use system libpng and zlib instead of bundled ones.
546 - Added php-rrdtool sub-package for the php4 module.
547
548 * Fri Dec  5 2003 Matthias Saou <http://freshrpms.net/> 1.0.45-4
549 - Added epoch to the perl dependency to work with rpm > 4.2.
550 - Fixed the %% escaping in the perl dep.
551
552 * Mon Nov 17 2003 Matthias Saou <http://freshrpms.net/> 1.0.45-2
553 - Rebuild for Fedora Core 1.
554
555 * Sun Aug  3 2003 Matthias Saou <http://freshrpms.net/>
556 - Update to 1.0.45.
557
558 * Wed Apr 16 2003 Matthias Saou <http://freshrpms.net/>
559 - Update to 1.0.42.
560
561 * Mon Mar 31 2003 Matthias Saou <http://freshrpms.net/>
562 - Rebuilt for Red Hat Linux 9.
563
564 * Wed Mar  5 2003 Matthias Saou <http://freshrpms.net/>
565 - Added explicit perl version dependency.
566
567 * Sun Feb 23 2003 Matthias Saou <http://freshrpms.net/>
568 - Update to 1.0.41.
569
570 * Fri Jan 31 2003 Matthias Saou <http://freshrpms.net/>
571 - Update to 1.0.40.
572 - Spec file cleanup.
573
574 * Fri Jul 05 2002 Henri Gomez <hgomez@users.sourceforge.net>
575 - 1.0.39
576
577 * Mon Jun 03 2002 Henri Gomez <hgomez@users.sourceforge.net>
578 - 1.0.38
579
580 * Fri Apr 19 2002 Henri Gomez <hgomez@users.sourceforge.net>
581 - 1.0.37
582
583 * Tue Mar 12 2002 Henri Gomez <hgomez@users.sourceforge.net>
584 - 1.0.34
585 - rrdtools include zlib 1.1.4 which fix vulnerabilities in 1.1.3
586