more fixes for rpm spec -- Mike Slifcak
[rrdtool.git] / rrdtool.spec
1 %define cvsdate cvs-snap
2 %define cvsver %(echo %{cvsdate} | tr -d -)
3 %define sover 1.0.0
4
5 Summary: Round Robin Database Tools
6 Name: rrdtool
7 Version: 1.1.0
8 Release: %{cvsver}
9 License: GPL
10 Group: Applications/Databases
11 Source: http://people.ee.ethz.ch/~oetiker/webtools/rrdtool/pub/beta/rrdtool-cvs-snap.tar.gz
12 URL: http://people.ee.ethz.ch/~oetiker/webtools/rrdtool/
13 Buildroot: /tmp/%{name}-root
14
15 BuildRequires: perl
16 BuildRequires: cgilib-devel
17 BuildRequires: freetype-devel libart_lgpl-devel libpng-devel zlib-devel
18
19 %description
20 It is pretty easy to gather status information from all sorts of things,
21 ranging from the temperature in your office to the number of octets which
22 have passed through the FDDI interface of your router. But it is not so
23 trivial to store this data in a efficient and systematic manner. This is
24 where RRDtool kicks in. It lets you log and analyze the data you gather from
25 all kinds of data-sources (DS). The data analysis part of RRDtool is based
26 on the ability to quickly generate graphical representations of the data
27 values collected over a definable time period.
28
29 %package devel
30 Summary: RRD Tool development libraries and header files
31 Group: Development/Libraries
32 Requires: %{name} = %{version}
33
34 %description devel
35 The RRD Tools development library.
36
37 %package perl
38 Summary: RRD Tool Perl interface
39 Group: Applications/Databases
40 Requires: %{name} = %{version}
41
42 %description perl
43 The RRD Tools Perl modules.
44
45 %prep
46 %setup -q -n rrdtool-%{cvsdate}
47
48 %define deffont %{_datadir}/fonts/VeraMono.ttf
49 perl -pi -e 's!^(#define\s+RRD_DEFAULT_FONT\s+).*!$1"%{deffont}"!' src/rrd_graph.c
50
51 %build
52 CPPFLAGS="-I/usr/include/libart-2.0 -I/usr/include/freetype2"
53 export CPPFLAGS
54 aclocal > /tmp/aclocal.out 2>&1
55 automake
56 autoconf
57 %configure
58 make
59
60 %install
61 rm -rf %{buildroot}
62 %makeinstall
63
64 # Install the font
65 mkdir -p %{buildroot}%{_datadir}/fonts
66 install -m 644 src/VeraMono.ttf %{buildroot}%{deffont}
67
68 # Fix up the documentation
69 [ -d docs ] && mv docs docs.src
70 mv %{buildroot}/usr/doc docs
71 rm -f docs/*.pod
72 [ -d examples ] && mv examples examples.src
73 mv %{buildroot}/usr/examples examples
74 [ -d html ] && mv html html.src
75 mv %{buildroot}/usr/html html
76
77 # Fix up the perl
78 %define perlsite %(perl -MConfig -e 'print $Config{"installsitearch"}')
79 mkdir -p %{buildroot}%{perlsite}
80 mv %{buildroot}%{_libdir}/perl/* %{buildroot}%{perlsite}
81 rmdir %{buildroot}%{_libdir}/perl
82
83 # Fix up the man pages
84 if [ "%{_mandir}" != "/usr/share/man" ]; then
85         mkdir -p %{buildroot}%{_mandir}
86         mv %{buildroot}/usr/man/* %{buildroot}%{_mandir}/
87 fi
88
89 %post
90 /sbin/ldconfig
91
92 %postun
93 /sbin/ldconfig
94
95 %clean
96 rm -rf %{buildroot}
97
98 %files
99 %defattr (-, root, root)
100 %doc 00README CONTRIBUTORS COPYING COPYRIGHT ChangeLog NEWS PROJECTS
101 %doc README THREADS TODO examples
102 %doc docs examples html
103 %{_bindir}/rrdcgi
104 %{_bindir}/rrdtool
105 %{_bindir}/rrdupdate
106 %{_libdir}/librrd.so.%{sover}
107 %{_libdir}/librrd_th.so.%{sover}
108 %{_mandir}/man1/[a-z]*
109 %{deffont}
110
111 %files devel
112 %defattr (-, root, root)
113 %{_includedir}/rrd.h
114 %{_libdir}/librrd.a
115 %{_libdir}/librrd.la
116 %{_libdir}/librrd.so
117 %{_libdir}/librrd_th.a
118 %{_libdir}/librrd_th.la
119 %{_libdir}/librrd_th.so
120
121 %files perl
122 %defattr (-, root, root)
123 %{perlsite}/RRDp.pm
124 %{perlsite}/RRDs.pm
125 %dir %{perlsite}/auto/RRDs
126 %{perlsite}/auto/RRDs/RRDs.bs
127 %{perlsite}/auto/RRDs/RRDs.so
128 %{_mandir}/man1/RRDp.1*
129 %{_mandir}/man1/RRDs.1*
130
131 %changelog
132 * Thu Apr 29 2004 Chris Adams <cmadams@hiwaay.net> 1.1.0-0.1.20040430
133 - initial build