fix rpm rules -- Mike Slifcak
[rrdtool.git] / rrdtool.spec
1 %define cvsdate cvs-snap
2 %define cvsver %(echo %{cvsdate} | tr -d -)
3 %define sover 1.0.0
4
5 Summary: Round Robin Database Tools
6 Name: rrdtool
7 Version: 1.1.0
8 Release: %{cvsver}
9 License: GPL
10 Group: Applications/Networking
11 Source: http://people.ee.ethz.ch/~oetiker/webtools/rrdtool/pub/beta/rrdtool-cvs-snap.tar.gz
12 URL: http://people.ee.ethz.ch/~oetiker/webtools/rrdtool/
13 Buildroot: /tmp/%{name}-root
14
15 BuildRequires: perl
16 BuildRequires: cgilib-devel
17 BuildRequires: freetype-devel libart_lgpl-devel libpng-devel zlib-devel
18
19 %description
20 It is pretty easy to gather status information from all sorts of things,
21 ranging from the temperature in your office to the number of octets which
22 have passed through the FDDI interface of your router. But it is not so
23 trivial to store this data in a efficient and systematic manner. This is
24 where RRDtool kicks in. It lets you log and analyze the data you gather from
25 all kinds of data-sources (DS). The data analysis part of RRDtool is based
26 on the ability to quickly generate graphical representations of the data
27 values collected over a definable time period.
28
29 %package devel
30 Summary: RRD Tool development libraries and header files
31 Group: Development/Libraries
32 Requires: rrdtool = %{version}-%{release}
33
34 %description devel
35 The RRD Tools development library.
36
37 %package perl
38 Summary: RRD Tool Perl interface
39 Group: Applications/Networking
40 Requires: rrdtool = %{version}-%{release}
41
42 %description perl
43 The RRD Tools Perl modules.
44
45 %prep
46 %setup -q -n rrdtool-%{cvsdate}
47
48 mkdir config
49 cd config
50 ln -s ../mkinstalldirs .
51 cd ..
52
53 %define deffont %{_datadir}/fonts/VeraMono.ttf
54 perl -pi -e 's!^(#define\s+RRD_DEFAULT_FONT\s+).*!$1"%{deffont}"!' src/rrd_graph.c
55
56 %build
57 CPPFLAGS="-I/usr/include/libart-2.0 -I/usr/include/freetype2"
58 export CPPFLAGS
59 aclocal > /tmp/aclocal.out 2>&1
60 automake
61 autoconf
62 %configure
63 make
64
65 %install
66 rm -rf %{buildroot}
67 %makeinstall
68
69 # Install the font
70 mkdir -p %{buildroot}%{_datadir}/fonts
71 install -m 644 src/VeraMono.ttf %{buildroot}%{deffont}
72
73 # Fix up the documentation
74 [ -d docs ] && mv docs docs.src
75 mv %{buildroot}/usr/doc docs
76 rm -f docs/*.pod
77 [ -d examples ] && mv examples examples.src
78 mv %{buildroot}/usr/examples examples
79 [ -d html ] && mv html html.src
80 mv %{buildroot}/usr/html html
81
82 # Fix up the perl
83 %define perlsite %(perl -MConfig -e 'print $Config{"installsitearch"}')
84 mkdir -p %{buildroot}%{perlsite}
85 mv %{buildroot}%{_libdir}/perl/* %{buildroot}%{perlsite}
86 rmdir %{buildroot}%{_libdir}/perl
87
88 # Fix up the man pages
89 if [ "%{_mandir}" != "/usr/share/man" ]; then
90         mkdir -p %{buildroot}%{_mandir}
91         mv %{buildroot}/usr/man/* %{buildroot}%{_mandir}/
92 fi
93
94 %post
95 /sbin/ldconfig
96
97 %postun
98 /sbin/ldconfig
99
100 %clean
101 rm -rf %{buildroot}
102
103 %files
104 %defattr (-, root, root)
105 %doc 00README CONTRIBUTORS COPYING COPYRIGHT ChangeLog NEWS PROJECTS
106 %doc README THREADS TODO examples
107 %doc docs examples html
108 %{_bindir}/rrdcgi
109 %{_bindir}/rrdtool
110 %{_bindir}/rrdupdate
111 %{_libdir}/librrd.so.%{sover}
112 %{_libdir}/librrd_th.so.%{sover}
113 %{_mandir}/man1/[a-z]*
114 %{deffont}
115
116 %files devel
117 %defattr (-, root, root)
118 %{_includedir}/rrd.h
119 %{_libdir}/librrd.a
120 %{_libdir}/librrd.la
121 %{_libdir}/librrd.so
122 %{_libdir}/librrd_th.a
123 %{_libdir}/librrd_th.la
124 %{_libdir}/librrd_th.so
125
126 %files perl
127 %defattr (-, root, root)
128 %{perlsite}/RRDp.pm
129 %{perlsite}/RRDs.pm
130 %dir %{perlsite}/auto/RRDs
131 %{perlsite}/auto/RRDs/RRDs.bs
132 %{perlsite}/auto/RRDs/RRDs.so
133 %{_mandir}/man1/RRDp.1*
134 %{_mandir}/man1/RRDs.1*
135
136 %changelog
137 * Thu Apr 29 2004 Chris Adams <cmadams@hiwaay.net> 1.1.0-0.1.20040430
138 - initial build