prepare for the release of rrdtool-1.2.16
[rrdtool.git] / bindings / Makefile.am
index 67df11f..0512914 100644 (file)
@@ -10,15 +10,21 @@ SUBDIRS = $(SUB_tcl) $(SUB_python)
 
 # the following files are not mentioned in any other Makefile
 EXTRA_DIST = perl-piped/MANIFEST perl-piped/README perl-piped/Makefile.PL perl-piped/RRDp.pm perl-piped/t/base.t \
-       perl-shared/ntmake.pl perl-shared/MANIFEST perl-shared/README perl-shared/Makefile.PL perl-shared/RRDs.pm  perl-shared/RRDs.xs perl-shared/t/base.t
+       perl-shared/ntmake.pl perl-shared/MANIFEST perl-shared/README perl-shared/Makefile.PL perl-shared/RRDs.pm  perl-shared/RRDs.xs perl-shared/t/base.t \
+       ruby/CHANGES     ruby/README      ruby/extconf.rb  ruby/main.c      ruby/test.rb
 
 
 # add the following to the all target
-all-local:  @COMP_PERL@
+all-local:  @COMP_PERL@ @COMP_RUBY@
 
 install-data-local:
        test -f perl-piped/Makefile && cd perl-piped && $(MAKE) install || true
        test -f perl-shared/Makefile && cd perl-shared && $(MAKE) install || true
+       test -f ruby/Makefile && cd ruby && $(MAKE) EPREFIX=$(exec_prefix) $(RUBY_MAKE_OPTIONS) install || true
+
+# rules for buildung the ruby module
+ruby: 
+       cd ruby && $(RUBY) extconf.rb && $(MAKE) EPREFIX=$(exec_prefix) $(RUBY_MAKE_OPTIONS)
 
 # rules for building the perl module
 perl_piped: perl-piped/Makefile
@@ -35,7 +41,10 @@ perl-shared/Makefile: perl-shared/Makefile.PL
 # LIBS="$(LDFLAGS) $(LIBS)" $(PERLFLAGS) $(PERL_MAKE_OPTIONS)
 
 clean-local:
-       test -f perl-piped/Makefile && cd perl-piped && $(MAKE) clean || rm perl-piped/Makefile || true
-       test -f perl-shared/Makefile && cd perl-shared && $(MAKE) clean || rm perl-shared/Makefile || true
+       test -f perl-piped/Makefile && cd perl-piped && $(MAKE) clean || true
+       test -f perl-piped/Makefile && rm perl-piped/Makefile || true
+       test -f perl-shared/Makefile && cd perl-shared && $(MAKE) clean || true
+       test -f perl-shared/Makefile && rm -f perl-shared/Makefile || true 
+       test -f ruby/Makefile && cd ruby && $(MAKE) clean && rm Makefile || true 
 
 ##END##