prepare for the release of rrdtool-1.2.16
[rrdtool.git] / bindings / Makefile.am
index 96bf37d..0512914 100644 (file)
@@ -10,7 +10,8 @@ SUBDIRS = $(SUB_tcl) $(SUB_python)
 
 # the following files are not mentioned in any other Makefile
 EXTRA_DIST = perl-piped/MANIFEST perl-piped/README perl-piped/Makefile.PL perl-piped/RRDp.pm perl-piped/t/base.t \
-       perl-shared/ntmake.pl perl-shared/MANIFEST perl-shared/README perl-shared/Makefile.PL perl-shared/RRDs.pm  perl-shared/RRDs.xs perl-shared/t/base.t
+       perl-shared/ntmake.pl perl-shared/MANIFEST perl-shared/README perl-shared/Makefile.PL perl-shared/RRDs.pm  perl-shared/RRDs.xs perl-shared/t/base.t \
+       ruby/CHANGES     ruby/README      ruby/extconf.rb  ruby/main.c      ruby/test.rb
 
 
 # add the following to the all target
@@ -22,12 +23,9 @@ install-data-local:
        test -f ruby/Makefile && cd ruby && $(MAKE) EPREFIX=$(exec_prefix) $(RUBY_MAKE_OPTIONS) install || true
 
 # rules for buildung the ruby module
-ruby: ruby/Makefile
-       cd ruby && $(MAKE) EPREFIX=$(exec_prefix) $(RUBY_MAKE_OPTIONS)
+ruby: 
+       cd ruby && $(RUBY) extconf.rb && $(MAKE) EPREFIX=$(exec_prefix) $(RUBY_MAKE_OPTIONS)
 
-ruby/Makefile: ruby/extconf.rb
-       cd ruby && $(RUBY) extconf.rb
-        
 # rules for building the perl module
 perl_piped: perl-piped/Makefile
        cd perl-piped && $(MAKE)