prepare for the release of rrdtool-1.2.16
[rrdtool.git] / bindings / Makefile.am
index 57773b7..1bac87c 100644 (file)
@@ -1,15 +1,29 @@
-SUBDIRS = tcl python
+if BUILD_TCL
+SUB_tcl = tcl
+endif
+
+if BUILD_PYTHON
+SUB_python = python
+endif
+
+SUBDIRS = $(SUB_tcl) $(SUB_python)
+
 # the following files are not mentioned in any other Makefile
 EXTRA_DIST = perl-piped/MANIFEST perl-piped/README perl-piped/Makefile.PL perl-piped/RRDp.pm perl-piped/t/base.t \
        perl-shared/ntmake.pl perl-shared/MANIFEST perl-shared/README perl-shared/Makefile.PL perl-shared/RRDs.pm  perl-shared/RRDs.xs perl-shared/t/base.t
 
 
 # add the following to the all target
-all-local:  @COMP_PERL@
+all-local:  @COMP_PERL@ @COMP_RUBY@
 
 install-data-local:
-       cd perl-piped && test -f Makefile && $(MAKE) install || true
-       cd perl-shared && test -f Makefile && $(MAKE) install || true
+       test -f perl-piped/Makefile && cd perl-piped && $(MAKE) install || true
+       test -f perl-shared/Makefile && cd perl-shared && $(MAKE) install || true
+       test -f ruby/Makefile && cd ruby && $(MAKE) EPREFIX=$(exec_prefix) $(RUBY_MAKE_OPTIONS) install || true
+
+# rules for buildung the ruby module
+ruby: ruby/Makefile
+       cd ruby && $(RUBY) extconf.rb && $(MAKE) EPREFIX=$(exec_prefix) $(RUBY_MAKE_OPTIONS)
 
 # rules for building the perl module
 perl_piped: perl-piped/Makefile
@@ -19,14 +33,17 @@ perl-piped/Makefile: perl-piped/Makefile.PL
        cd perl-piped && $(PERL) Makefile.PL $(PERL_MAKE_OPTIONS)
 
 perl_shared: perl-shared/Makefile
-       cd perl-shared && $(MAKE) RPATH=$(exec_prefix)/lib
+       cd perl-shared && $(MAKE)
 
 perl-shared/Makefile: perl-shared/Makefile.PL
-       cd perl-shared && $(PERL) Makefile.PL $(PERLFLAGS) $(PERL_MAKE_OPTIONS)
+       cd perl-shared && $(PERL) Makefile.PL $(PERLFLAGS) $(PERL_MAKE_OPTIONS) RPATH=$(exec_prefix)/lib
 # LIBS="$(LDFLAGS) $(LIBS)" $(PERLFLAGS) $(PERL_MAKE_OPTIONS)
 
 clean-local:
-       cd perl-piped && test -f Makefile && $(MAKE) clean || true
-       cd perl-shared && test -f Makefile && $(MAKE) clean || true
+       test -f perl-piped/Makefile && cd perl-piped && $(MAKE) clean || true
+       test -f perl-piped/Makefile && rm perl-piped/Makefile || true
+       test -f perl-shared/Makefile && cd perl-shared && $(MAKE) clean || true
+       test -f perl-shared/Makefile && rm -f perl-shared/Makefile || true 
+       test -f ruby/Makefile && cd ruby && $(MAKE) clean && rm Makefile || true 
 
 ##END##