* Updated perl compile system. It now uses Makefile.PL for everything,
[rrdtool.git] / bindings / Makefile.am
index d2eaad3..48a7508 100644 (file)
@@ -1,19 +1,13 @@
-SUBDIRS = tcl
-
+SUBDIRS = tcl 
 # the following files are not mentioned in any other Makefile
 EXTRA_DIST = $(shell for A in perl-*; do cat $$A/MANIFEST | sed -e s,^,$$A/, ; done)
 
-# lets schedule the perl stuff for installation
-# the special call to install-sh is because the -d switch is not portable
-install-data-local:
-       ../config/mkinstalldirs $(DESTDIR)$(prefix)/lib/perl/auto/RRDs
-       $(INSTALL) -m 644 perl-piped/RRDp.pm $(DESTDIR)$(prefix)/lib/perl
-       $(INSTALL) -m 644 perl-shared/RRDs.pm $(DESTDIR)$(prefix)/lib/perl
-       $(INSTALL) -m 644 perl-shared/blib/arch/auto/RRDs/RRDs.bs $(DESTDIR)$(prefix)/lib/perl/auto/RRDs
-       $(INSTALL) -m 755 perl-shared/blib/arch/auto/RRDs/RRDs.@SO_EXT@ $(DESTDIR)$(prefix)/lib/perl/auto/RRDs
-
 # add the following to the all target
-all-local:      @COMP_PERL@
+all-local:  @COMP_PERL@
+
+install-data-local:
+       cd perl-piped && test -f Makefile && $(MAKE) install || true
+       cd perl-shared && test -f Makefile && $(MAKE) install || true
 
 # rules for building the perl module
 perl_piped: perl-piped/Makefile
@@ -23,7 +17,7 @@ perl-piped/Makefile: perl-piped/Makefile.PL
        cd perl-piped && $(PERL) Makefile.PL $(PERL_MAKE_OPTIONS)
 
 perl_shared: perl-shared/Makefile
-       cd perl-shared && $(MAKE)
+       cd perl-shared && $(MAKE) RPATH=$(exec_prefix)/lib
 
 perl-shared/Makefile: perl-shared/Makefile.PL
        cd perl-shared && $(PERL) Makefile.PL $(PERLFLAGS) $(PERL_MAKE_OPTIONS)