added ruby bindings ... thanks to Loïs LHERBIER lois.lherbier covadis.ch
[rrdtool.git] / bindings / Makefile.am
index 2bd1a20..a095ef8 100644 (file)
@@ -14,12 +14,20 @@ EXTRA_DIST = perl-piped/MANIFEST perl-piped/README perl-piped/Makefile.PL perl-p
 
 
 # add the following to the all target
-all-local:  @COMP_PERL@
+all-local:  @COMP_PERL@ @COMP_RUBY@
 
 install-data-local:
        test -f perl-piped/Makefile && cd perl-piped && $(MAKE) install || true
        test -f perl-shared/Makefile && cd perl-shared && $(MAKE) install || true
+       test -f ruby/Makefile && cd ruby && $(MAKE) EPREFIX=$(exec_prefix) $(RUBY_MAKE_OPTIONS) install || true
 
+# rules for buildung the ruby module
+ruby: ruby/Makefile
+       cd ruby && $(MAKE) EPREFIX=$(exec_prefix) $(RUBY_MAKE_OPTIONS)
+
+ruby/Makefile: ruby/extconf.rb
+       cd ruby && $(RUBY) extconf.rb
+        
 # rules for building the perl module
 perl_piped: perl-piped/Makefile
        cd perl-piped && $(MAKE)
@@ -39,5 +47,6 @@ clean-local:
        test -f perl-piped/Makefile && rm perl-piped/Makefile || true
        test -f perl-shared/Makefile && cd perl-shared && $(MAKE) clean || true
        test -f perl-shared/Makefile && rm -f perl-shared/Makefile || true 
+       test -f ruby/Makefile && rm -f ruby/Makefile || true 
 
 ##END##