misc fixes to get rrdtool working without included libraries.
[rrdtool.git] / bindings / Makefile.am
index 79496c6..d2eaad3 100644 (file)
@@ -1,12 +1,12 @@
 SUBDIRS = tcl
 
 # the following files are not mentioned in any other Makefile
-EXTRA_DIST = `cat perl-*/MANIFEST`
+EXTRA_DIST = $(shell for A in perl-*; do cat $$A/MANIFEST | sed -e s,^,$$A/, ; done)
 
 # lets schedule the perl stuff for installation
 # the special call to install-sh is because the -d switch is not portable
 install-data-local:
-       ./config/mkinstalldirs $(DESTDIR)$(prefix)/lib/perl/auto/RRDs
+       ../config/mkinstalldirs $(DESTDIR)$(prefix)/lib/perl/auto/RRDs
        $(INSTALL) -m 644 perl-piped/RRDp.pm $(DESTDIR)$(prefix)/lib/perl
        $(INSTALL) -m 644 perl-shared/RRDs.pm $(DESTDIR)$(prefix)/lib/perl
        $(INSTALL) -m 644 perl-shared/blib/arch/auto/RRDs/RRDs.bs $(DESTDIR)$(prefix)/lib/perl/auto/RRDs