avoid problems when building with VPATH set and --disable-perl
[rrdtool.git] / bindings / Makefile.am
index 174a816..e939dc7 100644 (file)
@@ -1,13 +1,15 @@
-SUBDIRS = tcl 
+SUBDIRS = tcl python
 # the following files are not mentioned in any other Makefile
-EXTRA_DIST = $(shell for A in perl-*; do cat $$A/MANIFEST | sed -e "s,^,$$A/," ; done)
+EXTRA_DIST = perl-piped/MANIFEST perl-piped/README perl-piped/Makefile.PL perl-piped/RRDp.pm perl-piped/t/base.t \
+       perl-shared/ntmake.pl perl-shared/MANIFEST perl-shared/README perl-shared/Makefile.PL perl-shared/RRDs.pm  perl-shared/RRDs.xs perl-shared/t/base.t
+
 
 # add the following to the all target
 all-local:  @COMP_PERL@
 
 install-data-local:
-       cd perl-piped && test -f Makefile && $(MAKE) install || true
-       cd perl-shared && test -f Makefile && $(MAKE) install || true
+       test -f perl-piped/Makefile && cd perl-piped && $(MAKE) install || true
+       test -f perl-shared/Makefile && cd perl-shared && $(MAKE) install || true
 
 # rules for building the perl module
 perl_piped: perl-piped/Makefile
@@ -24,7 +26,7 @@ perl-shared/Makefile: perl-shared/Makefile.PL
 # LIBS="$(LDFLAGS) $(LIBS)" $(PERLFLAGS) $(PERL_MAKE_OPTIONS)
 
 clean-local:
-       cd perl-piped && test -f Makefile && $(MAKE) clean || true
-       cd perl-shared && test -f Makefile && $(MAKE) clean || true
+       test -f perl-piped/Makefile && cd perl-piped && $(MAKE) clean || true
+       test -f perl-shared/Makefile && cd perl-shared && $(MAKE) clean || true
 
 ##END##