avoid problems when building with VPATH set and --disable-perl
[rrdtool.git] / bindings / Makefile.am
index d723caf..e939dc7 100644 (file)
@@ -1,19 +1,15 @@
-SUBDIRS = tcl
-
+SUBDIRS = tcl python
 # the following files are not mentioned in any other Makefile
-EXTRA_DIST = $(shell for A in perl-*; do cat $$A/MANIFEST | sed -e s,^,$$A/, ; done)
+EXTRA_DIST = perl-piped/MANIFEST perl-piped/README perl-piped/Makefile.PL perl-piped/RRDp.pm perl-piped/t/base.t \
+       perl-shared/ntmake.pl perl-shared/MANIFEST perl-shared/README perl-shared/Makefile.PL perl-shared/RRDs.pm  perl-shared/RRDs.xs perl-shared/t/base.t
 
-# lets schedule the perl stuff for installation
-# the special call to install-sh is because the -d switch is not portable
-install-data-local:
-       ../config/mkinstalldirs $(DESTDIR)$(prefix)/lib/perl/auto/RRDs
-       $(INSTALL) -m 644 perl-piped/RRDp.pm $(DESTDIR)$(prefix)/lib/perl
-       $(INSTALL) -m 644 perl-shared/RRDs.pm $(DESTDIR)$(prefix)/lib/perl
-       $(INSTALL) -m 644 perl-shared/blib/arch/auto/RRDs/RRDs.bs $(DESTDIR)$(prefix)/lib/perl/auto/RRDs
-       $(INSTALL) -m 755 perl-shared/blib/arch/auto/RRDs/RRDs.@SO_EXT@ $(DESTDIR)$(prefix)/lib/perl/auto/RRDs
 
 # add the following to the all target
-all-local:      @COMP_PERL@
+all-local:  @COMP_PERL@
+
+install-data-local:
+       test -f perl-piped/Makefile && cd perl-piped && $(MAKE) install || true
+       test -f perl-shared/Makefile && cd perl-shared && $(MAKE) install || true
 
 # rules for building the perl module
 perl_piped: perl-piped/Makefile
@@ -23,13 +19,14 @@ perl-piped/Makefile: perl-piped/Makefile.PL
        cd perl-piped && $(PERL) Makefile.PL $(PERL_MAKE_OPTIONS)
 
 perl_shared: perl-shared/Makefile
-       cd perl-shared && $(MAKE) RPATH=$(prefix)/lib
+       cd perl-shared && $(MAKE) RPATH=$(exec_prefix)/lib
 
 perl-shared/Makefile: perl-shared/Makefile.PL
        cd perl-shared && $(PERL) Makefile.PL $(PERLFLAGS) $(PERL_MAKE_OPTIONS)
+# LIBS="$(LDFLAGS) $(LIBS)" $(PERLFLAGS) $(PERL_MAKE_OPTIONS)
 
 clean-local:
-       cd perl-piped && test -f Makefile && $(MAKE) clean || true
-       cd perl-shared && test -f Makefile && $(MAKE) clean || true
+       test -f perl-piped/Makefile && cd perl-piped && $(MAKE) clean || true
+       test -f perl-shared/Makefile && cd perl-shared && $(MAKE) clean || true
 
 ##END##