if python stuff does not work, do not die, just do not compile python
[rrdtool.git] / bindings / Makefile.am
index 48a7508..f1af1c5 100644 (file)
@@ -1,6 +1,8 @@
-SUBDIRS = tcl 
+SUBDIRS = tcl @PYTHON_DIR@
 # the following files are not mentioned in any other Makefile
-EXTRA_DIST = $(shell for A in perl-*; do cat $$A/MANIFEST | sed -e s,^,$$A/, ; done)
+EXTRA_DIST = perl-piped/MANIFEST perl-piped/README perl-piped/Makefile.PL perl-piped/RRDp.pm perl-piped/t/base.t \
+       perl-shared/ntmake.pl perl-shared/MANIFEST perl-shared/README perl-shared/Makefile.PL perl-shared/RRDs.pm  perl-shared/RRDs.xs perl-shared/t/base.t
+
 
 # add the following to the all target
 all-local:  @COMP_PERL@
@@ -21,6 +23,7 @@ perl_shared: perl-shared/Makefile
 
 perl-shared/Makefile: perl-shared/Makefile.PL
        cd perl-shared && $(PERL) Makefile.PL $(PERLFLAGS) $(PERL_MAKE_OPTIONS)
+# LIBS="$(LDFLAGS) $(LIBS)" $(PERLFLAGS) $(PERL_MAKE_OPTIONS)
 
 clean-local:
        cd perl-piped && test -f Makefile && $(MAKE) clean || true