Big autotool update:
[rrdtool.git] / bindings / Makefile.am
index b76d3a4..f551196 100644 (file)
@@ -1,12 +1,11 @@
 SUBDIRS = tcl
-
 # the following files are not mentioned in any other Makefile
-EXTRA_DIST = `cat perl-*/MANIFEST`
+EXTRA_DIST = $(shell for A in perl-*; do cat $$A/MANIFEST | sed -e s,^,$$A/, ; done)
 
 # lets schedule the perl stuff for installation
 # the special call to install-sh is because the -d switch is not portable
 install-data-local:
-       ../config/mkinstalldirs $(DESTDIR)$(prefix)/lib/perl/auto/RRDs
+       $(mkinstalldirs) $(DESTDIR)$(prefix)/lib/perl/auto/RRDs
        $(INSTALL) -m 644 perl-piped/RRDp.pm $(DESTDIR)$(prefix)/lib/perl
        $(INSTALL) -m 644 perl-shared/RRDs.pm $(DESTDIR)$(prefix)/lib/perl
        $(INSTALL) -m 644 perl-shared/blib/arch/auto/RRDs/RRDs.bs $(DESTDIR)$(prefix)/lib/perl/auto/RRDs
@@ -23,7 +22,7 @@ perl-piped/Makefile: perl-piped/Makefile.PL
        cd perl-piped && $(PERL) Makefile.PL $(PERL_MAKE_OPTIONS)
 
 perl_shared: perl-shared/Makefile
-       cd perl-shared && $(MAKE)
+       cd perl-shared && $(MAKE) RPATH=$(prefix)/lib
 
 perl-shared/Makefile: perl-shared/Makefile.PL
        cd perl-shared && $(PERL) Makefile.PL $(PERLFLAGS) $(PERL_MAKE_OPTIONS)