let the building of the perl extension be more reliable ...
[rrdtool.git] / bindings / perl-shared / Makefile.PL
index e0a4614..516cc39 100644 (file)
@@ -3,15 +3,26 @@ use Config;
 # See lib/ExtUtils/MakeMaker.pm for details of how to influence
 # the contents of the Makefile that is written.
 
-# Specify the location of the archive containing PIC compiled object files.
-my $R = "-R" ;
-
-for ($^O){
-       /linux/ && do{ $R = "-Wl,--rpath -Wl,"};
-       /hpux/  && do{ $R = "+b"};
+# if the last argument when calling Makefile.PL is RPATH=/... and ... is the
+# path to librrd.so then the Makefile will be written such that RRDs.so knows
+# where to find librrd.so later on ... 
+my $R="";
+if ($ARGV[-1] =~ /RPATH=(\S+)/){
+       pop @ARGV;
+       my $rp = $1;
+       for ($^O){
+               /linux/   && do{ $R = "-Wl,--rpath -Wl,$rp"};
+               /hpux/    && do{ $R = "+b$rp"};
+               /solaris/ && do{ $R = "-R$rp"};
+       }
 }
 
-my $librrd = "-L../../src/.libs/ $R\$(RPATH) -lrrd";
+# darwin works without this because librrd contains its
+# install_name which will includes the final location of the
+# library after it is installed. This install_name gets transfered
+# to the perl shared object.
+
+my $librrd = "-L../../src/.libs/ $R -lrrd";
 
 WriteMakefile(
     'NAME'         => 'RRDs',
@@ -22,3 +33,4 @@ WriteMakefile(
     'dynamic_lib'  => {'OTHERLDFLAGS' => "$librrd -lm"},
     'realclean'    => {FILES => 't/demo?.rrd t/demo?.png' }
 );
+