Attached a patch for the rrd-tool LIBDBI integration with the following improvements:
[rrdtool.git] / bindings / perl-shared / Makefile.PL
index 8793dd8..8dd92d6 100644 (file)
@@ -14,6 +14,7 @@ if ($ARGV[-1] =~ /RPATH=(\S+)/){
                /linux/   && do{ $R = "-Wl,--rpath -Wl,$rp"};
                /hpux/    && do{ $R = "+b$rp"};
                /solaris/ && do{ $R = "-R$rp"};
+               /bsd/     && do{ $R = "-R$rp"};
                 /aix/     && do{ $R = "-Wl,-blibpath:$rp"};
        }
 }