redo --disable-* options for python and tcl
[rrdtool.git] / bindings / python / Makefile.am
index bc36b59..ca6f762 100644 (file)
@@ -2,14 +2,17 @@ AM_CPPFLAGS = @CFLAGS@ -I../../src @PYTHON_INCLUDES@
 
 #pythondir = $(pyexecdir)/python@PYTHON_VERSION@/site-packages
 
+if BUILD_PYTHON
+
 python_PROGRAMS = rrdtoolmodule.so
 
 rrdtoolmodule_so_LDFLAGS = -module -shared -L../../src
 rrdtoolmodule_so_LDADD = -lrrd
 rrdtoolmodule_so_SOURCES =     rrdtoolmodule.c
 
-noinst_HEADERS =                rrd_extra.h  \
-                                rrd_format.h
+noinst_HEADERS =                rrd_extra.h
 
 clean:
        rm -rf build
+
+endif