call fpclass only once when replacing isnan for solaris
[rrdtool.git] / debian / rules
index ed736c3..6ddfafe 100755 (executable)
@@ -29,7 +29,7 @@ CFLAGS += -g
 endif
 
 # Whack the flags to compile additional dependent pieces
-CFLAGS += -I/usr/include/libart-2.0 -I/usr/local/include/freetype2
+CFLAGS += -I/usr/include/libart-2.0 -I/usr/include/freetype2
 
 ##NO_TCL CFLAGS += -I/usr/include/tcl8.4
 
@@ -39,6 +39,11 @@ configure-stamp:
        # Make sure we can find tcl stuff (configure won't fail)
        test -f $(tclconfigdir)/tclConfig.sh
 
+       # match the configure script to the build environment, as needed
+       #aclocal
+       #automake
+       #autoconf
+
        # Configure C and Tcl stuff
 ##NO_TCL       CFLAGS="$(CFLAGS)" ./configure --prefix=/usr --enable-shared=yes --enable-static=yes --with-tcllib=$(tclconfigdir) --enable-local-libpng=yes --enable-local-zlib=yes
        CFLAGS="$(CFLAGS)" ./configure --prefix=/usr --enable-shared=yes --enable-static=yes --enable-local-libpng=yes --enable-local-zlib=yes
@@ -102,6 +107,9 @@ install: build-stamp
        mv $(tmp)/usr/share/man/man1/RRDp.1 $(tmp)/usr/share/man/man3/RRDp.3pm
        mv $(tmp)/usr/lib/perl $(tmp)/usr/lib/perl5
 
+       ## trim off the doc sources
+       find $(tmp) -name "*.pod" | xargs rm -f
+
        dh_movefiles
 
 # Build architecture-independent files here.