prepare for the release of rrdtool-1.3.0
[rrdtool.git] / doc / Makefile.am
index a4de36c..16fd617 100644 (file)
@@ -12,7 +12,7 @@ POD = bin_dec_hex.pod        rrddump.pod            rrdgraph_examples.pod  rrdre
       cdeftutorial.pod       rrdfetch.pod           rrdgraph_graph.pod     rrdthreads.pod         rrdxport.pod   \
       rpntutorial.pod        rrdfirst.pod           rrdgraph_rpn.pod       rrdtool.pod                           \
       rrd-beginners.pod      rrdinfo.pod            rrdtune.pod            rrdbuild.pod                          \
-      rrdcgi.pod             rrdgraph.pod           rrdlast.pod                                                  \
+      rrdcgi.pod             rrdgraph.pod           rrdlast.pod            rrdlastupdate.pod                     \
       rrdcreate.pod          rrdgraph_data.pod      rrdresize.pod          rrdtutorial.pod                       
 
 
@@ -24,13 +24,11 @@ HTML = $(POD:.pod=.html) $(PMP:.pod=.html)
 PDF = $(MAN:.1=.pdf)
 
 # what should go into the distribution
-EXTRA_DIST= $(POD) $(HTML) $(TXT) rrdtool-dump.dtd rrdtool-xport.dtd
+EXTRA_DIST= $(POD) $(HTML) $(MAN) $(TXT) rrdtool-dump.dtd rrdtool-xport.dtd
 
-# some install rules if the install pat
-DOCPREFIX:=$(shell echo "@prefix@" | grep rrd >/dev/null && echo "rrdtool-@VERSION@/")
-idocdir = $(prefix)/shared/doc/$(DOCPREFIX)txt
+idocdir = $(RRDDOCDIR)/txt
 idoc_DATA = $(POD) $(TXT)
-ihtmldir = $(prefix)/shared/doc/$(DOCPREFIX)html
+ihtmldir = $(RRDDOCDIR)/html
 ihtml_DATA = $(HTML)
 imandir = $(mandir)/man1
 iman_DATA = $(MAN)
@@ -41,27 +39,24 @@ all-local: link txt man html-local
        perl -n -e 'if (/^=include\s+(\S+)/){open F,"$$1.inc" || die $$?;print <F>; close F} else {print}'  $<  > $@
 
 .pod.1 .pm.1 .pl.1:
-       pod2man --release=$(VERSION) --center=rrdtool $<  > $@
+       @POD2MAN@ --release=$(VERSION) --center=rrdtool $<  > $@
 
 .1.txt:
-       @NROFF@ -man -Tlp $< > $@
+       GROFF_NO_SGR=1 @NROFF@ -man -Tlp $< > $@
 
 .1.pdf:
        @TROFF@ -man $< | ps2pdf - $@
 
 .pm.html .pod.html .pl.html:
-       pod2html --infile=$< --outfile=$@ --noindex --htmlroot=. --podpath=. --title=$*
+       @POD2HTML@ --infile=$< --outfile=$@ --noindex --htmlroot=. --podpath=. --title=$*
 
 RRDs.pod:
-       ln -s $(top_srcdir)/bindings/perl-shared/RRDs.pm RRDs.pod
+       $(LN_S) $(top_srcdir)/bindings/perl-shared/RRDs.pm RRDs.pod
 
 RRDp.pod:
-       ln -s $(top_srcdir)/bindings/perl-piped/RRDp.pm RRDp.pod
+       $(LN_S) $(top_srcdir)/bindings/perl-piped/RRDp.pm RRDp.pod
 
-index.html:
-       rm -f index.html; ln -s rrdtool.html index.html
-
-link: RRDp.pod RRDs.pod index.html
+link: RRDp.pod RRDs.pod
 
 man: $(MAN)
 
@@ -72,3 +67,6 @@ txt: $(TXT)
 pdf-local: $(PDF)
 
 pod: $(POD)
+
+install-data-hook:
+       cd $(DESTDIR)$(ihtmldir) && rm -f index.html && $(LN_S) rrdtool.html index.html