when walking the bytes use the pitch not the width
[rrdtool.git] / doc / Makefile.am
index 4fe8da4..189c5c5 100644 (file)
@@ -1,32 +1,30 @@
 ## Process this file with automake to produce Makefile.in
 
-SUFFIXES = .pod .1 .man .html .txt .pm .pdf .src .inc
+SUFFIXES = .pod .1 .man .html .txt .pm .pdf .inc
 
 #AUTOMAKE_OPTIONS        =  foreign
 
 #ACLOCAL_M4 = $(top_srcdir)/config/aclocal.m4
 
-CLEANFILES = *.1 *.html *.txt *-dircache *.pm *.pdf *~ core *itemcache *.rej *.orig rrdgraph_*.pod *.tmp rrdgraph.pod
+CLEANFILES = *.1 *.html *.txt *-dircache RRD?.pod *.pdf *~ core *itemcache *.rej *.orig *.tmp
 
-SRC = rrdgraph.src rrdgraph_examples.src  rrdgraph_rpn.src \
-      rrdgraph_data.src rrdgraph_graph.src
+POD = bin_dec_hex.pod        rrddump.pod            rrdgraph_examples.pod  rrdrestore.pod         rrdupdate.pod  \
+      cdeftutorial.pod       rrdfetch.pod           rrdgraph_graph.pod     rrdthreads.pod         rrdxport.pod   \
+      rpntutorial.pod        rrdfirst.pod           rrdgraph_rpn.pod       rrdtool.pod                           \
+      rrd-beginners.pod      rrdinfo.pod            rrdtune.pod                                                  \
+      rrdcgi.pod             rrdgraph.pod           rrdlast.pod                                                  \
+      rrdcreate.pod          rrdgraph_data.pod      rrdresize.pod          rrdtutorial.pod                       
 
-POD = rrdtool.pod rrdlast.pod rrdcreate.pod rrdupdate.pod  rrdtutorial.es.pod \
-       cdeftutorial.pod rpntutorial.pod rrdgraph-old.pod  bin_dec_hex.pod \
-       rrdfetch.pod rrdrestore.pod rrddump.pod rrdtune.pod rrdresize.pod \
-       rrdxport.pod rrdcgi.pod rrdtutorial.pod rrdinfo.pod rrdthreads.pod \
-       rrd-beginners.pod \
-       $(SRC:.src=.pod)
 
-PMP = RRDs.pm RRDp.pm
+PMP = RRDs.pod RRDp.pod
 
-MAN = $(POD:.pod=.1) $(PMP:.pm=.1)
+MAN = $(POD:.pod=.1)
 TXT = $(MAN:.1=.txt)
-HTML = $(POD:.pod=.html) $(PMP:.pm=.html)
+HTML = $(POD:.pod=.html) $(PMP:.pod=.html)
 PDF = $(MAN:.1=.pdf)
 
 # what should go into the distribution
-EXTRA_DIST= $(POD) $(HTML) $(TXT)
+EXTRA_DIST= $(POD) $(HTML) $(TXT) rrdtool-dump.dtd rrdtool-xport.dtd
 
 # some install rules
 idocdir = $(prefix)/doc
@@ -53,16 +51,16 @@ all-local: link txt man html-local
 .pm.html .pod.html .pl.html:
        pod2html --infile=$< --outfile=$@ --noindex --htmlroot=. --podpath=. --title=$*
 
-RRDs.pm:
-       ln -s ../bindings/perl-shared/RRDs.pm .
+RRDs.pod:
+       ln -s ../bindings/perl-shared/RRDs.pm RRDs.pod
 
-RRDp.pm:
-       ln -s ../bindings/perl-piped/RRDp.pm .
+RRDp.pod:
+       ln -s ../bindings/perl-piped/RRDp.pm RRDp.pod
 
 index.html:
        rm -f index.html; ln -s rrdtool.html index.html
 
-link: RRDp.pm RRDs.pm index.html
+link: RRDp.pod RRDs.pod index.html
 
 man: $(MAN)
 
@@ -72,3 +70,4 @@ txt: $(TXT)
 
 pdf-local: $(PDF)
 
+pod: $(POD)