Allow to force overwrite when restoring from xml to rrd.
[rrdtool.git] / doc / Makefile.am
index 1515f18..261e8c7 100644 (file)
@@ -6,7 +6,7 @@ SUFFIXES = .pod .1 .man .html .txt .pm .pdf .src .inc
 
 #ACLOCAL_M4 = $(top_srcdir)/config/aclocal.m4
 
-CLEANFILES = *.1 *.html *.txt *-dircache *.pm *.pdf *~ core *itemcache *.rej *.orig
+CLEANFILES = *.1 *.html *.txt *-dircache *.pm *.pdf *~ core *itemcache *.rej *.orig rrdgraph_*.pod
 
 SRC = rrdgraph.src rrdgraph_examples.src  rrdgraph_rpn.src \
       rrdgraph_data.src rrdgraph_graph.src    
@@ -14,7 +14,8 @@ SRC = rrdgraph.src rrdgraph_examples.src  rrdgraph_rpn.src \
 POD = rrdtool.pod rrdlast.pod rrdcreate.pod rrdupdate.pod  rrdtutorial.es.pod \
        cdeftutorial.pod rpntutorial.pod rrdgraph-old.pod  bin_dec_hex.pod \
        rrdfetch.pod rrdrestore.pod rrddump.pod rrdtune.pod rrdresize.pod \
-       rrdcgi.pod rrdtutorial.pod rrdinfo.pod $(SRC:.src=.pod)
+       rrdxport.pod rrdcgi.pod rrdtutorial.pod rrdinfo.pod rrdthreads.pod \
+       $(SRC:.src=.pod)
 
 PMP = RRDs.pm RRDp.pm
 
@@ -57,7 +58,10 @@ RRDs.pm:
 RRDp.pm:
        ln -s ../bindings/perl-piped/RRDp.pm .
 
-link: RRDp.pm RRDs.pm
+index.html:
+       rm -f index.html; ln -s rrdtool.html index.html
+
+link: RRDp.pm RRDs.pm index.html
 
 man: $(MAN)