make MakeMaker work on debian and fix some leftovers from the library rip-out transition
[rrdtool.git] / doc / Makefile.am
index ba22f05..3fc96a4 100644 (file)
@@ -14,7 +14,8 @@ SRC = rrdgraph.src rrdgraph_examples.src  rrdgraph_rpn.src \
 POD = rrdtool.pod rrdlast.pod rrdcreate.pod rrdupdate.pod  rrdtutorial.es.pod \
        cdeftutorial.pod rpntutorial.pod rrdgraph-old.pod  bin_dec_hex.pod \
        rrdfetch.pod rrdrestore.pod rrddump.pod rrdtune.pod rrdresize.pod \
-       rrdcgi.pod rrdtutorial.pod rrdinfo.pod $(SRC:.src=.pod)
+       rrdxport.pod rrdcgi.pod rrdtutorial.pod rrdinfo.pod rrdthreads.pod \
+       $(SRC:.src=.pod)
 
 PMP = RRDs.pm RRDp.pm
 
@@ -34,7 +35,7 @@ ihtml_DATA = $(HTML)
 imandir = $(prefix)/man/man1
 iman_DATA = $(MAN)
 
-all-local: link txt man html
+all-local: link txt man html-local
 
 .src.pod:
        perl -n -e 'if (/^=include\s+(\S+)/){open F,"$$1.inc" || die $$?;print <F>; close F} else {print}'  $<  > $@ 
@@ -58,15 +59,15 @@ RRDp.pm:
        ln -s ../bindings/perl-piped/RRDp.pm .
 
 index.html:
-       rm index.html; ln -s rrdtool.html index.html
+       rm -f index.html; ln -s rrdtool.html index.html
 
 link: RRDp.pm RRDs.pm index.html
 
 man: $(MAN)
 
-html: $(HTML)
+html-local: $(HTML)
 
 txt: $(TXT)
 
-pdf: $(PDF)
+pdf-local: $(PDF)