let 'out-of tree' builds work for everythin but the perl module -- Peter Breitenlohner
[rrdtool.git] / doc / Makefile.am
index e392cfc..a4de36c 100644 (file)
@@ -11,7 +11,7 @@ CLEANFILES = *.1 *.html *.txt *-dircache RRD?.pod *.pdf *~ core *itemcache *.rej
 POD = bin_dec_hex.pod        rrddump.pod            rrdgraph_examples.pod  rrdrestore.pod         rrdupdate.pod  \
       cdeftutorial.pod       rrdfetch.pod           rrdgraph_graph.pod     rrdthreads.pod         rrdxport.pod   \
       rpntutorial.pod        rrdfirst.pod           rrdgraph_rpn.pod       rrdtool.pod                           \
-      rrd-beginners.pod      rrdinfo.pod            rrdtune.pod                                                  \
+      rrd-beginners.pod      rrdinfo.pod            rrdtune.pod            rrdbuild.pod                          \
       rrdcgi.pod             rrdgraph.pod           rrdlast.pod                                                  \
       rrdcreate.pod          rrdgraph_data.pod      rrdresize.pod          rrdtutorial.pod                       
 
@@ -53,10 +53,10 @@ all-local: link txt man html-local
        pod2html --infile=$< --outfile=$@ --noindex --htmlroot=. --podpath=. --title=$*
 
 RRDs.pod:
-       ln -s ../bindings/perl-shared/RRDs.pm RRDs.pod
+       ln -s $(top_srcdir)/bindings/perl-shared/RRDs.pm RRDs.pod
 
 RRDp.pod:
-       ln -s ../bindings/perl-piped/RRDp.pm RRDp.pod
+       ln -s $(top_srcdir)/bindings/perl-piped/RRDp.pm RRDp.pod
 
 index.html:
        rm -f index.html; ln -s rrdtool.html index.html