started change log
[rrdtool.git] / doc / Makefile.am
index 4d7182b..d23f49f 100644 (file)
@@ -6,26 +6,28 @@ SUFFIXES = .pod .1 .man .html .txt .pm .pdf .src .inc
 
 #ACLOCAL_M4 = $(top_srcdir)/config/aclocal.m4
 
-CLEANFILES = *.1 *.html *.txt *-dircache *.pm *.pdf *~ core *itemcache *.rej *.orig rrdgraph_*.pod
+CLEANFILES = *.1 *.html *.txt *-dircache *.pm *.pdf *~ core *itemcache *.rej *.orig rrdgraph_*.pod *.tmp rrdgraph.pod
 
 SRC = rrdgraph.src rrdgraph_examples.src  rrdgraph_rpn.src \
-      rrdgraph_data.src rrdgraph_graph.src    
+      rrdgraph_data.src rrdgraph_graph.src
 
-POD = rrdtool.pod rrdlast.pod rrdcreate.pod rrdupdate.pod  rrdtutorial.es.pod \
-       cdeftutorial.pod rpntutorial.pod rrdgraph-old.pod  bin_dec_hex.pod \
+PODOLD = rrdgraph-old.pod
+
+POD = rrdtool.pod rrdlast.pod rrdfirst.pod rrdcreate.pod rrdupdate.pod  rrdtutorial.es.pod \
+       cdeftutorial.pod rpntutorial.pod rrdthreads.pod bin_dec_hex.pod \
        rrdfetch.pod rrdrestore.pod rrddump.pod rrdtune.pod rrdresize.pod \
-       rrdxport.pod rrdcgi.pod rrdtutorial.pod rrdinfo.pod rrdthreads.pod \
+       rrdcgi.pod rrdtutorial.pod rrdinfo.pod rrdxport.pod rrd-beginners.pod \
        $(SRC:.src=.pod)
 
 PMP = RRDs.pm RRDp.pm
 
-MAN = $(POD:.pod=.1) $(PMP:.pm=.1) 
+MAN = $(POD:.pod=.1) $(PMP:.pm=.1)
 TXT = $(MAN:.1=.txt)
-HTML = $(POD:.pod=.html) $(PMP:.pm=.html) 
+HTML = $(POD:.pod=.html) $(PMP:.pm=.html)
 PDF = $(MAN:.1=.pdf)
 
 # what should go into the distribution
-EXTRA_DIST= $(POD) $(HTML) $(TXT)
+EXTRA_DIST= $(POD) $(HTML) $(TXT) rrdtool-dump.dtd rrdtool-xport.dtd
 
 # some install rules
 idocdir = $(prefix)/doc
@@ -38,7 +40,7 @@ iman_DATA = $(MAN)
 all-local: link txt man html-local
 
 .src.pod:
-       perl -n -e 'if (/^=include\s+(\S+)/){open F,"$$1.inc" || die $$?;print <F>; close F} else {print}'  $<  > $@ 
+       perl -n -e 'if (/^=include\s+(\S+)/){open F,"$$1.inc" || die $$?;print <F>; close F} else {print}'  $<  > $@
 
 .pod.1 .pm.1 .pl.1:
        pod2man --release=$(VERSION) --center=rrdtool $<  > $@