paramters in SHIFT are separated by : like everywhere else
[rrdtool.git] / doc / Makefile.am
index 5f3b815..d23f49f 100644 (file)
@@ -1,37 +1,46 @@
 ## Process this file with automake to produce Makefile.in
 
-SUFFIXES = .pod .1 .man .html .txt .pm .pdf
+SUFFIXES = .pod .1 .man .html .txt .pm .pdf .src .inc
 
 #AUTOMAKE_OPTIONS        =  foreign
 
 #ACLOCAL_M4 = $(top_srcdir)/config/aclocal.m4
 
-CLEANFILES = *.1 *.html *.txt *-dircache *.pm *.pdf *~ core *itemcache *.rej *.orig
+CLEANFILES = *.1 *.html *.txt *-dircache *.pm *.pdf *~ core *itemcache *.rej *.orig rrdgraph_*.pod *.tmp rrdgraph.pod
 
-POD = rrdtool.pod rrdlast.pod rrdcreate.pod rrdupdate.pod  rrdtutorial.es.pod \
-       cdeftutorial.pod rpntutorial.pod rrdgraph.pod  bin_dec_hex.pod \
+SRC = rrdgraph.src rrdgraph_examples.src  rrdgraph_rpn.src \
+      rrdgraph_data.src rrdgraph_graph.src
+
+PODOLD = rrdgraph-old.pod
+
+POD = rrdtool.pod rrdlast.pod rrdfirst.pod rrdcreate.pod rrdupdate.pod  rrdtutorial.es.pod \
+       cdeftutorial.pod rpntutorial.pod rrdthreads.pod bin_dec_hex.pod \
        rrdfetch.pod rrdrestore.pod rrddump.pod rrdtune.pod rrdresize.pod \
-       rrdcgi.pod rrdtutorial.pod rrdinfo.pod
+       rrdcgi.pod rrdtutorial.pod rrdinfo.pod rrdxport.pod rrd-beginners.pod \
+       $(SRC:.src=.pod)
 
 PMP = RRDs.pm RRDp.pm
 
-MAN = $(POD:.pod=.1) $(PMP:.pm=.1) 
+MAN = $(POD:.pod=.1) $(PMP:.pm=.1)
 TXT = $(MAN:.1=.txt)
-HTML = $(POD:.pod=.html) $(PMP:.pm=.html) 
+HTML = $(POD:.pod=.html) $(PMP:.pm=.html)
 PDF = $(MAN:.1=.pdf)
 
 # what should go into the distribution
-EXTRA_DIST= $(POD) $(HTML) $(TXT)
+EXTRA_DIST= $(POD) $(HTML) $(TXT) rrdtool-dump.dtd rrdtool-xport.dtd
 
 # some install rules
 idocdir = $(prefix)/doc
 idoc_DATA = $(POD) $(TXT)
 ihtmldir = $(prefix)/html
 ihtml_DATA = $(HTML)
-imandir = $(prefix)/man/man1
+imandir = $(mandir)/man1
 iman_DATA = $(MAN)
 
-all-local: link txt man html
+all-local: link txt man html-local
+
+.src.pod:
+       perl -n -e 'if (/^=include\s+(\S+)/){open F,"$$1.inc" || die $$?;print <F>; close F} else {print}'  $<  > $@
 
 .pod.1 .pm.1 .pl.1:
        pod2man --release=$(VERSION) --center=rrdtool $<  > $@
@@ -46,18 +55,21 @@ all-local: link txt man html
        pod2html --infile=$< --outfile=$@ --noindex --htmlroot=. --podpath=. --title=$*
 
 RRDs.pm:
-       ln -s ../perl-shared/RRDs.pm .
+       ln -s ../bindings/perl-shared/RRDs.pm .
 
 RRDp.pm:
-       ln -s ../perl-piped/RRDp.pm .
+       ln -s ../bindings/perl-piped/RRDp.pm .
+
+index.html:
+       rm -f index.html; ln -s rrdtool.html index.html
 
-link: RRDp.pm RRDs.pm
+link: RRDp.pm RRDs.pm index.html
 
 man: $(MAN)
 
-html: $(HTML)
+html-local: $(HTML)
 
 txt: $(TXT)
 
-pdf: $(PDF)
+pdf-local: $(PDF)