fix return codes in the error case -- Haroon Rafique <haroon.rafique@utoronto.ca>
[rrdtool.git] / src / Makefile.am
index 804a00b..1f1ff3a 100644 (file)
@@ -84,7 +84,7 @@ rrdupdate_LDADD       = rrdupdate.o librrd.la
 #      -ln -s ${srcdir}/rrdupdate.c rrd_update.c
 
 rrdupdate.o: rrd_update.c
-       $(COMPILE) -DSTANDALONE -c -o $@ $<
+       $(COMPILE) -DSTANDALONE -c -o $@ $^
 
 rrdtool_SOURCES = 
 rrdtool_DEPENDENCIES = rrd_tool.o