rrd_first code contributed by Burton Strauss <Burton@ntopSupport.com>
[rrdtool.git] / src / Makefile.am
index 804a00b..246ef78 100644 (file)
@@ -10,7 +10,7 @@ fonts_DATA = VeraMono.ttf
 
 #INCLUDES = $(CGI_INCLUDES) $(FREETYPE_INCLUDES) $(ART_INCLUDES) \
 #           $(PNG_INCLUDES) $(ZLIB_INCLUDES)
-INCLUDES = -DRRD_DEFAULT_FONT=\"$(fontsdir)/$(fonts_DATA)\"
+AM_CPPFLAGS = -DRRD_DEFAULT_FONT=\"$(fontsdir)/$(fonts_DATA)\"
 
 RRD_C_FILES =          \
        getopt.c        \
@@ -29,6 +29,7 @@ RRD_C_FILES =         \
        rrd_graph.c     \
        rrd_graph_helper.c      \
        rrd_last.c      \
+       rrd_first.c     \
        rrd_open.c      \
        rrd_resize.c    \
        rrd_restore.c   \
@@ -84,7 +85,7 @@ rrdupdate_LDADD       = rrdupdate.o librrd.la
 #      -ln -s ${srcdir}/rrdupdate.c rrd_update.c
 
 rrdupdate.o: rrd_update.c
-       $(COMPILE) -DSTANDALONE -c -o $@ $<
+       $(COMPILE) -DSTANDALONE -c -o $@ $^
 
 rrdtool_SOURCES = 
 rrdtool_DEPENDENCIES = rrd_tool.o