win32 fixes by Stefan . Ludewig . exitgames . com
[rrdtool.git] / src / Makefile.am
index 8a563f5..35ed960 100644 (file)
@@ -58,6 +58,10 @@ noinst_HEADERS = \
        fnv.h rrd_graph.h \
        rrd_is_thread_safe.h
 
+if BUILD_LIBDBI
+RRD_C_FILES += rrd_fetch_libdbi.c
+endif
+
 if BUILD_GETOPT
 noinst_HEADERS += rrd_getopt.h
 UPD_C_FILES += rrd_getopt.c rrd_getopt1.c
@@ -115,5 +119,8 @@ pkgconfig_DATA = librrd.pc
 # strftime is here because we do not usually need it. unices have propper
 # iso date support
 EXTRA_DIST= librrd.pc.in strftime.c strftime.h  rrd_getopt.c rrd_getopt1.c rrd_getopt.h \
-       win32comp.c  rrd_thread_safe_nt.c get_ver.awk librrd.sym
+       win32comp.c  rrd_thread_safe_nt.c get_ver.awk librrd.sym.in.in plbasename.c   plbasename.h   
+
 
+librrd.sym: librrd.sym.in
+       grep -v LIBC_HAS_GETOPT_LONG librrd.sym.in >$@