update timestamp continuity checks in rrd_cached ... allow sub-second precision
[rrdtool.git] / src / Makefile.am
index 05d75b0..5ec27da 100644 (file)
@@ -32,24 +32,27 @@ UPD_C_FILES =               \
        rrd_update.c
 
 RRD_C_FILES =          \
-       hash_32.c       \
-       pngsize.c       \
        rrd_create.c    \
-       rrd_graph.c     \
-       rrd_graph_helper.c      \
+       hash_32.c       \
        rrd_version.c   \
        rrd_last.c      \
        rrd_lastupdate.c        \
        rrd_first.c     \
        rrd_restore.c   \
-       rrd_xport.c     \
-       rrd_gfx.c \
        rrd_dump.c      \
        rrd_flushcached.c \
        rrd_fetch.c     \
        rrd_resize.c \
        rrd_tune.c
 
+if BUILD_RRDGRAPH
+RRD_C_FILES += rrd_graph.c     \
+       rrd_graph_helper.c      \
+       rrd_xport.c     \
+       rrd_gfx.c \
+       pngsize.c
+endif
+
 noinst_HEADERS = \
        unused.h \
         gettext.h \
@@ -77,7 +80,7 @@ lib_LTLIBRARIES           += librrd_th.la
 endif
 
 librrdupd_la_SOURCES      = $(UPD_C_FILES) rrd_not_thread_safe.c
-librrdupd_la_LIBADD       = $(CORE_LIBS) @LIB_LIBINTL@
+librrdupd_la_LIBADD       = $(CORE_LIBS)
 
 librrd_la_SOURCES         = $(RRD_C_FILES)
 librrd_la_DEPENDENCIES    = librrdupd.la librrd.sym