Added configure option to disable building rrd_graph: --disable-rrd_graph. With suppo...
[rrdtool.git] / src / Makefile.am
index 5cfc523..5ec27da 100644 (file)
@@ -32,26 +32,30 @@ UPD_C_FILES =               \
        rrd_update.c
 
 RRD_C_FILES =          \
-       hash_32.c       \
-       pngsize.c       \
        rrd_create.c    \
-       rrd_graph.c     \
-       rrd_graph_helper.c      \
+       hash_32.c       \
        rrd_version.c   \
        rrd_last.c      \
        rrd_lastupdate.c        \
        rrd_first.c     \
        rrd_restore.c   \
-       rrd_xport.c     \
-       rrd_gfx.c \
        rrd_dump.c      \
        rrd_flushcached.c \
        rrd_fetch.c     \
        rrd_resize.c \
        rrd_tune.c
 
+if BUILD_RRDGRAPH
+RRD_C_FILES += rrd_graph.c     \
+       rrd_graph_helper.c      \
+       rrd_xport.c     \
+       rrd_gfx.c \
+       pngsize.c
+endif
+
 noinst_HEADERS = \
        unused.h \
+        gettext.h \
        rrd_getopt.h rrd_parsetime.h \
        rrd_config_bottom.h rrd_i18n.h \
        rrd_format.h rrd_tool.h rrd_xport.h rrd.h rrd_rpncalc.h \
@@ -76,7 +80,7 @@ lib_LTLIBRARIES           += librrd_th.la
 endif
 
 librrdupd_la_SOURCES      = $(UPD_C_FILES) rrd_not_thread_safe.c
-librrdupd_la_LIBADD       = $(CORE_LIBS) @LIB_LIBINTL@
+librrdupd_la_LIBADD       = $(CORE_LIBS)
 
 librrd_la_SOURCES         = $(RRD_C_FILES)
 librrd_la_DEPENDENCIES    = librrdupd.la librrd.sym
@@ -124,4 +128,4 @@ EXTRA_DIST= librrd.pc.in strftime.c strftime.h  rrd_getopt.c rrd_getopt1.c rrd_g
 
 
 librrd.sym: librrd.sym.in
-       grep -v LIBC_HAS_GETOPT_LONG librrd.sym.in >$@
+       $(AM_V_GEN)grep -v LIBC_HAS_GETOPT_LONG librrd.sym.in >$@