* we are now creating true RGBA pngs
[rrdtool.git] / src / Makefile.am
index 804a00b..6f3928c 100644 (file)
@@ -10,7 +10,8 @@ fonts_DATA = VeraMono.ttf
 
 #INCLUDES = $(CGI_INCLUDES) $(FREETYPE_INCLUDES) $(ART_INCLUDES) \
 #           $(PNG_INCLUDES) $(ZLIB_INCLUDES)
-INCLUDES = -DRRD_DEFAULT_FONT=\"$(fontsdir)/$(fonts_DATA)\"
+RRD_DEFAULT_FONT=@RRD_DEFAULT_FONT@
+AM_CPPFLAGS = -DRRD_DEFAULT_FONT=\"$(RRD_DEFAULT_FONT)\"
 
 RRD_C_FILES =          \
        getopt.c        \
@@ -29,6 +30,7 @@ RRD_C_FILES =         \
        rrd_graph.c     \
        rrd_graph_helper.c      \
        rrd_last.c      \
+       rrd_first.c     \
        rrd_open.c      \
        rrd_resize.c    \
        rrd_restore.c   \
@@ -37,9 +39,14 @@ RRD_C_FILES =                \
        rrd_update.c    \
        rrd_xport.c     \
        rrd_nan_inf.c   \
+        art_rgba_rgba_affine.c \
+        art_rgba_svp.c \
+        art_rgb_affine_private.h \
+       art_rgba_rgba_affine.h \
+        art_rgba_svp.h \
        rrd_gfx.c rrd_gfx.h \
        rrd_afm.c rrd_afm_data.c \
-       getopt.h ntconfig.h parsetime.h \
+       getopt.h parsetime.h \
        rrd_format.h rrd_tool.h rrd_xport.h rrd.h rrd_hw.h rrd_rpncalc.h \
        rrd_tool.c \
        rrd_nan_inf.h fnv.h rrd_graph.h rrd_afm.h rrd_afm_data.h \
@@ -84,10 +91,12 @@ rrdupdate_LDADD     = rrdupdate.o librrd.la
 #      -ln -s ${srcdir}/rrdupdate.c rrd_update.c
 
 rrdupdate.o: rrd_update.c
-       $(COMPILE) -DSTANDALONE -c -o $@ $<
+       $(COMPILE) -DSTANDALONE -c -o $@ $^
 
 rrdtool_SOURCES = 
 rrdtool_DEPENDENCIES = rrd_tool.o
 rrdtool_LDADD  = librrd.la
 
-EXTRA_DIST= rrdtool.dsp rrdtool.dsw $(fonts_DATA)
+# strftime is here because we do not usually need it. unices have propper
+# iso date support
+EXTRA_DIST= rrdtool.dsp rrdtool.dsw strftime.c strftime.h $(fonts_DATA)