switched graphics library from arts to cairo+pango
[rrdtool.git] / src / Makefile.am
index 5ed0558..77d9245 100644 (file)
@@ -7,8 +7,10 @@
 fontsdir =  $(datadir)/rrdtool/fonts
 fonts_DATA = DejaVuSansMono-Roman.ttf
 
-#INCLUDES = $(FREETYPE_INCLUDES) $(ART_INCLUDES) \
-#           $(PNG_INCLUDES) $(ZLIB_INCLUDES)
+if STATIC_PROGRAMS
+AM_LDFLAGS = -all-static
+endif
+
 RRD_DEFAULT_FONT=@RRD_DEFAULT_FONT@
 AM_CPPFLAGS = -DRRD_DEFAULT_FONT=\"$(RRD_DEFAULT_FONT)\" -DNUMVERS=@NUMVERS@
 
@@ -30,30 +32,27 @@ RRD_C_FILES =               \
        hash_32.c       \
        pngsize.c       \
        rrd_create.c    \
-       rrd_dump.c      \
-       rrd_fetch.c     \
        rrd_graph.c     \
        rrd_graph_helper.c      \
+       rrd_version.c   \
        rrd_last.c      \
        rrd_lastupdate.c        \
        rrd_first.c     \
-       rrd_resize.c    \
        rrd_restore.c   \
-       rrd_tune.c      \
-       rrd_version.c   \
        rrd_xport.c     \
-        art_rgba_svp.c \
        rrd_gfx.c \
-       rrd_afm.c rrd_afm_data.c \
-       rrd_tool.c
+       rrd_dump.c      \
+       rrd_fetch.c     \
+       rrd_tool.c      \
+       rrd_resize.c \
+       rrd_tune.c
 
 noinst_HEADERS = \
-        art_rgba_svp.h \
        unused.h \
        rrd_gfx.h \
        rrd_getopt.h parsetime.h \
        rrd_format.h rrd_tool.h rrd_xport.h rrd.h rrd_hw.h rrd_rpncalc.h \
-       rrd_nan_inf.h fnv.h rrd_graph.h rrd_afm.h rrd_afm_data.h \
+       rrd_nan_inf.h fnv.h rrd_graph.h \
        rrd_is_thread_safe.h
 
 noinst_LTLIBRARIES        = librrdupd.la