improved handling of library versioning
[rrdtool.git] / src / Makefile.am
index 088de0d..785224e 100644 (file)
@@ -70,44 +70,13 @@ librrdupd_la_LIBADD       = $(CORE_LIBS)
 librrd_la_SOURCES         = $(RRD_C_FILES)
 librrd_la_LIBADD          = librrdupd.la $(ALL_LIBS)
 
-# This flag accepts an argument of the form current[:revision[:age]]. So,
-# passing -version-info 3:12:1 sets current to 3, revision to 12, and age to 1.
-#
-# If either revision or age are omitted, they default to 0. Also note that
-# age must be less than or equal to the current interface number.
-#
-# Here are a set of rules to help you update your library version information:
-#
-#   1. Start with version information of 0:0:0 for each libtool library.
-#
-#   2. Update the version information only immediately before a public
-#   release of your software. More frequent updates are unnecessary, and
-#   only guarantee that the current interface number gets larger faster.
-#
-#   3. If the library source code has changed at all since the last update,
-#   then increment revision (c:r:a becomes c:r+1:a).
-#
-#   4. If any interfaces have been added, removed, or changed since the last
-#   update, increment current, and set revision to 0.
-#
-#   5. If any interfaces have been added since the last public release, then
-#   increment age.
-#
-#   6. If any interfaces have been removed since the last public release,
-#   then set age to 0.
-#
-# Never try to set the interface numbers so that they correspond to the
-# release number of your package. This is an abuse that only fosters
-# misunderstanding of the purpose of library versions. Instead, use the
-# -release flag (see Release numbers), but be warned that every release of
-# your package will not be binary compatible with any other release.
-#
-# see http://www.gnu.org/software/libtool/manual.html#SEC32 for explanation
-librrd_la_LDFLAGS         = -version-info 2:10:0
+# see http://sourceware.org/autobook/autobook/autobook_91.html
+
+librrd_la_LDFLAGS         = -version-info @LIBVERS@
 
 librrd_th_la_SOURCES         = $(UPD_C_FILES) $(RRD_C_FILES) rrd_thread_safe.c
 librrd_th_la_CFLAGS          = $(MULTITHREAD_CFLAGS)
-librrd_th_la_LDFLAGS         = $(MULTITHREAD_LDFLAGS) -version-info 2:10:0
+librrd_th_la_LDFLAGS         = $(MULTITHREAD_LDFLAGS) -version-info @LIBVERS@
 librrd_th_la_LIBADD          = $(ALL_LIBS)
 
 include_HEADERS        = rrd.h