the fonts are now taken from the system. we do not distribute them anympore
[rrdtool.git] / src / Makefile.am
index 43f7ce4..80442ac 100644 (file)
@@ -4,8 +4,6 @@
 #
 #ACLOCAL_M4       = $(top_srcdir)/config/aclocal.m4
 #AUTOHEADER = @AUTOHEADER@ --localdir=$(top_srcdir)/config
-fontsdir =  $(datadir)/rrdtool/fonts
-fonts_DATA = DejaVuSansMono-Roman.ttf
 
 if STATIC_PROGRAMS
 AM_LDFLAGS = -all-static
@@ -19,6 +17,8 @@ UPD_C_FILES =         \
        rrd_getopt1.c   \
        parsetime.c     \
        rrd_hw.c        \
+       rrd_hw_math.c   \
+       rrd_hw_update.c \
        rrd_diff.c      \
        rrd_format.c    \
        rrd_info.c      \
@@ -49,9 +49,9 @@ RRD_C_FILES =         \
 
 noinst_HEADERS = \
        unused.h \
-       rrd_gfx.h \
        rrd_getopt.h parsetime.h \
-       rrd_format.h rrd_tool.h rrd_xport.h rrd.h rrd_hw.h rrd_rpncalc.h \
+       rrd_format.h rrd_tool.h rrd_xport.h rrd.h rrd_rpncalc.h \
+       rrd_hw.h rrd_hw_math.h rrd_hw_update.h \
        rrd_nan_inf.h fnv.h rrd_graph.h \
        rrd_is_thread_safe.h
 
@@ -128,6 +128,6 @@ rrdtool_LDADD       = librrd.la
 
 # strftime is here because we do not usually need it. unices have propper
 # iso date support
-EXTRA_DIST= strftime.c strftime.h $(fonts_DATA) \
+EXTRA_DIST= strftime.c strftime.h \
        win32comp.c  rrd_thread_safe_nt.c get_ver.awk