the fonts are now taken from the system. we do not distribute them anympore
[rrdtool.git] / src / Makefile.am
index 4845a16..80442ac 100644 (file)
@@ -4,19 +4,21 @@
 #
 #ACLOCAL_M4       = $(top_srcdir)/config/aclocal.m4
 #AUTOHEADER = @AUTOHEADER@ --localdir=$(top_srcdir)/config
-fontsdir =  $(datadir)/rrdtool/fonts
-fonts_DATA = DejaVuSansMono-Roman.ttf
 
-#INCLUDES = $(FREETYPE_INCLUDES) $(ART_INCLUDES) \
-#           $(PNG_INCLUDES) $(ZLIB_INCLUDES)
+if STATIC_PROGRAMS
+AM_LDFLAGS = -all-static
+endif
+
 RRD_DEFAULT_FONT=@RRD_DEFAULT_FONT@
 AM_CPPFLAGS = -DRRD_DEFAULT_FONT=\"$(RRD_DEFAULT_FONT)\" -DNUMVERS=@NUMVERS@
 
 UPD_C_FILES =          \
-       getopt.c        \
-       getopt1.c       \
+       rrd_getopt.c    \
+       rrd_getopt1.c   \
        parsetime.c     \
        rrd_hw.c        \
+       rrd_hw_math.c   \
+       rrd_hw_update.c \
        rrd_diff.c      \
        rrd_format.c    \
        rrd_info.c      \
@@ -30,30 +32,27 @@ RRD_C_FILES =               \
        hash_32.c       \
        pngsize.c       \
        rrd_create.c    \
-       rrd_dump.c      \
-       rrd_fetch.c     \
        rrd_graph.c     \
        rrd_graph_helper.c      \
+       rrd_version.c   \
        rrd_last.c      \
        rrd_lastupdate.c        \
        rrd_first.c     \
-       rrd_resize.c    \
        rrd_restore.c   \
-       rrd_tune.c      \
-       rrd_version.c   \
        rrd_xport.c     \
-        art_rgba_svp.c \
        rrd_gfx.c \
-       rrd_afm.c rrd_afm_data.c \
-       rrd_tool.c
+       rrd_dump.c      \
+       rrd_fetch.c     \
+       rrd_tool.c      \
+       rrd_resize.c \
+       rrd_tune.c
 
 noinst_HEADERS = \
-        art_rgba_svp.h \
        unused.h \
-       rrd_gfx.h \
-       getopt.h parsetime.h \
-       rrd_format.h rrd_tool.h rrd_xport.h rrd.h rrd_hw.h rrd_rpncalc.h \
-       rrd_nan_inf.h fnv.h rrd_graph.h rrd_afm.h rrd_afm_data.h \
+       rrd_getopt.h parsetime.h \
+       rrd_format.h rrd_tool.h rrd_xport.h rrd.h rrd_rpncalc.h \
+       rrd_hw.h rrd_hw_math.h rrd_hw_update.h \
+       rrd_nan_inf.h fnv.h rrd_graph.h \
        rrd_is_thread_safe.h
 
 noinst_LTLIBRARIES        = librrdupd.la
@@ -102,11 +101,11 @@ librrd_la_LIBADD          = librrdupd.la $(ALL_LIBS)
 # your package will not be binary compatible with any other release.
 #
 # see http://www.gnu.org/software/libtool/manual.html#SEC32 for explanation
-librrd_la_LDFLAGS         = -version-info 2:9:0
+librrd_la_LDFLAGS         = -version-info 2:99:0
 
 librrd_th_la_SOURCES         = $(UPD_C_FILES) $(RRD_C_FILES) rrd_thread_safe.c
 librrd_th_la_CFLAGS          = $(MULTITHREAD_CFLAGS)
-librrd_th_la_LDFLAGS         = $(MULTITHREAD_LDFLAGS) -version-info 2:8:0
+librrd_th_la_LDFLAGS         = $(MULTITHREAD_LDFLAGS) -version-info 2:99:0
 librrd_th_la_LIBADD          = $(ALL_LIBS)
 
 include_HEADERS        = rrd.h
@@ -129,6 +128,6 @@ rrdtool_LDADD       = librrd.la
 
 # strftime is here because we do not usually need it. unices have propper
 # iso date support
-EXTRA_DIST= strftime.c strftime.h $(fonts_DATA) \
+EXTRA_DIST= strftime.c strftime.h \
        win32comp.c  rrd_thread_safe_nt.c get_ver.awk