The previous code relied on the assumption that pthread_cond_init(&cond)
[rrdtool.git] / src / Makefile.am
index 09bbe86..8a563f5 100644 (file)
@@ -105,12 +105,15 @@ rrdtool_DEPENDENCIES = librrd.la
 rrdtool_LDADD  = librrd.la
 
 rrdcached_SOURCES = rrd_daemon.c
-rrdcached_DEPENDENCIES = librrd.la
+rrdcached_DEPENDENCIES = librrd_th.la
 rrdcached_CPPFLAGS = -DVERSION='"$(VERSION)"' -DLOCALSTATEDIR='"$(localstatedir)"'
-rrdcached_LDADD = librrd.la
+rrdcached_LDADD = librrd_th.la
+
+pkgconfigdir = $(libdir)/pkgconfig
+pkgconfig_DATA = librrd.pc
 
 # strftime is here because we do not usually need it. unices have propper
 # iso date support
-EXTRA_DIST= strftime.c strftime.h  rrd_getopt.c rrd_getopt1.c rrd_getopt.h \
+EXTRA_DIST= librrd.pc.in strftime.c strftime.h  rrd_getopt.c rrd_getopt1.c rrd_getopt.h \
        win32comp.c  rrd_thread_safe_nt.c get_ver.awk librrd.sym