fix from alex
[rrdtool.git] / src / Makefile.am
index 820acf6..9c14263 100644 (file)
@@ -109,8 +109,14 @@ rrdcached_DEPENDENCIES = librrd_th.la
 rrdcached_CPPFLAGS = -DVERSION='"$(VERSION)"' -DLOCALSTATEDIR='"$(localstatedir)"'
 rrdcached_LDADD = librrd_th.la
 
+pkgconfigdir = $(libdir)/pkgconfig
+pkgconfig_DATA = librrd.pc
+
 # strftime is here because we do not usually need it. unices have propper
 # iso date support
-EXTRA_DIST= strftime.c strftime.h  rrd_getopt.c rrd_getopt1.c rrd_getopt.h \
-       win32comp.c  rrd_thread_safe_nt.c get_ver.awk librrd.sym
+EXTRA_DIST= librrd.pc.in strftime.c strftime.h  rrd_getopt.c rrd_getopt1.c rrd_getopt.h \
+       win32comp.c  rrd_thread_safe_nt.c get_ver.awk librrd.sym.in.in
+
 
+librrd.sym: librrd.sym.in
+       grep -v LIBC_HAS_GETOPT_LONG librrd.sym.in >$@