make compilation on older OSX versios work by removing the # from the librrd.sym...
[rrdtool.git] / src / Makefile.am
index 8a563f5..9c14263 100644 (file)
@@ -115,5 +115,8 @@ pkgconfig_DATA = librrd.pc
 # strftime is here because we do not usually need it. unices have propper
 # iso date support
 EXTRA_DIST= librrd.pc.in strftime.c strftime.h  rrd_getopt.c rrd_getopt1.c rrd_getopt.h \
-       win32comp.c  rrd_thread_safe_nt.c get_ver.awk librrd.sym
+       win32comp.c  rrd_thread_safe_nt.c get_ver.awk librrd.sym.in.in
 
+
+librrd.sym: librrd.sym.in
+       grep -v LIBC_HAS_GETOPT_LONG librrd.sym.in >$@