prepare for the release of rrdtool-1.2.20
[rrdtool.git] / src / Makefile.am
index 4b1661f..be51036 100644 (file)
@@ -13,6 +13,8 @@ RRD_DEFAULT_FONT=@RRD_DEFAULT_FONT@
 AM_CPPFLAGS = -DRRD_DEFAULT_FONT=\"$(RRD_DEFAULT_FONT)\" -DNUMVERS=@NUMVERS@
 
 UPD_C_FILES =          \
+       rrd_getopt.c    \
+       rrd_getopt1.c   \
        parsetime.c     \
        rrd_hw.c        \
        rrd_diff.c      \
@@ -25,8 +27,6 @@ UPD_C_FILES =         \
        rrd_update.c
 
 RRD_C_FILES =          \
-       getopt.c        \
-       getopt1.c       \
        hash_32.c       \
        pngsize.c       \
        rrd_create.c    \
@@ -35,6 +35,7 @@ RRD_C_FILES =         \
        rrd_graph.c     \
        rrd_graph_helper.c      \
        rrd_last.c      \
+       rrd_lastupdate.c        \
        rrd_first.c     \
        rrd_resize.c    \
        rrd_restore.c   \
@@ -50,7 +51,7 @@ noinst_HEADERS = \
         art_rgba_svp.h \
        unused.h \
        rrd_gfx.h \
-       getopt.h parsetime.h \
+       rrd_getopt.h parsetime.h \
        rrd_format.h rrd_tool.h rrd_xport.h rrd.h rrd_hw.h rrd_rpncalc.h \
        rrd_nan_inf.h fnv.h rrd_graph.h rrd_afm.h rrd_afm_data.h \
        rrd_is_thread_safe.h
@@ -101,7 +102,7 @@ librrd_la_LIBADD          = librrdupd.la $(ALL_LIBS)
 # your package will not be binary compatible with any other release.
 #
 # see http://www.gnu.org/software/libtool/manual.html#SEC32 for explanation
-librrd_la_LDFLAGS         = -version-info 2:8:0
+librrd_la_LDFLAGS         = -version-info 2:10:0
 
 librrd_th_la_SOURCES         = $(UPD_C_FILES) $(RRD_C_FILES) rrd_thread_safe.c
 librrd_th_la_CFLAGS          = $(MULTITHREAD_CFLAGS)
@@ -129,5 +130,5 @@ rrdtool_LDADD       = librrd.la
 # strftime is here because we do not usually need it. unices have propper
 # iso date support
 EXTRA_DIST= strftime.c strftime.h $(fonts_DATA) \
-       win32comp.c  rrd_thread_safe_nt.c   
+       win32comp.c  rrd_thread_safe_nt.c get_ver.awk