started updating for 1.2 release
[rrdtool.git] / src / Makefile.am
index 246ef78..df9aa94 100644 (file)
@@ -10,7 +10,8 @@ fonts_DATA = VeraMono.ttf
 
 #INCLUDES = $(CGI_INCLUDES) $(FREETYPE_INCLUDES) $(ART_INCLUDES) \
 #           $(PNG_INCLUDES) $(ZLIB_INCLUDES)
-AM_CPPFLAGS = -DRRD_DEFAULT_FONT=\"$(fontsdir)/$(fonts_DATA)\"
+RRD_DEFAULT_FONT=@RRD_DEFAULT_FONT@
+AM_CPPFLAGS = -DRRD_DEFAULT_FONT=\"$(RRD_DEFAULT_FONT)\"
 
 RRD_C_FILES =          \
        getopt.c        \
@@ -40,7 +41,7 @@ RRD_C_FILES =         \
        rrd_nan_inf.c   \
        rrd_gfx.c rrd_gfx.h \
        rrd_afm.c rrd_afm_data.c \
-       getopt.h ntconfig.h parsetime.h \
+       getopt.h parsetime.h \
        rrd_format.h rrd_tool.h rrd_xport.h rrd.h rrd_hw.h rrd_rpncalc.h \
        rrd_tool.c \
        rrd_nan_inf.h fnv.h rrd_graph.h rrd_afm.h rrd_afm_data.h \